These are chat archives for nightscout/intend-to-bolus

7th
Apr 2018
Juan Mejías
@juanjuanmejias_twitter
Apr 07 2018 00:16
Hi everyone. Could someone give me a hand troubleshooting? I'm setting up BT-tethering by following this page of the docs:http://openaps.readthedocs.io/en/latest/docs/Customize-Iterate/bluetooth-tethering-edison.html
It all goes well apparently, but when I get to running this command:
iwconfig wlan0 txpower off; sleep 120; iwconfig wlan0 txpower auto
To disconnect the wifi and connect via Bluetooth
I get this response:
Error for wireless request "Set Tx Power" (8B26) :0; iwconfig wlan0 txpower auto SET failed on device wlan0 ; Input/output error.
And there is no reaction on the phone, as far as I can tell
Previously, when I ran ifconfig bnep0, I got this:
Juan Mejías
@juanjuanmejias_twitter
Apr 07 2018 00:22
Captura de pantalla 2018-04-07 a las 2.21.20.png
Any ideas are welcome
Juan Mejías
@juanjuanmejias_twitter
Apr 07 2018 01:10
I think I may have found the issue
Apparently my phone requires that I turn off Wi Fi completely to allow BT tethering
I guess I'll have to remember to switch off Wi Fi manually when I get out of Wi Fi range
Anyone else has something similar on their phones?
kempera
@kempera
Apr 07 2018 04:33
Dear all, I have apr
Kuss
Martin Haeberli
@mhaeberli
Apr 07 2018 04:47
when mmtune runs, it returns a signal strength - like -99 (horrible) , or -51 (much better). Question is: can the signal strength be easily read, let’s say, on every loop? or does one have to run mmtune ? if the former, I might try to track it more closely.
Scott Leibrand
@scottleibrand
Apr 07 2018 05:07
@ecc1 might know how easy it is to read the rssi during normal pump comms without an mmtune using the new Go based pump comms
Martin Haeberli
@mhaeberli
Apr 07 2018 05:08
@scottleibrand ok thx
LilDucky
@LilDucky
Apr 07 2018 10:01
@ecc1 the captures are in progress. do you need a BG sent from a CNL to the pump too?
and do you want a pump history dump too?
meli9er
@meli9er_twitter
Apr 07 2018 14:34
Hi all! My husband @Tilade set up a wonderful system for me, thanks to all who have made this possible! Now we're looking to become pregnant, and we're looking for related documentation. Where can we find it and/or who can we contact?
Eric
@ecc1
Apr 07 2018 14:55
@LilDucky couldn't hurt to have both of those, thanks. Also a note or description of what showed up on the pump screen and when?
@mhaeberli in the low level code, the rssi is available whenever a packet is received; the only question is whether it gets passed back in a useful way. There's "mdt rssi" in the Go branch that just does one "ping"and reports that rssi
Dana Lewis
@danamlewis
Apr 07 2018 17:09
@meli9er @Tilade no specific documentation related to pregnancy. But there are a few people who've been pregnant & used OpenAPS. (2 have donated data so we can analyze it and see if there are any patterns/things we can learn, but it's early stages and I don't think 2 is enough to assess patterns). But there's a Looping & Pregnancy Fbk group you may want to join for more specific discussions? I think the main thing, though, is understanding your settings and the features you can use, as PWD who are pregnant seem to be making several adjustments a week for settings.
Juan Mejías
@juanjuanmejias_twitter
Apr 07 2018 18:16
Hello everyone, I'm spending the day at my parents' and I've added their wifi to my rig, but it's not connecting. I've accessed their router and it's not appearing in the list of connected devices. I've connected the rig via serial to check the IP and this is what is showing up:
Captura de pantalla 2018-04-07 a las 19.26.34.png
James Babcock
@jimrandomh
Apr 07 2018 18:16
Do other devices you brought connect and get internet access successfully?
Juan Mejías
@juanjuanmejias_twitter
Apr 07 2018 18:17
Yes, my phone connects well
And I just added it
I can't see an IP when running ifconfig. Is that normal?
James Babcock
@jimrandomh
Apr 07 2018 18:19
Generally if you've successfully connected there should be an IP address there
You can try pinging 8.8.8.8 to be sure, but that looks like failure to connect
Juan Mejías
@juanjuanmejias_twitter
Apr 07 2018 18:19
Let me try it again
ping 8.8.8.8 from the rig?
James Babcock
@jimrandomh
Apr 07 2018 18:20
Right
Juan Mejías
@juanjuanmejias_twitter
Apr 07 2018 18:20
OK
One sec
It says Network is unreachable
James Babcock
@jimrandomh
Apr 07 2018 18:22
Double-check the SSID and password, if you haven't already
Juan Mejías
@juanjuanmejias_twitter
Apr 07 2018 18:23
I have, I have. Just did it again
Travis Cannell
@diabeticpilot
Apr 07 2018 18:49
Question on autosens- does autosens throw out data after an SMB? I just turned SMB always off and notice that autosens is working with a lot more data and wonder if that is why.
Scott Leibrand
@scottleibrand
Apr 07 2018 18:53
It doesn’t exclude data just because of a SMB. You can see an x in the autosens log for each data point it excludes. Usually that’s for COB, or for positive deviations after COB.
Travis Cannell
@diabeticpilot
Apr 07 2018 18:56
:+1:
Juan Mejías
@juanjuanmejias_twitter
Apr 07 2018 19:08
These are my latest logs from papertrail. From 11:23 this morning!
Captura de pantalla 2018-04-07 a las 21.07.09.png
Does it mean the system has stopped?
James Babcock
@jimrandomh
Apr 07 2018 19:11
Whether it can loop without internet access depends where it gets its data from. If it's connected to a CGM receiver by USB, it can keep looping, and you've only lost the ability to monitor it. If it gets CGM via Dexcom Share or something like that, it'll stop looping.
Juan Mejías
@juanjuanmejias_twitter
Apr 07 2018 19:12
No, it doesn't loop without internet as of now. But it's not looking for wifis anymore, is it?
What should I do in this case?
James Babcock
@jimrandomh
Apr 07 2018 19:13
Do you have a phone that you could try setting up tethering to?
That would solve the immediate problem, and also give you a solution for when you're out in random places with no wifi
Juan Mejías
@juanjuanmejias_twitter
Apr 07 2018 19:14
I was aware that the loop wasn't working by the way, I just want to know if it's still trying to reconnect or I have to do something to prompt it
Yes, in fact I' trying to setup a wi fi hotspot right now
The BT one gave me issues :worried:
James Babcock
@jimrandomh
Apr 07 2018 19:15
I believe it attempts to establish a connection once per minute on a timer
Juan Mejías
@juanjuanmejias_twitter
Apr 07 2018 19:16
OK, but it doesn't show on papertrail then
James Babcock
@jimrandomh
Apr 07 2018 19:16
(That's the oref0-online.sh script, which writes to /var/log/openaps/network.log)
Juan Mejías
@juanjuanmejias_twitter
Apr 07 2018 19:19
OK, I'm not sure if that shows in papertrail
Re the hotspot, I've added the network details. Do I need to do anything else?
James Babcock
@jimrandomh
Apr 07 2018 19:19
Try connecting a laptop to the hotspot and see if that works
Juan Mejías
@juanjuanmejias_twitter
Apr 07 2018 19:23
I've rebooted the rig to see if that helped, and after rebooting it's given me this: Rebooting to fix radio errors!
Captura de pantalla 2018-04-07 a las 21.23.25.png
Yes, I just connected my laptop and it works well
Juan Mejías
@juanjuanmejias_twitter
Apr 07 2018 19:32
Any ideas what to check? It doesn't connect to the home Wi Fi or the Wi Fi hotspot
James Babcock
@jimrandomh
Apr 07 2018 19:33
The "Rebooting to fix radio errors!" message is actually about communication with the pump, not with wifi
Juan Mejías
@juanjuanmejias_twitter
Apr 07 2018 19:34
Ok, I thought so, but just in case. That's one more issue for later :smile:
James Babcock
@jimrandomh
Apr 07 2018 19:35
Paste a copy of /etc/wpa_supplicant/wpa_supplicant.conf ? (Feel free to edit out the passwords)
Juan Mejías
@juanjuanmejias_twitter
Apr 07 2018 19:35
Yes, one sec
Captura de pantalla 2018-04-07 a las 21.35.48 copia.png
There are a few templates for new networks
Juan Mejías
@juanjuanmejias_twitter
Apr 07 2018 19:50
at the bottom
James Babcock
@jimrandomh
Apr 07 2018 19:51
The "mi red" network has a non-ASCII character in its password; that's very likely to cause problems
Which one is the house wifi that's not working, which is the phone hotspot?
Also try removing the spaces around = signs
Juan Mejías
@juanjuanmejias_twitter
Apr 07 2018 20:02
OK, I'm on it. The ones with visible passwords are all templates to use in the future, but I guess those can cause trouble too. I'll edit everything anyway
Juan Mejías
@juanjuanmejias_twitter
Apr 07 2018 20:11
Captura de pantalla 2018-04-07 a las 22.09.34 copia.png
Done :smile:
I've pinged 8.8.8.8 again, but it's still Network is unreachable
Juan Mejías
@juanjuanmejias_twitter
Apr 07 2018 20:23
Which one is the house wifi that's not working, which is the phone hotspot?
Sorry, I missed that. The home network is MOVISTAR_89BB
The hotspot is LGK10_WIFI
fidoman
@efidoman
Apr 07 2018 21:28
About 4 days now on fiasp/novolog 50/50. Verdicts still out because it's early but I'm impressed so far with the results. In the first couple of days, I did notice that BG levels would stay "higher" at times. So, I did lower ISF from 60 to 45 and CR from 16 to 12. It seems more insulin is necessary but once I did these changes if I set a low target and announce carbs, I don't have to manual meal bolus so far. SMB takes care of it nicely. Post-meal glucose seems to peak around 150 and then head back down to normal range. No problems with lows so far either. I am using the ultra-rapid curve and I'm changing the infusion set site location every 48 hours. I did that most of the time before fiasp because I use sure-T and re-use the catheter a few times before swapping sets.
James Babcock
@jimrandomh
Apr 07 2018 22:33
Why mix fiasp 50-50 with novolog rather than use fiasp alone?
fidoman
@efidoman
Apr 07 2018 22:48
Seems the vitamin b12 additive is enough to support twice the insulin with the same faster action based on what I've read. Also, I have a lot of Novolog and insurance will not cover fiasp yet. :smile:
James Babcock
@jimrandomh
Apr 07 2018 23:04
How much does self-pay Fiasp cost?
(Seeing my endo in ~1month, plan to ask for it, I anticipate insurance might be a problem. Wondering if something wacky like "fiasp plus lantus pens" might make sense)
fidoman
@efidoman
Apr 07 2018 23:14
Self pay is about $370 per vial if I went to Walgreens. You can get $100 off that and get it down to about $270 per vial if you fill out a novolog savings card. However, I just asked my end for a paper prescription, took a picture of it and ordered from Mark's pharmacy for $70 per vial. They called me back within minutes and shipped it quickly. It arrived within 2 business days in my case.
And if you live near Canada, just drive up there and it'll probably just cost $30/vial. I can't for the life of me understand why/how Canada can get the exact same drug for less than 1/10th of the cost that we pay here in the US.
James Babcock
@jimrandomh
Apr 07 2018 23:17
They're able to do that because pharmacies are legally forbidden from importing the vials on your behalf
That... might actually be worth me making a trip to Canada for