These are chat archives for nightscout/intend-to-bolus

25th
Apr 2018
Michael Lawley
@lawley
Apr 25 2018 02:23
more news on the WiFi issues I'm having - sitting the rig right next to the wireless router shows both 5GHz and 2.4GHz network SSIDs and a successful connection to the 2.4GHz one; looks like the Edison (?) is having trouble with picking up the signal
Michael Lawley
@lawley
Apr 25 2018 02:31
Problem diagnosed - I have an EDI2.SPOF, not an EDI2.SPON
James Babcock
@jimrandomh
Apr 25 2018 02:32
SPOF is the version with the antenna missing. I believe the docs have some info on how to make an external antenna, if you want to go that route.
James Babcock
@jimrandomh
Apr 25 2018 02:51
If people have Medtronic pumps lying around with missing stickers or broken buttons, they're repairable; I just tried it on a demo pump. The dome switches are https://www.digikey.com/product-detail/en/keystone-electronics/5133TR/36-5133CT-ND/6834345; almost any glue-backed plastic will do for the layer above that, I used https://www.digikey.com/product-detail/en/keystone-electronics/5200/36-5200-ND/6834332 .
Dana Lewis
@danamlewis
Apr 25 2018 02:54
Yay, glad that worked.
Can you pr that to the docs somewhere when you get a chance?
James Babcock
@jimrandomh
Apr 25 2018 02:55
Yep, working on a more detailed writeup of how to do it
Dana Lewis
@danamlewis
Apr 25 2018 02:55
Thx :smile:
Michael Lawley
@lawley
Apr 25 2018 04:05
Thx @jimrandomh - I recall looking carefully at part nos etc when originally ordering for exactly that reason (docs are clear about this). I can only surmise that I had a brain fade when it came to clicking the Buy button, or I had the wrong browser tab open, or it was due to (lack of) availability. Now have external antenna on order; current docs only really mention external antenna for the Explorer Block
hotelmama
@hotelmama
Apr 25 2018 09:35
I am still trying to restore bluetooth tethering with my rig. reinstalled oref0, redid the bonding with my samsung 7 edge, tested if it worked, but the terminal said the following: sudo bt-pan client AC:5F:3E:DB:C5:46
Traceback (most recent call last):
File "/usr/local/bin/bt-pan", line 228, in <module>
if name == 'main': sys.exit(main())
File "/usr/local/bin/bt-pan", line 188, in main
dev_remote = find_device(opts.remote_addr, devs.values()[0])
File "/usr/local/bin/bt-pan", line 53, in find_device
return find_device_in_objects(get_manager().GetManagedObjects(), device_address, adapter_pattern)
File "/usr/local/bin/bt-pan", line 68, in find_device_in_objects
raise BTError('Bluetooth device not found')
main.BTError: Bluetooth device not found - any ideas? Could it be a hardware thing? Could bluetooth on the edison still not work, even if the rig is visible as bonded in my phone? Thanks for any ideas!
John Benjamin
@Bender1061
Apr 25 2018 14:42
@jimrandomh Thank you for those links, I have a button that I keep repairing, and that is going to help me alot!
Martin Haeberli
@mhaeberli
Apr 25 2018 16:59
question re spontaneous shutdowns and identifying root cause - edison/explorer charging safe and stable on desk, charging light remains on, but Edison turned itself off. where might I look in logs?
James Babcock
@jimrandomh
Apr 25 2018 17:01
Run "dmesg" and see what's there just before the time it did that
Martin Haeberli
@mhaeberli
Apr 25 2018 17:02
k thx @jimrandomh
James Babcock
@jimrandomh
Apr 25 2018 17:02
Off until you did something to bring it back up, or off-and-then-reboot?
Martin Haeberli
@mhaeberli
Apr 25 2018 17:02
off until noticed, then on button pressed
I assume reboots should also show in the log?
I’ll go try to ‘snarf’ the logs now
(remote, tunnel, etc)
James Babcock
@jimrandomh
Apr 25 2018 17:04
Spontaneous power off might leave something in the log, or might not; if power gets interrupted somehow, for example, it can't write anything.
Is this happening repeatedly? And, what's its power source?
Martin Haeberli
@mhaeberli
Apr 25 2018 17:07
power source is canakit style rpi / android compatible wall wart
James Babcock
@jimrandomh
Apr 25 2018 17:08
It's probably not that, but temporarily switching wall wart is super easy so might as well just in case
Martin Haeberli
@mhaeberli
Apr 25 2018 17:08
k i’ll suggest
also hard to understand how a charger failure when battery is near full causes edison proper to shut down ...
Scott Leibrand
@scottleibrand
Apr 25 2018 17:12
check that the JST and Edison to EB connections are solid, too
Doug
@dougboss
Apr 25 2018 20:21
I enter carbs via either pump wizard or Ifttt button but it appears that the openaps pill shows zero COB ... as of now should be 30 or 40 .. any idea where it went ?
Dana Lewis
@danamlewis
Apr 25 2018 20:25
how did you enter carbs today? if bolus wwizard, did you include a bolus?
Doug
@dougboss
Apr 25 2018 20:30
i entered some from the ifttt button and some different from the wizard on the pump ... none are showing in COB in APS pill. And jst removed the COB from the heroku enable line
Dana Lewis
@danamlewis
Apr 25 2018 20:30
you need at least a .1 bolus for carbs in the wizard to show up in OpenAPS
not sure why your IFTTT ones aren't showing; can you check your IFTTT button to confirm that it activated successfully?
Doug
@dougboss
Apr 25 2018 20:32
i entered 45 g carbs via the wizard and delivered its calculated amount, and 15 via the ifttt button. The entries show in NS on the time line just not in COB
Dana Lewis
@danamlewis
Apr 25 2018 20:33
can you confirm that ifttt received the button press? (check the iftt log)
Doug
@dougboss
Apr 25 2018 20:33
i see the iftttt entry in nightscout time line ... Ill check log
Dana Lewis
@danamlewis
Apr 25 2018 20:33
ok if it's in NS it went through. can you confirm cob has never shown up in OpenAPS logs?
Doug
@dougboss
Apr 25 2018 20:34
Applet ran
Apr 25 - 1:44 PM
where is best place to check the openaps logs
Scott Leibrand
@scottleibrand
Apr 25 2018 20:35
You can press “l” (lowercase L) to see pump-loop.log in real time
Scott Leibrand
@scottleibrand
Apr 25 2018 20:36
Or less -R /var/log/openaps/pump-loop.log to see the whole thing
Doug
@dougboss
Apr 25 2018 20:45
Duh, Doug Look in Papertrail ... looks like the issue is the COB decay is way too fast ... 12:51pm COB:42 13:05pm COB 30 13:39pm COB:4 checking the DIA ... I changed it from 5 to 6 today on the pump so it shouldnt decay that fast
Scott Leibrand
@scottleibrand
Apr 25 2018 20:46
COB decay doesn’t depend on DIA
Are you running autotune?
Doug
@dougboss
Apr 25 2018 20:47
then Im confused - yes running autotune
Scott Leibrand
@scottleibrand
Apr 25 2018 20:47
Does it recommend any changes in CR?
Doug
@dougboss
Apr 25 2018 20:48
yes pump CR is 6 and autotune suggests 4.2 ... I havent adjusted the pump recently due to topical steroid use
Scott Leibrand
@scottleibrand
Apr 25 2018 20:56
if your CR is too weak (high), then OpenAPS will only be expecting a small increase in BG as all the carbs absorb. once it sees BG increase that much (relative to the expected drop from insulin activity) it will consider the COB fully decayed to zero
Doug
@dougboss
Apr 25 2018 20:57
and to help that I need to adjust the CR to the autotune number ?
Scott Leibrand
@scottleibrand
Apr 25 2018 20:59
well, if you're running autotune on the rig, OpenAPS is using the autotuned number already. the question is whether that number is still too high, possibly because it's restricted by your autosens_max (default 1.2) from tuning it down further
Doug
@dougboss
Apr 25 2018 21:00
ok makes sense ... Ive adjusted the pump ..
May also adjust the autosense_max