These are chat archives for nightscout/intend-to-bolus

26th
Apr 2018
Cfomodz
@Cfomodz
Apr 26 2018 13:27
What would be causing a OpenAPS ⚠unknown on NS if it is looping and sending BGs via xdrip-js to NS, so I know the rig is connected to the internet and the pump.
Jon Cluck
@cluckj
Apr 26 2018 14:46
check /var/log/openaps/ns-loop.log?
HebertPin
@HebertPin
Apr 26 2018 15:30

Hello. How are you? I am new to the group, I am writing from Uruguay
Maybe help me with the problem I'm having. I'm doing
a loop and it does not work, I do not understand the problem for which it does not do well.
I am using an Edison board, a Metronic 715 pump, G5 sensor and Nightscout.
If you need more data, tell me and I send them.
I detail below what tells me that the bond is capable of helping me.
thank you very much

Starting oref0-pump-loop at Wed Apr 25 12:52:02 -03 2018 with 3 second wait_for_silence:
Waiting up to 4 minutes for new BG: ls: cannot access /tmp/pump_loop_completed: No such file or directory
Radio ok. Listening: .No interfering pump comms detected from other rigs (this is a good thing!)
Preflight OK. Old settings: AssertionError
ls: cannot access settings/profile.json: No such file or directory
Profile invalid: ls: cannot access settings/profile.json: No such file or directory
AssertionError
Couldn't refresh_old_profile
oref0-pump-loop failed. pump_loop_completed more than 15m old; waiting for 40s silence before mmtuning
Radio ok. Listening: .No interfering pump comms detected from other rigs (this is a good thing!)
Listening for 40s silence before mmtuning: .No interfering pump comms detected from other rigs (this is a good thing!)
mmtune: "916.684", 5, -51 No wait required.
Unsuccessful oref0-pump-loop at Wed Apr 25 12:54:06 -03 2018
grep: monitor/temp_basal.json: No such file or directory

ArvoNiilo
@ArvoNiilo
Apr 26 2018 15:32
Is there any explanation for that when I log in to my rig through with ssh through wifi I get in but the rig rejects the same correct password when I try to log in through the USB cables? This means I cannot give the name and password of hotel eyc wifi networks.
Eric
@ecc1
Apr 26 2018 15:39
When you use ssh, does it prompt for a login password, or have you set up a public/private key pair for ssh?
Try logging in with ssh, then do "passwd" to change the password to something else
Scott Leibrand
@scottleibrand
Apr 26 2018 17:56
@ArvoNiilo are you logging in with the same username as well as the same password?
@HebertPin it looks like that AssertionError message is the problem, but not all of the details are making it to that log. Have you looped successfully with this rig in the past? if so, how long have you been looping? which version/branch of oref0 are you using?
Martin Haeberli
@mhaeberli
Apr 26 2018 18:20
20180426etghopenaps.png
question here is - overnight - target is pump target 120 - CGM readings hovering around 100. But on a small rise, zero temp canceled, even brief high temps. Is there some way to prevent this below a given CGM reading? (needed to intervene when sudden drop from 100 to about 70 - hard to tell even what caused the sudden drop. she assures us it was NOT a compression low…) [also wondering whether other parameters need to be tuned. DIA? - she was running negative IOB for a while but not coming back up…]
James Babcock
@jimrandomh
Apr 26 2018 18:40
@mhaeberli Zoom that graph out a bit? It looks like there's a meal close enough to that for the meal and its insulin to still be having an impact.
Martin Haeberli
@mhaeberli
Apr 26 2018 18:50
detail.png
James Babcock
@jimrandomh
Apr 26 2018 18:51
Was that sensor pre-soaked? And, what brand is it?
Martin Haeberli
@mhaeberli
Apr 26 2018 18:51
@jimrandomh 16 grams carbs added via IFTTT announcement 00:30. but note that in theory, the SMB insulin that followed the announcement likely still hadn’t aged out, even though the IOB was theoretically negative
no. Dexcom G5. calibrated around 21:00 last night (all times local)
James Babcock
@jimrandomh
Apr 26 2018 18:52
At 4am I see the sensor detecting a low, a fingerstick recorded and the low isn't real
Martin Haeberli
@mhaeberli
Apr 26 2018 18:52
that’s one way to read the record.
James Babcock
@jimrandomh
Apr 26 2018 18:52
Or alternatively there were rescue carbs that weren't entered, and the fingerstick is after those carbs have had an impact
Hmm
Martin Haeberli
@mhaeberli
Apr 26 2018 18:53
another way to read the record: she woke up near 77 or 71 say 20 minutes before the fingerstick, felt low, added rescue carbs (juice and bar) that weren’t recorded on purpose
indeed, as you say
not recorded on purpose because we didn’t want too aggressive treatments while still sleeping
also used high target after rescue carbs
James Babcock
@jimrandomh
Apr 26 2018 18:54
I think the recommended way to handle that is to enter the rescue carbs, and only use high targets for controlling aggressiveness
Martin Haeberli
@mhaeberli
Apr 26 2018 18:55
:+1:
the meta - question is - how to prevent some of the non-zero temps in the 90 minutes or so leading up to the low
given target was 120
almost like we’d like an optional rule - IF ‘sleeping’ (defined as time range) and more than 10 below target, then don’t temp basal unless we have announced carbs…)
Martin Haeberli
@mhaeberli
Apr 26 2018 19:00
@jimrandomh why did you happen to ask about sensor soaking?
James Babcock
@jimrandomh
Apr 26 2018 19:01
First screenshot shows a sensor age of 8h, which is young enough that an unsoaked sensor might have accuracy problems
Fingersticks don't seem to be far off the CGM readings, though, so it's probably not that
Dana Lewis
@danamlewis
Apr 26 2018 19:02
Remidner: we are nearing release of 0.6.1 to master. But we need testers to confirm readiness! Please grab a fresh dev, and please comment on the PR (openaps/oref0#816) with your setup details (pump, rig type, time zone, etc) and :+1: if all is well or let us know here if something isn't working so we can fix it.
Scott Leibrand
@scottleibrand
Apr 26 2018 19:03
@mhaeberli with a target of 120, a BG of 103 isn't low enough to force a zero temp when eventualBG is above target
that's because we don't want to cause too big of a rebound when the zero temps kick in and BG starts rising
there is a threshold below which we do LGS almost no matter what, but it's probably closer to 80 than 100 when target is 120.
Martin Haeberli
@mhaeberli
Apr 26 2018 19:07
@scottleibrand thx … in this case, it almost ‘feels’ like just a small amount of variance / noise in the sensor caused the eventual to rise above target, so then high temp, … It’s almost like even long negative IOBs don’t necessarily result in ACTUAL rises even if predicted to do so. -a ) is there a way to over-ride that threshold? ; b ) are there other parameters we’re missing? like maybe tweak DIA? she’s been trying to tweak carb ratios and basals per autotune to balance things out ...
see a DM coming
Scott Leibrand
@scottleibrand
Apr 26 2018 19:08
I would check whether your basal might still be too high before/during that timeframe
Martin Haeberli
@mhaeberli
Apr 26 2018 19:09
@scottleibrand DM sent
Scott Leibrand
@scottleibrand
Apr 26 2018 19:11
we also might want to talk about expectations. with a 120 target, you should expect BG to mostly stay above 80, but I wouldn't expect it to keep BG above 100, simply because low temps don't work fast enough.
Martin Haeberli
@mhaeberli
Apr 26 2018 19:11
autotune actually recommending higher basals than set:
12:00        | 1.650    | 1.553    
  12:30        | 1.65     |          
  13:00        |          | 1.800    
  13:30        |          |          
  14:00        |          | 1.962    
  14:30        |          |          
  15:00        |          | 1.926    
  15:30        | 1.6      |          
  16:00        |          | 1.823    
  16:30        |          |          
  17:00        |          | 1.872    
  17:30        |          |          
  18:00        |          | 1.772    
  18:30        |          |          
  19:00        |          | 1.721    
  19:30        |          |          
  20:00        |          | 1.629    
  20:30        | 1.4      |          
  21:00        |          | 1.560    
  21:30        |          |          
  22:00        |          | 1.636    
  22:30        | 1.4      |          
  23:00        |          | 1.643    
  23:30        |          |
Scott Leibrand
@scottleibrand
Apr 26 2018 19:11
and CR?
Martin Haeberli
@mhaeberli
Apr 26 2018 19:12
(excerpt obviously) - :+1: as to expectations
Parameter      | Pump     | Autotune 
-------------------------------------
ISF [mg/dL/U]  | 45.000   | 51.059   
Carb Ratio[g/U]| 6.500    | 5.933
these recs are a bit dated but give you an idea. I’ll pull fresh recs now. btw, running autotune on both overnight rigs but both rigs are not with her all day and I’m not yet benefiting from your rsync advice.
Scott Leibrand
@scottleibrand
Apr 26 2018 19:13
ok, those all look pretty close, so I don't think settings are far off
Martin Haeberli
@mhaeberli
Apr 26 2018 19:13
so she had had some autotune guidance to go as far s 5.3
she tried that, decided it was WAY too far (too much roller-coaster) and we discussed moving in half-steps towards recs on CR
Scott Leibrand
@scottleibrand
Apr 26 2018 19:14
:+1:
Martin Haeberli
@mhaeberli
Apr 26 2018 19:14
actual CRs in Pump have about 3 settings.
k thx
James Babcock
@jimrandomh
Apr 26 2018 19:14
Increasing your ISF (as autotune recommends) may make it a bit less rollercoaster -- part of the problem in those graphs looks like overcorrections
Martin Haeberli
@mhaeberli
Apr 26 2018 19:15
anyway, any magic parameter besides code changes to say: no carbs on board, if below 90 (or 100, or something, no high-temps, or no temps above 1/2 pump setting, or whatever?
@jimrandomh :+1: good idea, I’ll recommend
Scott Leibrand
@scottleibrand
Apr 26 2018 19:19
@mhaeberli the only way to do that without code changes is to set a higher target
// min_bg of 90 -> threshold of 65, 100 -> 70 110 -> 75, and 130 -> 85
Martin Haeberli
@mhaeberli
Apr 26 2018 19:22
:+1:
HebertPin
@HebertPin
Apr 26 2018 22:54
@scottleibrand How are you? Thank you very much for your answer. With this pump and plate Edison is the first loop I try to do and I can not solve the problem, but I made another one a while ago with other pieces for a friend and it worked perfectly.
Since yesterday he is looping with the same mistake that happens.
The version is oref0@0.6.0
The branch is the * master
Can I give you some more information to help me?
Thank you
HebertPin
@HebertPin
Apr 26 2018 23:06
@scottleibrand Thanks, I will follow these steps and anything will bother me again. Regards
Tore Bjørndalen
@BjoTore_twitter
Apr 26 2018 23:45
@jimrandomh I just had the same happening to me, the giant boluses all over the place in NS.
Did you find out anything?
Those giant boluses are actually reported by NS and originates from the the pump.
Tore Bjørndalen
@BjoTore_twitter
Apr 26 2018 23:51
Still having problems after midnight. IOB=0 Pump history mismatch etc. I need to figure out this tomorrow.
Bolus NS.JPG
Jon Cluck
@cluckj
Apr 26 2018 23:57
lol, wow