These are chat archives for nightscout/intend-to-bolus

11th
May 2018
Ryan Dalisky
@rdalisky
May 11 2018 01:05
Hey all, switched to the 670g as required by my endocrinologist. Not happy with it, and have been away from looping for a while. What’s the best setup for ease of use, as well as offline looping ? I currently have a 723 and the latest explorer board, and am able to get a dexcom if it is the best to use. Thanks!
I guess I should add that I was using enlisted sensors before with OpenAPS, and I liked having to carry minimal equipment. I always have a cell phone on me,and tethering is not an issuer
*enlite
Dana Lewis
@danamlewis
May 11 2018 02:29
I'd recommend dexcom using xdrip-js on the rig if you prefer less stuff. @tynbendad has been pleased with this setup for offline looping. (With Edison and explorer board)
RBJervey
@RBJervey
May 11 2018 13:26
Hi, I have a quick question and if this isn't the right board for it please let me know where to go! A couple of days ago I noticed that most of my insulin delivery via my pump no longer shows on NightScout. The treatment is in the reports, it's included in the IOB, but in the graph it doesn't show as any insulin delivered. I have seen it show SMB delivery but bolus wizard or quick bolus boluses aren't showing (the carbs entered in the bolus wizard are though). Any idea how to fix this?
This is for version 0.10.2-release-20171201
sooperlooper
@sooperlooper
May 11 2018 21:26
IMG_2651.jpg
did it let me go low because of sensor noise? the sensor is about 20 days old..
Screen Shot 2018-05-11 at 2.29.54 PM.png
garykidd
@garykidd
May 11 2018 21:50
Has there been any changes to the logic whereby manually entered carbs on pump are ignored? If not, might that be an area that could be made into an toggle option of sorts?
Scott Leibrand
@scottleibrand
May 11 2018 21:53
Yes, but since when do you mean?
@sooperlooper how does the total insulin delivered over those 4 hours (subtract the reservoir values) compare to your normal (and auto tuned) basals? What did the OpenAPS pill say about sensitivityRatio?
garykidd
@garykidd
May 11 2018 22:02
i was 25 commits behind on dev on 1 rig and I think 42 behind on the other---can youpoint me a bit as to where I can read more about it? thx
hmmm...first rig update to latest dev worked great. #2 (blue)...did this...
/root/src/oref0/ already exists; pulling latest
fatal: No remote repository specified.  Please, specify either a URL or a
remote name from which new revisions should be fetched.
Couldn't pull latest oref0
while running
bash ~/myopenaps/oref0-runagain.sh
garykidd
@garykidd
May 11 2018 22:08
ok, so stepping back a little...
root@BLUE:~/src/oref0# cd ~/src/oref0 && git checkout dev && git pull
error: pathspec 'dev' did not match any file(s) known to git.
Martin Haeberli
@mhaeberli
May 11 2018 22:29
Screen Shot 2018-05-11 at 15.27.11.png
why did this go from zero-temp to non-zero temp? ...
Scott Leibrand
@scottleibrand
May 11 2018 22:32
because the temp basal it read from pumphistory didn't match what it read from the pump. in later versions we've changed the way it deals with that error condition to not cancel zero temps
Martin Haeberli
@mhaeberli
May 11 2018 22:32
k cool - (another openaps instance had been running but battery on that one just went to zero / shutdown) - so 0.6.1 dev should be better?
Scott Leibrand
@scottleibrand
May 11 2018 22:33
I don't remember whether that change is in 0.6.1 or 0.7.0
Martin Haeberli
@mhaeberli
May 11 2018 22:33
np
Scott Leibrand
@scottleibrand
May 11 2018 22:33
it should be a transient thing: it should immediately set a new zero temp as soon as it sees its neutral temp in pumphistory
Martin Haeberli
@mhaeberli
May 11 2018 22:33
btw, is it still worth us regressing 0.6.1 (on a 723) or should we just wait for formal release
Scott Leibrand
@scottleibrand
May 11 2018 22:34
never hurts to get started testing sooner if you're ready
release could be as soon as Sunday, but the more testing we get before then the better
Martin Haeberli
@mhaeberli
May 11 2018 22:34
k thx
garykidd
@garykidd
May 11 2018 22:44
lil help?
Scott Leibrand
@scottleibrand
May 11 2018 22:46
@garykidd I didn't see a question
Dana Lewis
@danamlewis
May 11 2018 22:46
@garykidd you can read the open dev to master PR for more info.
garykidd
@garykidd
May 11 2018 23:14
@danamlewis sure--just dont know how to find it...
@scottleibrand washaving issue updating one rig to latest dev---1st one went fine though...error's above...thc
thx
garykidd
@garykidd
May 11 2018 23:28
why might I get this response
root@BLUE:~/src/oref0# cd ~/src/oref0 && git checkout dev && git pull
error: pathspec 'dev' did not match any file(s) known to git.
Scott Leibrand
@scottleibrand
May 11 2018 23:36
you can git pull first
garykidd
@garykidd
May 11 2018 23:36
.
oot@BLUE:~/src/oref0# git pull
fatal: No remote repository specified.  Please, specify either a URL or a
remote name from which new revisions should be fetched.
Scott Leibrand
@scottleibrand
May 11 2018 23:37
so you apparently deleted ~/src/oref0/.git at some point. you'll want to delete and re-clone ~/src/oref0/
garykidd
@garykidd
May 11 2018 23:38
so rm ~/src/oref0/.git
?
Scott Leibrand
@scottleibrand
May 11 2018 23:38
cd ~/src && rm -rf ~/src/oref0/
and then cd ~/src && git clone https://github.com/openaps/oref0.git
garykidd
@garykidd
May 11 2018 23:40
and then if I was goign to try 0.7.0...
Scott Leibrand
@scottleibrand
May 11 2018 23:40
find the instructions for checking out a feature branch (called 0.7.0-dev in this case)
garykidd
@garykidd
May 11 2018 23:41
cd ~/src/oref0 && git checkout dev && git pull ?
Scott Leibrand
@scottleibrand
May 11 2018 23:41
basically just replace dev with 0.7.0-dev there if you want 0.7.0
garykidd
@garykidd
May 11 2018 23:41
oh...right below
this look right cd ~/src/oref0 && git fetch && git checkout 0.7.0-dev && git pull && npm run global-install
Scott Leibrand
@scottleibrand
May 11 2018 23:43
no
the branch is 0.7.0-dev
and you're missing an && between git pull and npm run
garykidd
@garykidd
May 11 2018 23:45
edited with your fixes---thx
Scott Leibrand
@scottleibrand
May 11 2018 23:46
one more: remove the space in global-install
copy-paste is your friend there. :)
garykidd
@garykidd
May 11 2018 23:47
so sad because I actually did copy / paste...yikes
making progress
so should 0.7.0 improve battery life vs. 0.6.0
Scott Leibrand
@scottleibrand
May 11 2018 23:51
which battery?
garykidd
@garykidd
May 11 2018 23:52
rig battery if running off explorer board based rig ?
Scott Leibrand
@scottleibrand
May 11 2018 23:52
yes, it should help some with that
we haven't tried to measure it
garykidd
@garykidd
May 11 2018 23:52
yeah--just curious..I think I get like 20 hours or so on these rigs.
when I was on 0.6.0 and old toolkit measures
garykidd
@garykidd
May 11 2018 23:59
scott, how can I see/compare what's different 0.6.0 vs. 0.7.0 ?