These are chat archives for nightscout/intend-to-bolus

23rd
May 2018
Tracey Berg-Fulton
@BergFulton_twitter
May 23 2018 13:11
So I've recently started running oref1, and the last two days, I've had two bloodsugars greater than 500 (Currently sitting at 563 right now). I wonder if I'm doing it wrong? I've been announcing meal carbs through the NS Meal Bolus form...but I wonder if I'm missing something? When I'm sitting here, I can see the little microboluses going, but on these huge spikes, I don't see any activity sometimes and I'm having to intervene with my pump. Max IOB is set to 20, after last night's fiasco I swapped out my infusion set, and went for a new vial of insulin, and used an infusion site I haven't used before, but it seems like nothing will bring me down
Jon Cluck
@cluckj
May 23 2018 13:26
do you have syringes or pens to inject with? with a BG that high I would go analog because of the risk of DKA.
Tracey Berg-Fulton
@BergFulton_twitter
May 23 2018 13:27
Yeah, I went with a syringe dose. I didn't believe it and tested my BG like four times to be sure
Jon Cluck
@cluckj
May 23 2018 13:27
:thumbsup:
Tracey Berg-Fulton
@BergFulton_twitter
May 23 2018 13:27
I tested with a ketone meter I had left over and only got 0.3 ketones, so thankfully no DKA just yet
Jon Cluck
@cluckj
May 23 2018 13:27
whew!
can you post a screenshot of your nightscout for that time period?
going no-bolus on really high carb meals doesn't work for me (even on fiasp), because SMB just can't pump enough insulin into my body before all those carbs hit
Jon
@Jonathan-Cole
May 23 2018 13:30
I've gotten 3 motor errors on my 723 in the past 2 days... Looks like I may be down & out with OpenAPS until I can magically find a replacement pump that's compatible. :worried:
Tracey Berg-Fulton
@BergFulton_twitter
May 23 2018 13:31
Here's some screenshots of last night's/this morning's shenanigans https://imgur.com/a/nehx5M8
Jon Cluck
@cluckj
May 23 2018 13:31
thanks
Tracey Berg-Fulton
@BergFulton_twitter
May 23 2018 13:34
@cluckj yeah that's what I was thinking, maybe I need to still use bolus wizard for these big carb meals (party last night, work breakfast this morning), I was just thinking about what the docs say about not using the bolus wizard in case it interferes with SMB
Jon Cluck
@cluckj
May 23 2018 13:35
the easy bolus buttons don't interfere with SMB, so what some of us do is do a roughly-estimated bolus w/ easy bolus, enter carbs and let SMB take care of the difference :)
@BergFulton_twitter on your NS after the carb entries, are those boluses manual or from SMB?
the 1.2, 1.1, 1.0 etc.
Tracey Berg-Fulton
@BergFulton_twitter
May 23 2018 13:37
Both. 1.2 was me freaking out about super fast rise and not seeing SMB kick in, 1.1 was the same after another blood test and still rising, then 1.0 was SMB
Jon Cluck
@cluckj
May 23 2018 13:38
what's the grey dot before those 1.0s?
Tracey Berg-Fulton
@BergFulton_twitter
May 23 2018 13:39
Change basal profile (I usually check in with Autotune every Wed to make sure everything is ticking along, edited my 3AM basal down a touch)
Jon Cluck
@cluckj
May 23 2018 13:39
ah okay
can you paste your preferences.json or post a screenshot? I think you might have "enableSMB_with_COB": false, set?
openaps should have been freaking out with SMBs instead of delivering at max_basal
Tracey Berg-Fulton
@BergFulton_twitter
May 23 2018 13:45
Yeah give me a sec plug my machine in. That's what I thought too...like it should have been really pushing because of the carb activity & rapid BG change
Jon Cluck
@cluckj
May 23 2018 13:46
:thumbsup:
Tracey Berg-Fulton
@BergFulton_twitter
May 23 2018 13:59
sorry, having some trouble getting into my rig
naboull1
@naboull1
May 23 2018 13:59
hey @cluckj whats an insulin action curve? its on 6
Tracey Berg-Fulton
@BergFulton_twitter
May 23 2018 14:00
and for some reason when i use sudo its just dive bombing me into the preferences file and it looks realy jacked up
Jon Cluck
@cluckj
May 23 2018 14:00
@BergFulton_twitter no worries!
Scott Leibrand
@scottleibrand
May 23 2018 14:01
Perhaps we need something in the docs telling people not to rely on SMBs until they have tested them, know they’re actually working, and know what they should expect to see (and to go back to manual boluses if they don’t see it).
Jon Cluck
@cluckj
May 23 2018 14:02
a slow-and-steady how-to?
Scott Leibrand
@scottleibrand
May 23 2018 14:04
And “don’t rely on SMB unless you’re watching the pump-loop.log in real time.”
Tracey Berg-Fulton
@BergFulton_twitter
May 23 2018 14:06
      "max_iob": 20,
        "max_daily_safety_multiplier": 3,
        "current_basal_safety_multiplier": 4,
        "autosens_max": 1.2,
        "autosens_min": 0.7,
        "rewind_resets_autosens": true,
        "adv_target_adjustments": false,
        "exercise_mode": true,
        "wide_bg_target_range": false,
        "sensitivity_raises_target": true,
        "unsuspend_if_no_temp": true,
        "enableSMB_with_bolus": true,
        "enableSMB_with_COB": true,
        "enableSMB_with_temptarget": true,
        "enableUAM": true,
        "enableSMB_always": true,
        "enableSMB_after_carbs": true,
        "allowSMB_with_high_temptarget": true,
        "maxSMBBasalMinutes": true,
        "high_temptarget_raises_sensitivity": true,
        "low_temptarget_lowers_sensitivity": true,
        "sensitivity_raises_target": true,
      "resistance_lowers_target": true,
        "curve": "rapid-acting",
        "offline_hotspot": false

}
current preferences.json
Scott Leibrand
@scottleibrand
May 23 2018 14:12
What does pump-loop.log say about why it wasn’t bolusing?
Jon Cluck
@cluckj
May 23 2018 14:15
^^^ yeah
Tracey Berg-Fulton
@BergFulton_twitter
May 23 2018 14:16
oh crap I just realized that I never set up papertrail again after I reflashed 😑
johnaras98
@johnaras98
May 23 2018 14:16
@BergFulton_twitter there is a wrong entry "maxSMBBasalMinutes": true, in your settings, value should be 30 instead of true
This could be the reason for missing SMB
Jon Cluck
@cluckj
May 23 2018 14:22
ooo, nice catch
Tracey Berg-Fulton
@BergFulton_twitter
May 23 2018 14:22
Yep, good spot :+1:
Jon Cluck
@cluckj
May 23 2018 14:22
more info about what went wrong should be reflected in pump-loop.log too :)
johnaras98
@johnaras98
May 23 2018 14:25
I think "enableSMB_always": true, supercedes all other enableSMB_xxx entries, right ?
Tracey Berg-Fulton
@BergFulton_twitter
May 23 2018 14:25
Going to ask a dumb question here...so I almost always have to use sudo to get into my rig, and if I want to look at my preferences.json, or run log, and I try to scroll up either with the keypad or with my trackpad, I just get a bunch of garbage that spews out at the last line, OR it'll run through the command I've entered previously
So trying to scroll up through my logs isn't working for me
Latest pumplog
Jon Cluck
@cluckj
May 23 2018 14:33
I think I know what you mean about the terminal? are you logging in via serial or SSH?
Tracey Berg-Fulton
@BergFulton_twitter
May 23 2018 14:33
serial, SSH only works for me like 30% of the time for some odd reason
Scott Leibrand
@scottleibrand
May 23 2018 14:36
FWIW, it sounds like you’re using sudo screen to connect over usbserial. The sudo command itself is just a “no, really”.
Jon Cluck
@cluckj
May 23 2018 14:36
ah okay, iirc from when I was using serial to the edison, I had to not resize the terminal window once I connected via serial
Tracey Berg-Fulton
@BergFulton_twitter
May 23 2018 14:37
ahh ok
That would explain a few things.
Scott Leibrand
@scottleibrand
May 23 2018 14:37
Tracey Berg-Fulton
@BergFulton_twitter
May 23 2018 14:37
😆
Jon Cluck
@cluckj
May 23 2018 14:42
I dunno exactly what was causing the serial window thing, but when I stopped resizing the window it stopped barfing nonsense
Scott Leibrand
@scottleibrand
May 23 2018 14:45
You only want to use your arrow keys to navigate, not your mouse wheel etc.
Jon Cluck
@cluckj
May 23 2018 14:54
once you have the terminal thing worked out, can you look through /var/log/openaps/pump-loop.log for entries from like 7-9am today? (after the 90g of carbs)
(pgup + pgdown in nano is :fire:)
oh, ctrl+w and searching for Wed 23 May 08might get you there faster too?
Tracey Berg-Fulton
@BergFulton_twitter
May 23 2018 14:58
:thumbsup: Yeah I've been using vim to navigate these things because I managed to wreck my wifi preferences file with Nano
Jon Cluck
@cluckj
May 23 2018 14:58
ah okay, I'm not a pro vim user
or even an amateur vim user :laughing:
Tracey Berg-Fulton
@BergFulton_twitter
May 23 2018 15:00
heh, neither am I! VSCode is my normal jam, but I know enough to insert, write, and quit
hm, /var/log/openaps/pump-loop.log gives me permission denied
Jon Cluck
@cluckj
May 23 2018 15:04
sudo it :)
Eric
@ecc1
May 23 2018 15:05
once you're in a screen terminal on your rig, you can change the window size, as long as you do "stty rows N cols M" for suitable N and M. Then things like "less" and "vi" will do the right thing
Tracey Berg-Fulton
@BergFulton_twitter
May 23 2018 15:08
no command found
Scott Leibrand
@scottleibrand
May 23 2018 15:09
No, don’t sudo it. Either vi or nano it.
Jon Cluck
@cluckj
May 23 2018 15:17
oh, sudo vim /var/log/openaps/pump-loop.log or sudo nano /var/log/openaps/pump-loop.log
Scott Leibrand
@scottleibrand
May 23 2018 15:22
If you have to sudo, you’re logging in wrong. You should be logged in as root.
Jon Cluck
@cluckj
May 23 2018 15:31
if you don't want to enable remote root login, you can sudo bash as soon as you log in :)
Tracey Berg-Fulton
@BergFulton_twitter
May 23 2018 15:32
It's strange, because I have to use serial to get in most of the time, sometimes it asks for my login (root) and password, other times it's just like "here ya go!"
Jon Cluck
@cluckj
May 23 2018 15:33
if you don't exit before closing the terminal window, it will leave the login open from the last time you used it
Thomas
@TH2100
May 23 2018 18:01
Hello, there is some minor problem with my installation and internet connectivity. At home, I’m using wlan, else I have to BT-tether. A wlan prioritized switch often worked fine on 0.6. It might not be an 0.7 topic at all, but now it never does and I have to hard switch off/on the rig to make it work. Netwise I find different generic approaches to head on this topic. Is there an advisable way on edison considering the openaps configuration or maybe some documented troubleshooting?
Alan
@Alzibiff
May 23 2018 19:34
Question about the new PiZero + Explorer Hat. Mine has a LiPo battery attached and is being charged via a 5V mains adapter .... has been so for over 24 hours yet the red LED, the charge indicator, remains on. The booklet which came with the hat says that the light will turn off when the battery is charged - any ideas how long this will be?
Scott Leibrand
@scottleibrand
May 23 2018 19:40
How big is the battery? What % does the battery json read if you unplug from wall power?
Alan
@Alzibiff
May 23 2018 19:42
2000mAH battery ... pls can you tell me how to interrogate battery json
Alan
@Alzibiff
May 23 2018 19:53
I have found battery.json and when I look at it, it says Voltage 1.38V on one line and string normal on another
Screen Shot 2018-05-23 at 20.53.41.png
Jon Cluck
@cluckj
May 23 2018 20:01
@Alzibiff monitor/battery.json is your pump battery, monitor/edison-battery.json is your rig's battery
Alan
@Alzibiff
May 23 2018 20:04
Screen Shot 2018-05-23 at 21.04.00.png
Aha!
Jon Cluck
@cluckj
May 23 2018 20:04
:)
Alan
@Alzibiff
May 23 2018 20:05
Guess that looks as though it is 7% away then.
Jon Cluck
@cluckj
May 23 2018 20:05
in my experience the charging light is an indicator of whether it's attached to external power or not (but I have a prototype, not a production version)
Alan
@Alzibiff
May 23 2018 20:06
Would it speed up if I turned the switch to OFF? No need to answer - I have just done that!
Fair enough - I will leave it for another 24hrs. I am not using it in anger at the moment .... waiting for the publication of a design for a case which I can 3D print. (My CAD skills are not too good!)
Jon Cluck
@cluckj
May 23 2018 20:08
2000mAh should be charged in 24 hours
Alan
@Alzibiff
May 23 2018 20:09
Thought so!
Thank you (again) for support. Will see how it goes.
Jon Cluck
@cluckj
May 23 2018 20:11
no problem
Alan
@Alzibiff
May 23 2018 20:24
One question ... what does the 4059.99999 figure refer to?
garykidd
@garykidd
May 23 2018 20:44

/root/src/oref0/bin/oref0-setup.sh: line 1125: syntax error: unexpected end of file
root@YELLOW:~#
just had pulled latest dev and attempted to run---is there something I can check---I guess the directory to start?
Jon Cluck
@cluckj
May 23 2018 21:37
@Alzibiff the voltage the battery is putting out
garykidd
@garykidd
May 23 2018 21:59
i installed 0.7.0 instead---no issues...not sure if something is wrong with latest dev commit?
alimhassam
@alimhassam
May 23 2018 22:19
hi all, i've had a backup edison that i finally decided to setup. i remember reading earlier (i think on this channel) about a way to flash the edison in a way to have the root and home partition together, but don't remember what needed to be done for this, anyone has any pointers?
th122
@th122
May 23 2018 23:52
@alimhassam references here by @esialb from Mar/Apr 2017, I probably messed up the order while trying to extract them from the itb json:
alimhassam
@alimhassam
May 23 2018 23:52
oh, wow, thanks!
alimhassam
@alimhassam
May 23 2018 23:56
i think i'll try my luck jubilinux 0.4 not sure if oref0 will work, but worth the try, otherwise i'll go with the repartition commands.