These are chat archives for nightscout/intend-to-bolus

30th
May 2018
marafie
@marafie
May 30 2018 00:06
'Starting oref0-pump-loop at Wed 30 May 02:57:04 +03 2018 with 5 second wait_for_silence:
Waiting up to 4 minutes for new BG: .glucose.json newer than pump_loop_completed
Listening: ..................No interfering pump comms detected from other rigs (this is a good thing!)
Continuing oref0-pump-loop at Wed 30 May 02:57:57 +03 2018
Preflight fail. Retry 1 of preflight
Preflight OK. Profile less than 60m old; Profile valid. Pump history update failed. Last record 2018-05-30T02:55:15+03:00
Retry 1 of invoke_pumphistory_etc
Pump history update failed. Last record 2018-05-30T02:55:15+03:00
Listening: .No interfering pump comms detected from other rigs (this is a good thing!)
Continuing oref0-pump-loop at Wed 30 May 02:58:36 +03 2018
Retry 2 of invoke_pumphistory_etc
Pump history updated through 2018-05-30T02:55:15+03:00; meal.json refreshed
Listening for 3 s silence: Listening: .No interfering pump comms detected from other rigs (this is a good thing!)
Continuing oref0-pump-loop at Wed 30 May 02:58:59 +03 2018
Checking pump clock: "2018-05-30T02:59:39+03:00" is within 90s of current time: Wed 30 May 02:59:01 +03 2018
Temp refreshed: monitor/temp_basal.json: {"duration":27,"temp":"absolute","rate":0}
Autotune exists! Hoorah! You can use microbolus-related features.
{"carbs":50,"nsCarbs":50,"bwCarbs":0,"journalCarbs":0,"mealCOB":20,"currentDeviation":-3.67,"maxDeviation":0,"minDeviation":-4,"slopeFromMaxDeviation":0,"slopeFromMinDeviation":0.056,"allDeviations":[-4,-3,-3,-3,-3,-4],"lastCarbTime":1527616907000,"bwFound":false}
{"iob":0.155,"activity":0.0028,"basaliob":0.155,"bolusiob":0,"netbasalinsulin":0.8,"bolusinsulin":0,"time":"2018-05-29T23:59:41.000Z","iobWithZeroTemp":{"iob":0.155,"activity":0.0028,"basaliob":0.155,"bolusiob":0,"netbasalinsulin":0.8,"bolusinsulin":0,"time":"2018-05-29T23:59:41.000Z"},"lastBolusTime":1527616907000,"lastTemp":{"rate":0,"timestamp":"2018-05-30T02:55:15+03:00","started_at":"2018-05-29T23:55:15.000Z","date":1527638115000,"duration":5.43}}
{"delta":-4,"glucose":120,"noise":1,"short_avgdelta":-4.06,"long_avgdelta":-3.49,"date":1527638080274}
Autosens ratio: 1.06; Basal unchanged: 0.25; ISF from 301.1 to 284; CR: 12
currenttemp: { duration: 27, temp: 'absolute', rate: 0 } lastTempAge: 4 m tempModulus: 1 m
SMB disabled (no enableSMB preferences active)
Last carbs 358 minutes ago; remainingCATime: 11.8 hours; 60% carbs absorbed
Carb Impact: -0.1 mg/dL per 5m; CI Duration: 0 hours; remaining CI (~2h peak): 6.7 mg/dL per 5m
predCIs (mg/dL/5m): 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0
remainingCIs: 0 0 0 0 0 1 1 1 1 1 1 1 1 1 1 2 2 2 2 2 2 2 2 2 2 2 3 3 3 3 3 3 3 3 3 3 3 4 4 4 4 4 4 4 4 4 4 5
UAM Impact: -0.1 mg/dL per 5m; UAM Duration: 0 hours
minPredBG: 93 minIOBPredBG: 72 minZTGuardBG: 93 minCOBPredBG: 93 minUAMPredBG: 72 avgPredBG: 117 COB: 20 / 50
BG projected to remain above 6.5 for 5 minutes
BG projected to remain above 4.4 for 240 minutes
naive_eventualBG: 76 bgUndershoot: 2.5 zeroTempDuration: 240 zeroTempEffect: 273 carbsReq: -19
2018-05-29T23:59:17.898Z
Checking deliverAt: 2018-05-29T23:59:17.898Z is within 1m of current time: Wed 30 May 02:59:18 +03 2018
and that smb-suggested.json is less than 1m old'
'enact/smb-suggested.json: {"temp":"absolute","bg":120,"tick":-4,"eventualBG":179,"insulinReq":0,"reservoir":"78.9\n","deliverAt":"2018-05-29T23:59:17.898Z","sensitivityRatio":1.06,"COB":20,"IOB":0.155,"duration":30,"rate":0.25}
"COB: 20, Dev: 0.0, BGI: -0.2, ISF: 15.8, CR: 12, Target: 6.5, minPredBG 5.2, minGuardBG 4.4, IOBpredBG 4.0, COBpredBG 9.9, UAMpredBG 4.0; Eventual BG 9.9 > 6.5 but Min. Delta -4.06 < Exp. Delta -0.1; setting current basal of 0.25 as temp. "
COB: [120,116,112,109,106,103,101,99,97,95,94,93,92,92,92,92,92,92,93,94,95,97,98,100,102,104,106,108,111,113,116,119,122,125,128,132,135,139,142,146,150,154,158,162,166,170,174,179]
UAM: [120,116,112,108,105,102,99,96,93,91,89,87,85,83,82,80,79,78,77,76,75,75,74,74,73,73,73,73,72]
IOB: [120,116,112,108,105,102,99,96,93,91,89,87,85,83,82,80,79,78,77,76,75,75,74,74,73,73,73,73,72]
ZT: [120,116,112,109,106,103,100,98,97,95,94,94,93,93,94,94,95,97,98,100,102,104,107,109,112,115]
Temp refreshed: monitor/temp_basal.json: {"duration":27,"temp":"absolute","rate":0}
enact/smb-enacted.json: "Rate: 0.25 Duration: 30"
Temp refreshed: monitor/temp_basal.json: {"duration":30,"temp":"absolute","rate":0.25}
No bolus needed. Settings less than 15 minutes old. grep: enact/bolused.json: No such file or directory
Refreshing pumphistory because: enacted, Pump profile refreshed; Could not parse temptargets_data.
No temptargets found.
Settings refreshed; Pump history updated through 2018-05-30T03:00:01+03:00; Retry 1 of invoke_reservoir_etc
Listening: ...No interfering pump comms detected from other rigs (this is a good thing!)
Continuing oref0-pump-loop at Wed 30 May 03:00:35 +03 2018
Retry 2 of invoke_reservoir_etc
Listening: ...No interfering pump comms detected from other rigs (this is a good thing!)
Continuing oref0-pump-loop at Wed 30 May 03:00:45 +03 2018
Retry 3 of invoke_reservoir_etc
meal.json refreshed
IOB: 0.152
Your instance of oref0 [0.7.0-dev, 0.7.0-dev] is up-to-date.
Completed oref0-pump-loop at Wed 30 May 03:01:15 +03 2018
'
@danamlewis looking into the above, any idea why the BG goes down to 4, while i have the target in the pump 6.5 to 8.0?
Dana Lewis
@danamlewis
May 30 2018 00:10
it's using the 6.5 target. eventual BG is above target, though, even though some of the predictions may go lower (those are the worst case scenario targets used to make sure you don't go low while lowering eventual highs)
marafie
@marafie
May 30 2018 00:21
How can I prevent worst case scenarios from to the lows
Scott Leibrand
@scottleibrand
May 30 2018 00:21
you have 20 COB, and are going to eventually go high from those without additional insulin.
because you're falling at the moment, it doesn't want to high temp, but since your eventualBG is so high from the COB, it doesn't want to zero temp either.
if you enabled SMB, it would be able to zero temp in that scenario, because it could quickly give more insulin later when you start rising from the carbs
marafie
@marafie
May 30 2018 00:41

Thanks

I can’t use SMB the lowest dosage is 0.1U in the bolas... but in the Basel it’s 0.05U .... I am no longer using diluted insulin for my kid... I can think of SMB if I have model 723 which I assum it’s gives bolus as low as 0.05

Scott Leibrand
@scottleibrand
May 30 2018 00:44
you could enable SMB, but you'd need a maxSMBBasalMinutes of at least 60 to allow it to dose 0.1U at a time (if/when your insulinReq is >= 0.2U). not sure if that would be helpful or not
the minimum SMB size is 0.1U regardless of the pump. I think I recall someone modifying that in their fork of the code, but there's never been enough demand for it to make it automatic (or a preference).
marafie
@marafie
May 30 2018 00:51
Thanks will look into it
Dana Lewis
@danamlewis
May 30 2018 01:19
@henghayan if you're looking to run OpenAPS on a laptop computer - you need a linux machine, or to use a virtual machine. you'll essentially do the same setup steps, but on the linux machine. remember you'll need a radio stick, either carelink USB or a TI stick-type device so it can talk to the pump. There are no straight-forward docs for this type of setup, so I don't advise it unless you have some linux experience and can feel your way through it.
Scott Leibrand
@scottleibrand
May 30 2018 01:23
Realistically there’s no advantage to doing that vs. using a Raspberry Pi: best to order an Explorer HAT, but anything you could do with a laptop you can do more easily with a Pi 3.
Benjamin Ortega
@substars
May 30 2018 02:09

Hey all, trying to set up a new Explorer HAT rig and running into some trouble with mmeowlink-any-pump-comms.py. It looks like Jesse uses kernel 4.14.43+, so the install script doesn't install mraa, but then mmeowlink-any-pump-comms.py blows up with a ImportError: No module named mraa error.

I'm using the dev branch, is that correct? Seems like something is on the wrong version...

Jon Cluck
@cluckj
May 30 2018 02:12
we recommend that you use 0.7.0-dev for the explorer HAT + Pi0, if you can be attentive to your logs and be able to update frequently
Benjamin Ortega
@substars
May 30 2018 02:13
that's cool, probably should have asked that before I started! thanks.
Jon Cluck
@cluckj
May 30 2018 02:13
no worries :) we're still working on the documentation
Benjamin Ortega
@substars
May 30 2018 02:14
yeah, i wrote down everything I did so maybe I can help. Once things are actually working, anyway.
Jon Cluck
@cluckj
May 30 2018 02:15
that particular issue is fixed in 0.7.0-dev: openaps/oref0#1015
Benjamin Ortega
@substars
May 30 2018 02:18
perfect, will give it another shot now
henghayan
@henghayan
May 30 2018 02:21
@danamlewis Thanks!!!
kelseyyearick
@kelseyyearick
May 30 2018 15:11
Hey guys, I am running 0.7.0 dev and when nightly autotune runs the carb ratio comes back as NaN, if I run it manually I don't have issues. Thoughts?
Scott Leibrand
@scottleibrand
May 30 2018 15:27
I'd take a look at the files in ~/myopenaps/autotune to see which ones are showing NaN or otherwise invalid contents
Dana Lewis
@danamlewis
May 30 2018 16:25
@kelseyyearick why did you switch to 0.7.0-dev? (Sorry, I missed that). I would not run that on your rig - just master or dev.
davidwagaps
@davidwagaps
May 30 2018 16:29
FWIW I get "NaN" running autotune manually on 0.6.1
Dana Lewis
@danamlewis
May 30 2018 16:30
@davidwagaps see @scottleibrand comment above
kelseyyearick
@kelseyyearick
May 30 2018 16:52
@danamlewis dev branch was giving me syntax errors
Scott Leibrand
@scottleibrand
May 30 2018 16:55
that was fixed 22h ago: openaps/oref0#1023
Dana Lewis
@danamlewis
May 30 2018 16:57
@kelseyyearick 0.7.0-dev has a lot of WIP around radio work and shouldn't be used for primary rigs at this point, so I'd jump back to dev as soon as possible.
kelseyyearick
@kelseyyearick
May 30 2018 17:00
Thanks @scottleibrand and @danamlewis
Dana Lewis
@danamlewis
May 30 2018 17:06
@kelseyyearick but the autotune issue may persist when you switch back over - so if so, let's look to see what files might be the issue in the autotune directory
peterfulvi
@peterfulvi
May 30 2018 18:14
Whats the progress on the PI Explorer HAT . I would like to get the parts. Is there documentation on installing?
Martin Haeberli
@mhaeberli
May 30 2018 18:16
yes - there is good documentation on installing
hang on a minute for links
Dana Lewis
@danamlewis
May 30 2018 18:16
yes, Pi instructions are in the docs. code is still a WIP since we're also switching radio, so I wouldn't plan for it to be primary rig quite yet.
peterfulvi
@peterfulvi
May 30 2018 18:17
Ok! Well ill just gather the parts.
Dana Lewis
@danamlewis
May 30 2018 18:17
:+1:
peterfulvi
@peterfulvi
May 30 2018 18:18
thanks
Martin Haeberli
@mhaeberli
May 30 2018 18:19

(from a recent note on hardware-dev, but ITB here is now the place to post this):

FWIW, my install process was to follow:
http://openaps.readthedocs.io/en/latest/docs/Build%20Your%20Rig/pi-install.html
but control-c rather than install master
-then reboot and login as root
then follow:
http://openaps.readthedocs.io/en/latest/docs/Build%20Your%20Rig/OpenAPS-install.html#step-4-setup-script
but to:
-git checkout 0.7.0-dev
-npm run global-install
then
-cd && ~/src/oref0/bin/oref0-setup.sh

peterfulvi
@peterfulvi
May 30 2018 18:20
THanks
Martin Haeberli
@mhaeberli
May 30 2018 18:21
:+1:
garykidd
@garykidd
May 30 2018 18:26
does upgrading mlab to higher paid tier circumvent the issues with size---even when mlab issues <500Mb cause an issue with NS?
philipgo
@philipgo
May 30 2018 18:54
@garykidd You might want to have a look at ns.10be.de instead of upgrading your mlab account
garykidd
@garykidd
May 30 2018 20:32
Hmmm??
This message was deleted
Scott Leibrand
@scottleibrand
May 30 2018 20:42
ns.10be.de is a hosted nightscout service
Neal
@tnharvey
May 30 2018 22:47

I'm having some odd trouble with bluetooth. I've had it paired and working for a couple of months, and I updated in the last week to start trying out UAM/SMB, and now my BT pairing doesn't stick. It pairs initially, but with a reboot, it doesn't reconnect. If I connect manually:

sudo bt-pan client AA:BB:CC:DD:EE:FF
sudo dhclient bnep0

it works fine, but once again, with a restart, it doesn't reconnect. I'm sure I've missed something simple!

(I put my actual MAC address in there, not the ABC one there)
Oh, and I'm on Android 8.1.0
Scott Leibrand
@scottleibrand
May 30 2018 23:18
what does /var/log/openaps/network.log show?