These are chat archives for nightscout/intend-to-bolus

4th
Jun 2018
marafie
@marafie
Jun 04 2018 00:11
Actually didn’t work
Worked for several mins
And back again to empty or Unknow
garykidd
@garykidd
Jun 04 2018 02:08
@scottleibrand silly question....assuming it's OK to physically install pihat on pi rig when attempting to ssh into rig for first time----I'm having difficulty---just getting hostname error when attempting to ssh into rig...
green light blinks a bit but then remains solid after just about 15-20 secs
Scott Leibrand
@scottleibrand
Jun 04 2018 02:16
yeah, HAT is fine. your wpa_supplicant may not be correct. you may want to connect with a keyboard and monitor if you're not sure how to get wpa_supplicant correct
garykidd
@garykidd
Jun 04 2018 02:17
weird...i copy and pasted it in and just replaced xx with US and...then network ssid and pw
Scott Leibrand
@scottleibrand
Jun 04 2018 02:18
if I had a dollar for every wpa_supplicant syntax error in ITB...
garykidd
@garykidd
Jun 04 2018 02:18
got the idea that the green light on pi0 should go on and off longer than just a few seconds though
right---I''ll hook up two micro usbcables and see if I can get screen to work
is nano OK to create wpa_supplicant.conf file
?
OH...wait---spaces OK in Network ID?
getting error writing wpa_supplicant.conf now....hmmm
garykidd
@garykidd
Jun 04 2018 02:25
got it sorry
garykidd
@garykidd
Jun 04 2018 02:47
I think I may have just created my supplicant file in the wrong directory---not even worth exploring---installing now...thanks
for being patient with me
is ITB? In The Beginning?
garykidd
@garykidd
Jun 04 2018 02:49
oh....duh.......kinda funny
garykidd
@garykidd
Jun 04 2018 03:51
Would you like to [D]ownload precompiled Go pump communication library or build them from [S]ource? [D]/S ???
?
why would one want to build from source?
Scott Leibrand
@scottleibrand
Jun 04 2018 03:53
for development
there's a default for a reason: just hit enter. :)
garykidd
@garykidd
Jun 04 2018 03:57
I hit D...hoping that's default?
0.7.0 has been working well for me FYI
Scott Leibrand
@scottleibrand
Jun 04 2018 04:01
the one in [] is always the default
garykidd
@garykidd
Jun 04 2018 04:02
dint pick up on that but glad I know now--thx...
Scott Leibrand
@scottleibrand
Jun 04 2018 04:02
design patterns from the pre-Internet MUD/BBS days. :)
garykidd
@garykidd
Jun 04 2018 04:02
didnt
BBS....yeah
300 baud
funny
Scott Leibrand
@scottleibrand
Jun 04 2018 04:02
you obviously didn't play enough doorgames. ;-)
garykidd
@garykidd
Jun 04 2018 04:05
I started with ZORK...found it found to collect games which I mostly never played...cool to learn how to make free phone calls though
Scott Leibrand
@scottleibrand
Jun 04 2018 04:08
I started with 2400 baud, and never heard about phreaking until much later. played lots and lots of Land of Devastation, Legend of the Red Dragon, and Solar Realms Elite / Barren Realms Elite
at one point I inherited my dad's old 286 laptop, which only had an 80x24 monochrome-CGA display, so I played a bunch of single-player LOD on that on road trips as well. :)
garykidd
@garykidd
Jun 04 2018 04:11
I wish I could remember more from back then.....I funded indigogo atari acs the other day... nostalgia
commodoer 64, ibm pc with a turbo button that 2x the clock speed to ....i cant even remember---but it was fast at the time and funny now.
hmmm...
seem to be hanging now
upload ! bash -c "echo -n Upload && ( openaps upload-bg; openaps upload-ns-status; openaps upload-pumphistory-entries; openaps upload-recent-treatments ) 2>/dev/null >/dev/null && echo ed"
first-upload ! bash -c "cat monitor/glucose.json | json 1 > nightscout/recent-missing-entries.json && openaps report invoke nightscout/uploaded-entries.json"
many minutes......pull plug and retry?
Scott Leibrand
@scottleibrand
Jun 04 2018 04:14
does it respond to Ctrl-C?
garykidd
@garykidd
Jun 04 2018 04:15
actually, no
finally broke it; yes
garykidd
@garykidd
Jun 04 2018 04:20
ahhh---just starting over...
garykidd
@garykidd
Jun 04 2018 04:42
assuming the one antenna jack next to top right of display is the one and only place to attach antenna...right?
garykidd
@garykidd
Jun 04 2018 05:03
ok,,,,have OpenAPS screenon rig---very cool unicorn
havent beenable to get past radio check though
waiting to mmtune forever
Scott Leibrand
@scottleibrand
Jun 04 2018 05:04
🦄
garykidd
@garykidd
Jun 04 2018 05:05
be patient I guess---so hard
Martin Haeberli
@mhaeberli
Jun 04 2018 05:06
@garykidd first time I tried, I failed because test pump battery was too low
garykidd
@garykidd
Jun 04 2018 05:06
hmmm....got full battery indicationoin pump
Martin Haeberli
@mhaeberli
Jun 04 2018 05:06
You can watch l and see what its doing
K so that’s not it
Scott Leibrand
@scottleibrand
Jun 04 2018 05:06
if it's waiting for silence, that means you have another rig looping
garykidd
@garykidd
Jun 04 2018 05:07
thinking something else is driving this...
Starting oref0-pump-loop at Mon  4 Jun 00:37:04 EDT 2018 with 25 second wait_for_silence:
Waiting up to 4 minutes for new BG: jq: error: Could not open file monitor/glucose.json: No such file or directory
jq: error: Could not open file monitor/glucose.json: No such file or directory
date: invalid date ‘@’
ls: cannot access '/tmp/pump_loop_completed': No such file or directory
ImportError: No module named mraa

Radio check failed. No more radio errors; canceling reboot

Starting oref0-pump-loop at Mon  4 Jun 00:38:05 EDT 2018 with 8 second wait_for_silence:
Waiting up to 4 minutes for new BG: ls: cannot access '/tmp/pump_loop_completed': No such file or directory
ImportError: No module named mraa

Radio check failed. ImportError: No module named mraa
Listening for 40s silence before mmtuning: ................................................................................................................................................................................................................................................................................................................................................................No more radio errors; canceling reboot

Starting oref0-pump-loop at Mon  4 Jun 00:38:05 EDT 2018 with 8 second wait_for_silence:
Waiting up to 4 minutes for new BG: ls: cannot access '/tmp/pump_loop_completed': No such file or directory
ImportError: No module named mraa

Radio check failed. ImportError: No module named mraa
Listening for 40s silence before mmtuning: ..................................................................................................................................
Starting oref0-pump-loop at Mon  4 Jun 01:01:04 EDT 2018 with 9 second wait_for_silence:
Waiting up to 4 minutes for new BG: ls: cannot access '/tmp/pump_loop_completed': No such file or directory
ImportError: No module named mraa

Radio check failed. ImportError: No module named mraa
Listening for 40s silence before mmtuning: .............................................................................................................................
Scott Leibrand
@scottleibrand
Jun 04 2018 05:07
umm...
you see that thing that says Error... a dozen times?
garykidd
@garykidd
Jun 04 2018 05:08
no module names mraa...
what'd I miss?
Scott Leibrand
@scottleibrand
Jun 04 2018 05:09
I believe that is due to mixing your 0.6.1 and 0.7.0-dev installs
is this a freshly flashed rig, or an upgrade?
garykidd
@garykidd
Jun 04 2018 05:09
oh...yeah my 0.7.0 just hing so I tried master...
new rig
ish
sort of
Scott Leibrand
@scottleibrand
Jun 04 2018 05:10
don't ish. reflash
Martin Haeberli
@mhaeberli
Jun 04 2018 05:10
I’m with Scott.
Having first ignored then reflagged
Reflashed
garykidd
@garykidd
Jun 04 2018 05:10
COOL
but gotta hang it up tonight early start tomorrow
thx
beback tomorrow night
Martin Haeberli
@mhaeberli
Jun 04 2018 05:14
Check out my remarks on hardware-dev and here a few days ago... reflash, run the first fresh install phase, control c (don’t install master), then check out 0.7.0-dev ; npm run global-install, THEN run oref0-setup
Julius de Bruijn
@pimeys
Jun 04 2018 10:37
hi all, I'm getting a Accu-Chek Combo tomorrow and I'm otherwise ready to loop, been running the open loop with androidaps a while already. the Combo I'm getting misses the configuration tool and infrared device, but I have one infrared reader from my Animas pump and I think it SHOULD work, but I'm not sure
also is there any place where you could download the Accu-Chek 360 configuration software?
JohnDoeAkira
@JohnDoeAkira
Jun 04 2018 12:01
Hello everyone, I am a happy owner of a 640G which I use with enlite sensors. I bought a 722 and prepared all the edison stuff ... to the point that I realized that my 722 could not pair with the sensor. Do you confirm that guardian transmitter are not compatible with older pumps ? I had a look at medwow but the minilink transmitter are crazy expensive !!!
Eric
@ecc1
Jun 04 2018 13:32
Too pressed for time to check the Explorer HAT setup docs, but is there a warning not to power it on without an antenna attached? There should be; wouldn't want to accidentally run mmtune or other radio comms w/o it
Tim Street
@tim2000s
Jun 04 2018 13:57
@JohnDoeAkira - to use enlites with the x22 and x23 series you need to use a Minilink transmitter. Guardians are not compatible.
JohnDoeAkira
@JohnDoeAkira
Jun 04 2018 14:02
Hi Tim. Thanks for the confirmation. This is indeed a sad news. I was happy to have found the 722, I have to go back to hunting hardware on the second hand market. Any hint of sources in EU ?
Dana Lewis
@danamlewis
Jun 04 2018 14:33
@pimeys hi - I would join the AndroidAPS Users group on Facebook, and the AndroidAPS channel here on gitter.
Julius de Bruijn
@pimeys
Jun 04 2018 16:27
I'm not using facebook but I'll join the channel here
holy cow!
JohnDoeAkira
@JohnDoeAkira
Jun 04 2018 16:45
Gitlab recorded 10 times more repo creations last weekend ;-)
Jon Cluck
@cluckj
Jun 04 2018 16:48
@ecc1 I don't think there is, good catch! Did you get a HAT?
Martin Haeberli
@mhaeberli
Jun 04 2018 17:29
@ecc1 @cluckj not clear to me that harm would be done by running a PiHAT without antenna (not to say it would work very well). Can someone who knows a bit more on this please chime in?
Jon Cluck
@cluckj
Jun 04 2018 17:30
It would probably work very poorly without an antenna
Scott Leibrand
@scottleibrand
Jun 04 2018 17:35
I am also interested in whether there's any potential for physical damage from trying to transmit at the power levels we're using without an antenna connected. I had assumed it just wouldn't work, but wouldn't permanently hurt anything.
Martin Haeberli
@mhaeberli
Jun 04 2018 17:37
@scottleibrand I share your assumption. but would be nice to have confirmation...
JohnDoeAkira
@JohnDoeAkira
Jun 04 2018 18:06
I found two very old MMT-7703 transmitter but the battery is obviously dead. Has any of you managed to replace the battery ? I am not so familiar with Gitter ... if this is not the right place to ask these hardware question, I apologize ...
Scott Leibrand
@scottleibrand
Jun 04 2018 18:14
are those Enlite transmitters? or something else?
Eric
@ecc1
Jun 04 2018 18:24
I'm not enough of a EE to confirm or refute; I was just operating based on warnings I've seen (for example, from Sparkfun about the need to connect an antenna to the RFM69). So it may just be superstition at this point, but not something I want to test. (No, I don't have an Explorer HAT, just other CC111x devices with onboard chip antennas.)
JohnDoeAkira
@JohnDoeAkira
Jun 04 2018 18:27
@scottleibrand those are minilink transmitter that I intend to use with a 722 for openAPS looping. I opened it and managed to remove the resin and get the lipo out but I don't know the specs of the battery. Probably a 1S (3.7V).
Scott Leibrand
@scottleibrand
Jun 04 2018 18:52
is minilink == enlite? I'm mildly surprised it got all the way to the point where you couldn't recharge it at all. I haven't heard of anyone replacing the rechargable Enlite transmitter batteries
Jon Cluck
@cluckj
Jun 04 2018 18:57
ah okay :)
JohnDoeAkira
@JohnDoeAkira
Jun 04 2018 19:01
@scottleibrand it was sitting ten years in a box ... 10 years without charge is a long time for a lipo. If they get two low in charge, they can be permanently damaged. The minilink was the former version of the guardian. enlite is the sensor name. Minilink or guardian are the tranmitter name.
alimhassam
@alimhassam
Jun 04 2018 19:30
@JohnDoeAkira i also have a minilink which doesn't charge anymore, let em know if you figure out how to replace the battery and make it work?
JohnDoeAkira
@JohnDoeAkira
Jun 04 2018 19:37
It looks clearly possible. Here is a link I found on youtube. Problem is now to find the right battery. At least I have the specs : 1S 22mAh.
JohnDoeAkira
@JohnDoeAkira
Jun 04 2018 20:17
In the video, it says that a usable battery should be of size 21021 mm. He used the GMB201021. I could not find it anywhere but I found the GMB201024. The electrical specs are close : 1S 22mAh. Despite the name, it should also be 21 mm long , 10mm large and 2mm thick. It could work. I found it in UK : https://www.ebay.com/itm/Nike-Fuelband-1-Set-2-Replacement-Battery-22mAh-36mAh/272211953080?hash=item3f6118c5b8:m:mPkpEU5uXYVEFHlNZI3J8_A
I have ordered one. I hope it will work !!!
Martin Haeberli
@mhaeberli
Jun 04 2018 20:38
here’s sort of a whacky question re SMB / UAM users : -would it be possible (maybe NOT advised) to have a ‘feature’ where the user enters carbs (maybe the same time as a finger prick bg), and OpenAPS decides whether to bolus 0, bolus, say 1/2, or full bolus, depending on factors including current BG value? So maybe if target is 120, and bg is 80, no bolus (yet) - chase it with SMBs as forecast comes up; if BG is 130, 1/2 bolus; let SMBs chase the reset, and if BG 200 or more, full bolus, let SMBs chase…
Scott Leibrand
@scottleibrand
Jun 04 2018 21:04
That might be something AndroidAPS would implement. In OpenAPS there’s no UI for presenting a bolus recommendation the user and getting confirmation, so we instead just deliver the resulting insulinReq as SMBs. If you raise maxSMBBasalMinutes, it can deliver up to insulinReq/2 (a half bolus, if needed) at a time, and the rest very quickly afterward.
Scott Leibrand
@scottleibrand
Jun 04 2018 21:41
probably easiest to just delete ~/src/oref0 and re-clone the repo
Dosefinder
@Dosefinder
Jun 04 2018 21:45
thanks
Martin Haeberli
@mhaeberli
Jun 04 2018 22:37
@scottleibrand - thx for your comment. would your view on this change for PiHAT platform where there IS a UI?
Scott Leibrand
@scottleibrand
Jun 04 2018 22:40
that isn't good enough for dosing IMO
much better to just enter the carbs and let SMB do its thing
you might want to create a UI with the screen and buttons for entering carbs, or just use the meal marker (or bolus wizard if you're careful about A52s). but I don't see the point of trying to reinvent the pump's bolus wizard when SMB already does a better job than a full manual bolus