These are chat archives for nightscout/intend-to-bolus

8th
Aug 2018
alimhassam
@alimhassam
Aug 08 2018 00:20
@garykidd @efidoman added g6 support to xdrip-js
Dana Lewis
@danamlewis
Aug 08 2018 00:24
is it ready for wider testing, or still testing out the kinks?
Jon Cluck
@cluckj
Aug 08 2018 00:34
I haven't had a chance to test no-calibration mode to see if it is working, but calibration mode works
Jon Cluck
@cluckj
Aug 08 2018 00:41
At worst, if no-calibration mode fails to start you get a calibration-mode session...so if anyone wants to try it before I get a chance feel free, it's not going to blow up or anything :laughing:
Garrett Webb
@garetis
Aug 08 2018 01:29
For the Edison/Explorer, what's the difference between the OTG and UART ports?
Never mind, I think I found something on Github about it
Debby Muskar
@debbymuskar
Aug 08 2018 02:37
Hi all - I made a mistake and typed the command line 'iw config' and now I am not getting updates to my NS nor can I connect to the rig using SSH
I am still looping because I am using Lookout, but I am seemingly "offline"
Can anyone help me with this please? TIA
garykidd
@garykidd
Aug 08 2018 02:38
just ordered g6. seems like it's worth a shot now.
Debby Muskar
@debbymuskar
Aug 08 2018 02:41
A look at my attempt to reset my wifi:
root@debbymuskar2:~# cd ~/src
root@debbymuskar2:~/src# git clone https://github.com/TC2013/edison_wifi
Cloning into 'edison_wifi'...
fatal: unable to access 'https://github.com/TC2013/edison_wifi/': Could not resolve host: github.com
root@debbymuskar2:~/src# cd edison_wifi
-bash: cd: edison_wifi: No such file or directory
root@debbymuskar2:~/src#
Debby Muskar
@debbymuskar
Aug 08 2018 02:50
@cluckj - any chance you can help me with my iw config mistake?
Jon Cluck
@cluckj
Aug 08 2018 02:52
Have you rebooted?
Debby Muskar
@debbymuskar
Aug 08 2018 02:53
Several times
Don't know if this helps or not:
root@debbymuskar2:~# ifconfig wlan0
wlan0     Link encap:Ethernet  HWaddr 00:00:00:00:00:00
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
Jon Cluck
@cluckj
Aug 08 2018 02:55
kinda
which command did you run?
Debby Muskar
@debbymuskar
Aug 08 2018 02:55
iw config
that's what messed this up
ironically - I started this night with the problem of why I wasn't looping while offline using Lookout
now I'm looping but not connecting to wifi
Jon Cluck
@cluckj
Aug 08 2018 02:56
iw config or iwconfig?
Debby Muskar
@debbymuskar
Aug 08 2018 02:56
with the space
as shown in the history of the commands I ran
root@debbymuskar2:~# iw config
Jon Cluck
@cluckj
Aug 08 2018 02:57
was there more after that?
Debby Muskar
@debbymuskar
Aug 08 2018 02:57
no
but after that I lost my SSH connection and my NS stopped updating
Jon Cluck
@cluckj
Aug 08 2018 03:02
iwconfig wlan0 txpower auto?
Debby Muskar
@debbymuskar
Aug 08 2018 03:03
you want me to try that?
root@debbymuskar2:~# iwconfig wlan0 txpower auto
Error for wireless request "Set Tx Power" (8B26) :
    SET failed on device wlan0 ; Input/output error.
hah! NS just updated
Jon Cluck
@cluckj
Aug 08 2018 03:05
lol
Debby Muskar
@debbymuskar
Aug 08 2018 03:05
let me see if I can connect using SSH
yep, we are back in business!
thank goodness! I knew I needed to call my superhero to fix this! Thank you @cluckj!!!!
Jon Cluck
@cluckj
Aug 08 2018 03:07
at least I was still awake!
Debby Muskar
@debbymuskar
Aug 08 2018 03:07
I was thinking this would have to wait until tomorrow - but my bat signal is very strong!
now I need to get my darn BG down
Jon Cluck
@cluckj
Aug 08 2018 03:07
:thumbsup:
Debby Muskar
@debbymuskar
Aug 08 2018 03:08
thanks again and have a great night!
Jon Cluck
@cluckj
Aug 08 2018 03:08
no problem, you too
Debby Muskar
@debbymuskar
Aug 08 2018 03:08
thanks
Tim Street
@tim2000s
Aug 08 2018 05:17
@scottleibrand The odd thing about the issue the @nsewar01 is having is that i installed the same image from the same Mac onto a different Pi rig two days previously and had no issues.
katie disimone
@Kdisimone
Aug 08 2018 06:37
I secretly think @cluckj never sleeps
Jon Cluck
@cluckj
Aug 08 2018 13:09
It's true, I have a toddler :laughing:
Dromore1911
@Dromore1911
Aug 08 2018 14:47
Well i ran into a brick wall two nights ago. I'm getting BG's to nightscout but for some reason pump comms aren't working. I reflashed and reinstalled to see if that helps but at this point i think my edison is done

Profile less than 60m old; Profile valid. Refreshedjq: monitor/pumphistory-zoned.json: No such file or directory
jq: settings/pumphistory-24h-zoned.json: No such file or directory
jq: error: Cannot iterate over null
jq: error: null and array cannot be sorted, as they are not both arrays
module.js:674
throw err;
^

SyntaxError: /root/myopenaps/monitor/pumphistory-merged.json: Unexpected end of JSON input
at JSON.parse (<anonymous>)
at Object.Module._extensions..json (module.js:671:27)
at Module.load (module.js:565:32)
at tryModuleLoad (module.js:505:12)
at Function.Module._load (module.js:497:3)
at Module.require (module.js:596:17)
at require (internal/module.js:11:18)
at Object.<anonymous> (/home/.rootfs/usr/local/lib/node_modules/oref0/bin/oref0-calculate-iob.js:43:18)
at Module._compile (module.js:652:30)
at Object.Module._extensions..js (module.js:663:10)
pumphistoryCould not parse input data: SyntaxError: Unexpected end of JSON input
at JSON.parse (<anonymous>)
at Object.<anonymous> (/home/.rootfs/usr/local/lib/node_modules/oref0/bin/oref0-meal.js:47:37)
at Module._compile (module.js:652:30)
at Object.Module._extensions..js (module.js:663:10)
at Module.load (module.js:565:32)
at tryModuleLoad (module.js:505:12)
at Function.Module._load (module.js:497:3)
at Function.Module.runMain (module.js:693:10)
at startup (bootstrap_node.js:191:16)
at bootstrap_node.js:612:3
and meal.json
Checking pump clock: "2018-08-08T07:50:02-07:00" is within 90s of current time: Wed Aug 8 07:50:03 PDT 2018
Error: pumphistory too old
oref0-pump-loop failed. pump_loop_completed more than 15m old; waiting for 40s silence before mmtuning

this is what im getting

Benjamin Ortega
@substars
Aug 08 2018 14:52
Hey all, I updated dev OpenAPS on my edison and pi and now OpenAPS status is "unknown" in NS despite everything else working. NS logs keep saying "OpenAPS hasn't reported a loop yet", so I'm wondering if something changed in oref0? Tried all the troubleshooting steps (deleting data etc.) and no dice. Any other things I could try, or is this something other people have noticed on the dev branch recently?
Jens Heuschkel
@juehv
Aug 08 2018 15:16
Hi, in the last few weeks I get occationally A64 errors, well I don't get an error but communication stops and when I make a selftest it displays A64 error and reboots. After the reboot it works fine for about two days ... Is my pump dying now??
Benjamin Ortega
@substars
Aug 08 2018 15:40
yes, i deleted all my entries and compacted. It looks like NS auth really did break on (both of!) my rigs even though the token didn't change. Generating a new one and running oref0-runagain with it to see if that helps.
Benjamin Ortega
@substars
Aug 08 2018 15:52
Well, a new token seems to have fixed it, which is pretty weird. Must have been a Nightscout thing.
I think I will create different tokens for each rig in the future...
iValkou
@iValkou
Aug 08 2018 17:58
what battery is enough for pi/explorer hat rig? it looks like 5000 mAh is not enough for a day
I'm disappointed in performance and battery life compared to Edison based rig
Scott Leibrand
@scottleibrand
Aug 08 2018 18:20
if you'd like you can underclock the Pi to get better battery life (and help us write up the instructions for doing so)
Zach Gohr
@zgohr
Aug 08 2018 18:55
5000mah not enough for the day? wow, how long do you get @iValkou ?
Scott Leibrand
@scottleibrand
Aug 08 2018 18:58
ah, cool thx
Jon Cluck
@cluckj
Aug 08 2018 19:04
How long is a day?
Diabetic_Dude
@diabetic_dude_twitter
Aug 08 2018 19:05
23.934 hours ?????
Jon Cluck
@cluckj
Aug 08 2018 19:05
:laughing:
Zach Gohr
@zgohr
Aug 08 2018 19:10
i’m about to rig two 2500mAh batteries in parallel to see if i can see improvement in loop speeds when adjusting clock speed back up. my initial tests weren’t oref1 and it seems SMB loops are a bit more CPU intensive
iValkou
@iValkou
Aug 08 2018 19:12
@zgohr tnaks
Eric
@ecc1
Aug 08 2018 19:17
Yes, very disappointing that a Pi Zero is more power hungry than a cell phone. Price and software/community support still make it the best option, though, until the whole loop moves to the phone like AAPS
Or to rephrase: wadda ya want for $10?
Scott Leibrand
@scottleibrand
Aug 08 2018 19:18
lol
Zach Gohr
@zgohr
Aug 08 2018 19:31
how close is the AAPS loop to oref1 in terms of what it does? is it basically the same?
Scott Leibrand
@scottleibrand
Aug 08 2018 19:32
which version?
AAPS RC6 has oref1 features (SMB + UAM), but not autotune
Zach Gohr
@zgohr
Aug 08 2018 19:35
how much does it affect phone battery?
Scott Leibrand
@scottleibrand
Aug 08 2018 19:41
I haven't heard of any reports of shorter battery life on AndroidAPS 2 vs 1. AAPS caches interim calculations, whereas oref0 recalculates everything each run.
that has some interesting implications for exercise mode, for example. if we wanted to keep state on the rig, it would require some very careful engineering. I suspect there are some other optimizations that would make sense to do before that, but it'd require someone more skilled in performance optimization than me to find them.
Adi Barilan
@Adidushi
Aug 08 2018 19:55
Heyo, can anyone help me out with this issue?
My loop often waits for a bg from my g4 receiver via usb (non-share) and just can't read it, and then I can't loop
It randomly stops working for anywhere between an hour to a couple of days
Scott Leibrand
@scottleibrand
Aug 08 2018 20:02
How does “just can’t read it” manifest?
PieterGit
@PieterGit
Aug 08 2018 20:44
@Adidushi have you shutdown and restart your g4?
or check your cable
Adi Barilan
@Adidushi
Aug 08 2018 20:50
@scottleibrand typing 'l' shows that it waits for now bg then after 4 minutes says pump loop failed
@PieterGit haven't tried restarting it, I'll try now
Scott Leibrand
@scottleibrand
Aug 08 2018 20:50
what does cgm-loop.log show?
tail -n 100 -F /var/log/openaps/cgm-loop.log
Adi Barilan
@Adidushi
Aug 08 2018 20:59
cgm/g4-glucose.json has < 24h worth of data
2018/08/08 23:58:15 PAPERTRAIL environment variable is not set
2018/08/08 23:58:15 read 0 entries from cgm/g4-glucose.json
2018/08/08 23:58:15 CGM clock difference = 1.288278056s
2018/08/08 23:58:15 retrieving records since 2018-08-07 17:58:14
2018/08/08 23:58:15 stopping SensorData scan at 2018-08-07 17:58:00
2018/08/08 23:58:16 stopping EGVData scan at 2018-08-07 17:58:01
2018/08/08 23:58:16 stopping MeterData scan at 2018-08-07 00:19:24
2018/08/08 23:58:16 stopping CalibrationData scan at 2018-08-07 00:23:02
2018/08/08 23:58:16 704 CGM records
2018/08/08 23:58:17 out-of-order glucose entries (delta = -58s)
panic: out-of-order glucose entries (delta = -58s)

goroutine 1 [running]:
log.Panicf(0x3071d1, 0x29, 0x1203d8fc, 0x1, 0x1)
        /usr/lib/go-1.10/src/log/log.go:333 +0xa4
github.com/ecc1/dexcom.mergeGlucoseEntries(0x12148000, 0x2c0, 0x2c0, 0xe, 0x4912b0, 0x0)
        /home/ecc/go/src/github.com/ecc1/dexcom/nightscout.go:89 +0x60c
github.com/ecc1/dexcom.NightscoutEntries(0x1213e000, 0x2c0, 0x2c0, 0x1, 0x1, 0x2c0)
        /home/ecc/go/src/github.com/ecc1/dexcom/nightscout.go:18 +0x12c
main.getCGMInfo()
        /home/ecc/go/src/github.com/ecc1/dexcom/cmd/g4update/main.go:111 +0x4fc
main.main()
        /home/ecc/go/src/github.com/ecc1/dexcom/cmd/g4update/main.go:59 +0x7c
Found  calibration records.
@scottleibrand
Scott Leibrand
@scottleibrand
Aug 08 2018 21:04
there's your problem: panic: out-of-order glucose entries (delta = -58s)
perhaps @ecc1 would have some suggestions for troubleshooting that
PieterGit
@PieterGit
Aug 08 2018 21:31
@Adidushi aha, this is 0.7.0. not much experience with. the EU dexcoms G4 (without share) can sometimes stop recognize cgm-values (both on the receiver and via USB). in that case reboot the receiver and try to enter glucose value. in most cases after a while 5-20 minutes it then will function again
Adi Barilan
@Adidushi
Aug 08 2018 21:34
I restarted it but it still doesn't work
Scott Leibrand
@scottleibrand
Aug 08 2018 21:36
it probably won't work until those out-of-order glucose entries expire out of the timeframe being queried
Adi Barilan
@Adidushi
Aug 08 2018 21:41
How do those happen?
Scott Leibrand
@scottleibrand
Aug 08 2018 21:46
no idea: I've never seen it before
and I'm not very familiar with the low-level ecc1/dexcom code
Eric
@ecc1
Aug 08 2018 22:48
@Adidushi do you know if you changed your G4 Receiver's time setting in the last 24 hours? (Or does any part of openaps do that automatically?)
Scott Leibrand
@scottleibrand
Aug 08 2018 22:55
yes, oref0-set-device-clocks can do that automatically
Eric
@ecc1
Aug 08 2018 23:01
I can certainly avoid panicing there, but then there will be out-of-order glucose entries. Does the rest of the openaps code handle that OK, or should I also sort them? That (sorting) sounds like it might mask some more serious problem
garykidd
@garykidd
Aug 08 2018 23:02
@cluckj 1 day is equal to 2802 hours
I mean on venus it is.
but it'll actually depend on where you are and how fast you may be going if you believe Einstein at all...you know...its relative and stuff like that.
alimhassam
@alimhassam
Aug 08 2018 23:29
Does the G4 receiver have records for time change similar to the pump?