These are chat archives for nightscout/intend-to-bolus

21st
Aug 2018
MarvelousMarvin
@MarvelousMarvin
Aug 21 2018 00:44
I was having problems with an error about bg to old, suspended temp basals. Look like the problem was an underclocked rig. After reversing the underclocking the problems looks resolved.
Scott Leibrand
@scottleibrand
Aug 21 2018 00:46
what BG source?
MarvelousMarvin
@MarvelousMarvin
Aug 21 2018 00:48
Xdrip
Scott Leibrand
@scottleibrand
Aug 21 2018 00:59
not sure why underclocking would make it too slow getting BG from xdrip. any ideas?
MarvelousMarvin
@MarvelousMarvin
Aug 21 2018 01:02
I am not at all experienced in this. But the whole process was so slow, a full cycle was maybe out lasting the bg time?
Zach Gohr
@zgohr
Aug 21 2018 01:08
@MarvelousMarvin how far was your underclock? do you have your rig in a case (is it hot?)
MarvelousMarvin
@MarvelousMarvin
Aug 21 2018 01:15
500
The 3d printed case, did not get really hot.
bryce
@bryce2071
Aug 21 2018 07:38
@PieterGit Explorer Block
bryce
@bryce2071
Aug 21 2018 09:50
@scottleibrand Hi Scott, do you know, we talked about what could be wrong because of the radio error above and another one. how the radio error above is back. don't know why! New battery s in, runned setup again. does this radio errors come from explorer block or Edison?
Paper
@PaperT1D
Aug 21 2018 10:20
i had a problem with underclocking as well maybe a week and a half ago. underlocked to 500. data was bring received fine from nightscout and it was uploading boluses fine, but it wouldnt update the openaps or pump pills. and i was getting more frequent errors than usual about being unable to parse meal.json
lyntonr
@lyntonr
Aug 21 2018 11:06
@ecc1 here is the pump history file using pumphistory -a using dev-0-7-0 it was about 8 commits behind I updated and ran again but file was much shorter so I am providing this one. Can provide another if required though.
lyntonr
@lyntonr
Aug 21 2018 11:19
Screenshot (12).png
lyntonr
@lyntonr
Aug 21 2018 11:25
In the short time before I could stop the loop after logging in it still managhed to create some "future entries" on nightscout note that these times are recent but are not in the future.
lotte
@loettz_twitter
Aug 21 2018 12:44
@scottleibrand The message "Error: pumphistory too old" comes from oref0-pump-loop.sh in the function "smb_reservoir_before". (# Refresh reservoir.json and pumphistory.json). I tried the commands in from the function manually and "grep -q pumphistory" failed. Any Idea? @danamlewis
lotte
@loettz_twitter
Aug 21 2018 13:14
another thing I recognized is that when I reboot the rig the first loop runs succesful. After that I'm having future entries in nightscout and the following loops fail with 'pumphistory too old'. when I delete the future entries and resboot again I get another succesful loop but future entries are coming back. Timezone on rig and ns are both European/Berlin
Zach Gohr
@zgohr
Aug 21 2018 14:04
@PaperT1D that’s interesting that the meal.json errors might be related to under clocking. i’ve been trying to debug that every time i get it
wfeddern
@wfeddern
Aug 21 2018 14:40
Was able to send my pi HAT back in for replacement, but now I have to go at least a couple weeks before I can loop again :(
question on autotune, when using to make decisions on basal adjustments, do I need to look at each individual day and determine myself where makes sense to make changes, or if I set it to run on last week of data, are the results cummulative based on the previous days? If I have it running nightly, does it show results from the past day only, or based on some length of history?
Scott Leibrand
@scottleibrand
Aug 21 2018 15:03
It’s cumulative.
Eric
@ecc1
Aug 21 2018 15:17
@lyntonr I verified that there are no duplicates in either the raw pump history retrieved from the pump, or the openaps-format version that's created with the jq script. So it's probably the issue on the NS side that others have identified.
lyntonr
@lyntonr
Aug 21 2018 15:35
I'm only getting it with with openAps androidaps which I have switch to now (although only with virtual pump) is not getting this problem.
Dana Lewis
@danamlewis
Aug 21 2018 15:56
@loettz_twitter what kind of future entries are you getting, and how far in the future are they?
PeetuHongisto
@PeetuHongisto
Aug 21 2018 17:42
root@murunedison:~# bluetoothctl
Agent registered
[bluetooth]# power off
No default controller available
where did my controller go? and where to find it?
Scott Leibrand
@scottleibrand
Aug 21 2018 17:47
under the couch cushions? ;-p
you might try power-cycling the Edison
PeetuHongisto
@PeetuHongisto
Aug 21 2018 17:51
i assume that's not reboot...
shutdown now?
couch cushions on provided with some used test strips :D
only...
Scott Leibrand
@scottleibrand
Aug 21 2018 17:52
heh
shutdown, turn off power, and turn it back on, ya
PeetuHongisto
@PeetuHongisto
Aug 21 2018 17:57
wohoo, i found my controller :) thanks a bunch
Dave Rich
@drich4608
Aug 21 2018 19:07

I just set up my second rig and ran into this, I've Reflashed the edison and ran initialsetup script after troubleshooting for 2 hrs last night, any suggestions? Could it be a host name confusion on the edison? Starting oref0-pump-loop at Tue Aug 21 14:35:02 EDT 2018 with 4 second wait_for_silence:
Waiting up to 4 minutes for new BG: ls: cannot access /tmp/pump_loop_completed: No such file or directory
mmeowlink.exceptions.CommsException: Could not get subg_rfspy state or version. Have you got the right port/device and radio_type?

Radio check failed. mmeowlink.exceptions.CommsException: Could not get subg_rfspy state or version. Have you got the right port/device and radio_type?
Listening for 40s silence before mmtuning:

Dana Lewis
@danamlewis
Aug 21 2018 20:23
@drich4608 did you try flashing ccprog on that rig?
Dave Rich
@drich4608
Aug 21 2018 20:50
No, I'm not sure what the is :p.. I've found some discrepancies in the wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf ...I used the boot strap auto set up after flashing. Going over all of the dependancies. Would errors in that file generate the mmeowlink.exceptions? Will find out in a few minutes.... Then try ccprog.
Scott Leibrand
@scottleibrand
Aug 21 2018 20:52
are the two LEDs right next to each other beside the USB ports dimly illuminated?
Dave Rich
@drich4608
Aug 21 2018 20:56
yes..
Scott Leibrand
@scottleibrand
Aug 21 2018 20:58
then you need to download and run ccprog. search for it in the docs
Dave Rich
@drich4608
Aug 21 2018 21:02
Ok, thanks so much...my first edison seems to be having wifi/bt intermittent connections so it maybe on its way out.
Dave Rich
@drich4608
Aug 21 2018 21:36
The lights are off now. Still showing the same error in log. will wait and try ccprog again if no resolve. What should I see after entering....killall -g oref0-pump-loop; openaps mmtune..?
Scott Leibrand
@scottleibrand
Aug 21 2018 21:49
are you using 0.6.x master, or 0.7.0 dev?
Dave Rich
@drich4608
Aug 21 2018 21:52
0.6.2
Scott Leibrand
@scottleibrand
Aug 21 2018 21:55
k. openaps mmtune should report mmtune: and then a signal strength and best frequency
Dave Rich
@drich4608
Aug 21 2018 21:58
@scottleibrand heres what I get back....i:~# killall -g oref0-pump-loop; openaps mmtune
Not an openaps environment, run: openaps init
Dave Rich
@drich4608
Aug 21 2018 22:04
i:~# openaps mmtune
Not an openaps environment, run: openaps init
Dana Lewis
@danamlewis
Aug 21 2018 22:04
cd myopenaps first
Dave Rich
@drich4608
Aug 21 2018 22:07
this what came back.....
:~/myopenaps# killall -g oref0-pump-loop; openaps mmtune
mmtune: pump://JSON/mmtune/monitor/mmtune.json
monitor/mmtune.json raised Could not get subg_rfspy state or version. Have you got the right port/device and radio_type?
Traceback (most recent call last):
File "/usr/local/bin/openaps-report", line 82, in <module>
app( )
File "/usr/local/lib/python2.7/dist-packages/openaps/cli/init.py", line 51, in call
self.run(self.args)
File "/usr/local/bin/openaps-report", line 75, in run
output = app(args, self)
File "/usr/local/lib/python2.7/dist-packages/openaps/cli/subcommand.py", line 52, in call
return self.method.main(args, app)
File "/usr/local/lib/python2.7/dist-packages/openaps/reports/invoke.py", line 40, in main
output = task.method(args, app)
File "/usr/local/lib/python2.7/dist-packages/openaps/uses/use.py", line 44, in call
self.before_main(args, app)
File "/usr/local/lib/python2.7/dist-packages/openaps/vendors/medtronic.py", line 62, in before_main
self.setup_medtronic( )
File "/usr/local/lib/python2.7/dist-packages/mmeowlink/vendors/mmeowlink.py", line 92, in setup_medtronic
setup_medtronic_link(self)
File "/usr/local/lib/python2.7/dist-packages/mmeowlink/vendors/mmeowlink.py", line 75, in setup_medtronic_link
link = builder.build(radio_type, port)
File "/usr/local/lib/python2.7/dist-packages/mmeowlink/link_builder.py", line 16, in build
return SubgRfspyLink(port)
File "/usr/local/lib/python2.7/dist-packages/mmeowlink/vendors/subg_rfspy_link.py", line 55, in init
self.open()
File "/usr/local/lib/python2.7/dist-packages/mmeowlink/vendors/serial_interface.py", line 28, in open
self.check_setup()
File "/usr/local/lib/python2.7/dist-packages/mmeowlink/vendors/subg_rfspy_link.py", line 72, in check_setup
self.serial_rf_spy.sync()
File "/usr/local/lib/python2.7/dist-packages/mmeowlink/vendors/serial_rf_spy.py", line 121, in sync
raise CommsException("Could not get subg_rfspy state or version. Have you got the right port/device and radio_type?")
mmeowlink.exceptions.CommsException: Could not get subg_rfspy state or version. Have you got the right port/device and radio_type?
Usage: grep [OPTION]... PATTERN [FILE]...
Try 'grep --help' for more information.
Daniel Harrelson
@danielharrelson
Aug 21 2018 22:09
I don't know if this belongs in here or not, but i ordered a 4500 mah battery off amazon. it seems it's "keyed" incorrectly... the red and the black are reversed on the JST, is it possible to recrimp, or should i ship back to seller?
Daniel Harrelson
@danielharrelson
Aug 21 2018 22:14
actually, i was able to pull the pins out without damaging the connector... i reversed them, and everything is good to go. crisis averted :)
Scott Leibrand
@scottleibrand
Aug 21 2018 22:18
good job checking to make sure the polarity was correct and fixing it first
Daniel Harrelson
@danielharrelson
Aug 21 2018 22:19
i did not realize how big this battery was, 2 x 3", think it'll work in the tally gear case, or do i need to downsize ? (i don't have tally gear case yet)
Scott Leibrand
@scottleibrand
Aug 21 2018 22:21
not all the tallygear cases are the same size, so dunno
Dana Lewis
@danamlewis
Aug 21 2018 22:22
they're pretty stretchy and flexible - so probably, might just fill it more than a smaller battery
Daniel Harrelson
@danielharrelson
Aug 21 2018 22:23
👍
Daniel Harrelson
@danielharrelson
Aug 21 2018 22:29
What kind of antenna connection is on the board? Looks smaller than mcx
(I'm hoping tp source one locally) also, does it make a big gain on WW pumps?
Scott Leibrand
@scottleibrand
Aug 21 2018 22:32
there's a link in the docs to the mouser antenna we use, which has all the details
Daniel Harrelson
@danielharrelson
Aug 21 2018 22:40
I saw the mouser, i didn't see the connection type. I'll look again
Scott Leibrand
@scottleibrand
Aug 21 2018 22:43
I think it's u.fl or something
Daniel Harrelson
@danielharrelson
Aug 21 2018 22:45
I see that now on the site :) Locally, I have "the wire man" (HAM RADIO) and can probably get an antenna within a day or two as opposed to waiting 2 weeks ;)