These are chat archives for nightscout/intend-to-bolus

24th
Aug 2018
Lin
@denglfddd
Aug 24 2018 03:48

* PSH loader *
PCM page cache size = 192 KB
Cache Constraint = 0 Pages
Arming IPC driver ..
Adding page store pool ..
PagestoreAddr(IMR Start Address) = 0x04899000
pageStoreSize(IMR Size) = 0x00080000

Ready to receive application

When I plugged edison into my cable
Mac, it seems to stop, someone knows what is going on?
Tore Bjørndalen
@BjoTore_twitter
Aug 24 2018 09:11
Fri 24 Aug 11:05:04 CEST 2018
Not an openaps environment, run: openaps init
I'm getting this in cgm-loop.log? I run Rpi0 with explorer HAT dev branch (just updated) and using xdrip CGM.
ElwinABC
@ElwinABC
Aug 24 2018 11:25
Hi, I had a problem with a 100% full disk of my Edison. This problem is solved, but my rig has a problem with connecting to my home wifi (or other wifi-routers). It does not connect to the wifi router, but keeps connected to my iphone with BT tethering. I have run this script which is advised in de OpenAPS docs in case of wifi problems. cd ~/src
git clone https://github.com/TC2013/edison_wifi
cd edison_wifi
chmod 0755 /root/src/edison_wifi/wifi.sh
The following error messages is displayed ? Does anybody know how to solve this?
root@elwinrig:~/src# git clone https://github.com/TC2013/edison_wifi
Cloning into 'edison_wifi'...
fatal: unable to access 'https://github.com/TC2013/edison_wifi/': Could not resolve host: github.com
root@elwinrig:~/src# cd edison_wifi
-bash: cd: edison_wifi: No such file or directory
Garrett Webb
@garetis
Aug 24 2018 12:36
It looks like there's a button on the Explorer board that pairs with the Edison -- what exactly does that button do?
wfeddern
@wfeddern
Aug 24 2018 14:07
@ElwinABC sounds like either DNS or gateway issue. Can you try to ping github.com and see if it resolves. maybe try a few others too like www.google.com. Have not setup bluetooth tethering myself so not sure how the DNS and routing should look.
Garrett Webb
@garetis
Aug 24 2018 14:53
@alimhassam Ah, perfect. That's what I was hoping for. I either forgot reading that or missed it, but thanks for the info.
Andrew Kirkby
@kirkbysound
Aug 24 2018 16:02
I'm having a bit of a strange nightscout issue. Rig is looping fine, but the NS page says openaps isn't looping and it's missing data that would normally be sent back from the rig. I'll dig into the loop logs but has anyone seen an issue lately before I do? Perhaps a service down or similar?
Scott Leibrand
@scottleibrand
Aug 24 2018 16:21
Probably a full mongo collection. See docs for details.
ElwinABC
@ElwinABC
Aug 24 2018 18:12
@wfeddern this is the ping result:
root@elwinrig:~# ping github.com
ping: unknown host github.com
root@elwinrig:~# ping www.google.com
ping: unknown host www.google.com
Scott Leibrand
@scottleibrand
Aug 24 2018 18:14
you won't be able to do that while the rig is offline: you'll need to get it online somehow first
ElwinABC
@ElwinABC
Aug 24 2018 18:23
but received the following error message

network={
ssid="Sitecom09251bBedstefar"
psk=""
}

Attempting to bring up wlan0:

ifdown: interface wlan0 not configured
wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
Failed to bring up wlan0.

Scott Leibrand
@scottleibrand
Aug 24 2018 18:26
that network stanza is incorrect
either you need to specify the password in the psk field, or if it doesn't have one you have to do it differently
ElwinABC
@ElwinABC
Aug 24 2018 18:47
I'm not at home at the moment and the wifi network here has no password. I will try it at home again (after the weekend). Many thanks for your help so far.
wfeddern
@wfeddern
Aug 24 2018 18:49
@ElwinABC quick google search looks like what you want is:
network={
ssid="Sitecom09251bBedstefar"
key_mgmt=NONE
}
Scott Leibrand
@scottleibrand
Aug 24 2018 19:05
:+1: exactly
ElwinABC
@ElwinABC
Aug 24 2018 20:17
I'm not able to connect to the wifi network. Only Internet through BT tether. I rebooted the rig and read some error messages in the start-up process. Are these messages normal?
[FAILED] Failed to start dnsmasq - A lightweight DHCP and caching DNS server.
See 'systemctl status dnsmasq.service' for details.
[DEPEND] Dependency failed for Host and Network Name Lookups.
[ OK ] Started Login Service.
Starting Hostname Service...
Starting Load/Save RF Kill Switch Status of rfkill3...
[ OK ] Reached target Bluetooth.
[FAILED] Failed to start Hostname Service.
See 'systemctl status systemd-hostnamed.service' for details.
I checked the 'systemctl status systemd-hostnamed.service' for details:

root@elwinrig:~# systemctl status systemd-hostnamed.service
● systemd-hostnamed.service - Hostname Service
Loaded: loaded (/lib/systemd/system/systemd-hostnamed.service; static)
Active: failed (Result: exit-code) since Fri 2018-08-24 22:02:02 CEST; 26s ago
Docs: man:systemd-hostnamed.service(8)
man:hostname(5)
man:machine-info(5)
http://www.freedesktop.org/wiki/Software/systemd/hostnamed
Process: 575 ExecStart=/lib/systemd/systemd-hostnamed (code=exited, status=226/NAMESPACE)
Main PID: 575 (code=exited, status=226/NAMESPACE)

Aug 24 22:02:02 elwinrig systemd[575]: Failed at step NAMESPACE spawning /l...ry
Aug 24 22:02:02 elwinrig systemd[1]: systemd-hostnamed.service: main proces...CE
Aug 24 22:02:02 elwinrig systemd[1]: Failed to start Hostname Service.
Aug 24 22:02:02 elwinrig systemd[1]: Unit systemd-hostnamed.service entered...e.
Hint: Some lines were ellipsized, use -l to show in full.

Scott Leibrand
@scottleibrand
Aug 24 2018 20:49
the hostname service failure is normal. not sure about the dnsmasq thing: do you have the offline hotspot enabled? what does network.log show?
GlossySwan
@GlossySwan
Aug 24 2018 21:26
Good evening all,
Am attempting first build on a Raspberry Pi 3, using iMac and Pi Bakery
Repeatedly hanging at final stage of OpenAPS install with a message:
Fatal:unable to connect to GitHub.com:
GitHub.com (IP address): errno:Connection timed out
This appears to be different from earlier problems about drive capacity listed above - I have plenty of room on the drive
Any advice?
ElwinABC
@ElwinABC
Aug 24 2018 21:35

root@elwinrig:~# tail -F /var/log/openaps/network.log
edison:x:1002:100::/home/edison:/bin/bash

Starting oref0-online at Fri Aug 24 23:34:02 CEST 2018.
At Fri Aug 24 23:34:02 CEST 2018 my wifi is not connected
At Fri Aug 24 23:34:02 CEST 2018 my local wifi IP is: unassigned
At Fri Aug 24 23:34:02 CEST 2018 my Bluetooth is connected to iPhoneElwin
At Fri Aug 24 23:34:02 CEST 2018 my local Bluetooth IP is: 172.20.10.2
At Fri Aug 24 23:34:02 CEST 2018 my public IP is: 62.140.137.72
At Fri Aug 24 23:34:03 CEST 2018 my local hotspot is not running (and not enable d in preferences.json)
Finished oref0-online at Fri Aug 24 23:34:03 CEST 2018.

I don't have an offline hotspot enabled (never used this). I have rig / G5-share / NS setup, and no Dexcom reader
Scott Leibrand
@scottleibrand
Aug 24 2018 21:37
looks like your rig is online via bluetooth
so your pings should work
and you should be able to reach github
ElwinABC
@ElwinABC
Aug 24 2018 21:38
Offline hotspot not enabled in preferences.json
At Fri Aug 24 23:38:04 CEST 2018 my local hotspot is not running
Cycling wlan0
Failed to bring up wlan0.
Finished oref0-online at Fri Aug 24 23:38:06 CEST 2018.
Scott Leibrand
@scottleibrand
Aug 24 2018 21:39
you might also look at /var/log/syslog to see why it's unable to connect to wifi
@GlossySwan same for you: it looks like your wifi is misconfigured
ElwinABC
@ElwinABC
Aug 24 2018 21:40
root@elwinrig:~# ping github.com
PING github.com (192.30.253.112) 56(84) bytes of data.
64 bytes from lb-192-30-253-112-iad.github.com (192.30.253.112): icmp_seq=1 ttl=47 time=246 ms
64 bytes from lb-192-30-253-112-iad.github.com (192.30.253.112): icmp_seq=2 ttl=47 time=445 ms
64 bytes from lb-192-30-253-112-iad.github.com (192.30.253.112): icmp_seq=3 ttl=47 time=947 ms
64 bytes from lb-192-30-253-112-iad.github.com (192.30.253.112): icmp_seq=4 ttl=47 time=366 ms
etc. etc.
GlossySwan
@GlossySwan
Aug 24 2018 21:44
Okay - do you mean wifi in the Raspberry Pi or on my router?
I'm getting good response to Ping

64 bytes from know-sspiprxy-vip.network.virginmedia.net (62.252.172.241): icmp_seq=7 ttl=244 time=19.8 ms

--- github.com ping statistics ---
7 packets transmitted, 7 received, 0% packet loss, time 6009ms
rtt min/avg/max/mdev = 19.865/25.536/31.895/4.005 ms

ElwinABC
@ElwinABC
Aug 24 2018 22:07
I don't understand to much from my /var/log/syslog
Aug 24 23:52:01 localhost Invalid Packet Received - '' - retrying: 1 of 3
Aug 24 23:52:01 localhost CRON[12840]: (CRON) info (No MTA installed, discarding output)
Aug 24 23:52:02 localhost CRON[12839]: (CRON) info (No MTA installed, discarding output)
Aug 24 23:52:02 localhost CRON[12835]: (CRON) info (No MTA installed, discarding output)
Aug 24 23:52:02 localhost Invalid Packet Received - 'Error decoding FourBySix packet' - retrying: 2 of 3
Aug 24 23:52:05 localhost CRON[12837]: (CRON) info (No MTA installed, discarding output)
Aug 24 23:52:05 localhost Invalid Packet Received - '' - retrying: 3 of 3
Aug 24 23:52:10 localhost SubgRfspyLink opening serial port
Aug 24 23:52:10 localhost libmraa[13062]: libmraa version v1.7.0 initialised by user 'root' with EUID 0
Aug 24 23:52:10 localhost libmraa[13062]: gpio214: init: Failed to write to 'export': No such device
Aug 24 23:52:10 localhost libmraa[13062]: edison: Arduino board not detected, assuming Intel Edison Miniboard
Aug 24 23:52:10 localhost libmraa[13062]: libmraa initialised for platform 'Intel Edison' of type 2
Aug 24 23:52:10 localhost subg_rfspy status: OK
Aug 24 23:52:10 localhost Version: subg_rfspy 0.8
Aug 24 23:52:11 localhost Invalid Packet Received - '' - retrying: 1 of 3
Aug 24 23:52:11 localhost Invalid Packet Received - 'Error decoding FourBySix packet' - retrying: 2 of 3
Aug 24 23:52:11 localhost dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 6
Aug 24 23:52:12 localhost Invalid Packet Received - '' - retrying: 3 of 3
Aug 24 23:52:13 localhost root: Uploaded upload/ns-status.json to https://elwin.herokuapp.com
Aug 24 23:52:14 localhost SubgRfspyLink opening serial port
Aug 24 23:52:14 localhost subg_rfspy status: OK
Aug 24 23:52:14 localhost Version: subg_rfspy 0.8
Aug 24 23:52:15 localhost Invalid Packet Received - 'Error decoding FourBySix packet' - retrying: 1 of 3
Aug 24 23:52:15 localhost Invalid Packet Received - 'Error decoding FourBySix packet' - retrying: 2 of 3
Aug 24 23:52:16 localhost Invalid Packet Received - 'Error decoding FourBySix packet' - retrying: 3 of 3
Aug 25 00:10:06 localhost dhclient: No working leases in persistent database - sleeping.
Aug 25 00:10:14 localhost libmraa[19931]: libmraa version v1.7.0 initialised by user 'root' with EUID 0
Aug 25 00:10:14 localhost libmraa[19931]: gpio214: init: Failed to write to 'export': No such device
Aug 25 00:10:14 localhost libmraa[19931]: edison: Arduino board not detected, assuming Intel Edison Miniboard
Aug 25 00:10:14 localhost libmraa[19931]: libmraa initialised for platform 'Intel Edison' of type 2
Aug 25 00:10:16 localhost root: Uploaded upload/ns-status.json to https://elwin.herokuapp.com
Aug 25 00:10:17 localhost libmraa[19953]: libmraa version v1.7.0 initialised by user 'root' with EUID 0
Aug 25 00:10:17 localhost libmraa[19953]: gpio214: init: Failed to write to 'export': No such device
Aug 25 00:10:17 localhost libmraa[19953]: edison: Arduino board not detected, assuming Intel Edison Miniboard
Aug 25 00:10:17 localhost libmraa[19953]: libmraa initialised for platform 'Intel Edison' of type 2
Aug 25 00:10:18 localhost dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 5
Aug 25 00:10:21 localhost CRON[19661]: (CRON) info (No MTA installed, discarding output)
Aug 25 00:10:23 localhost dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 5
Aug 25 00:10:28 localhost dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
Aug 25 00:10:36 localhost dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
Aug 25 00:10:39 localhost dhclient: No DHCPOFFERS received.
Aug 25 00:10:39 localhost dhclient: No working leases in persistent database - sleeping.
Aug 25 00:10:44 localhost SubgRfspyLink opening serial port
Aug 25 00:10:44 localhost libmraa[19997]: libmraa version v1.7.0 initialised by user 'root' with EUID 0
Aug 25 00:10:44 localhost libmraa[19997]: gpio214: init: Failed to write to 'export': No such device
Aug 25 00:10:44 localhost libmraa[19997]: edison: Arduino board not detected, assuming Intel Edison Miniboard
Aug 25 00:10:44 localhost libmraa[19997]: libmraa initialised for platform 'Intel Edison' of type 2
Aug 25 00:10:44 localhost subg_rfspy status: OK
Aug 25 00:10:44 localhost Version: subg_rfspy 0.8
Aug 25 00:10:45 localhost Timed out or other comms error - Received an error response Timeout - retrying: 1 of 3
Aug 25 00:10:45 localhost Timed out or other comms error - Received an error response Timeout - retrying: 2 of 3
Aug 25 00:10:47 localhost Timed out or other comms error - Received an error response Timeout - retrying: 3 of 3
Aug 25 00:10:49 localhost BEGIN POWER CONTROL 616611
Aug 25 00:10:51 localhost dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8