These are chat archives for nightscout/intend-to-bolus

8th
Sep 2018
ericmtx
@ericmtx
Sep 08 2018 03:00
@dougboss I usually have to delete entries in Nightscout mongo database. I go to menu in nightscout then admin tools and use the button to delete all documents in the mongo section. It clears the corrupt data causing the graph not to display correctly. Give it a minute and things show up as expected.
Scott Leibrand
@scottleibrand
Sep 08 2018 05:14
Please donate your data before destroying it.
ideeagit
@ideeagit
Sep 08 2018 07:34
Hi, for breakfast I tried the first time to use OpenAPS for meal. It happens that the eventual BG was 183 and target 130, but nevertheless insulin req was negative and the rig made low temping all the time after the meal. I also adjusted the preferences with bolussnooze dia divisor but still low temps.
So I was going slowly but surely higher and higher.
Paper
@PaperT1D
Sep 08 2018 08:42
Were you trying to let OpenAPS SMB for the meal for you, instead of bolusing manually? Is that what you are saying? Just wanted to clarify.
ideeagit
@ideeagit
Sep 08 2018 08:55
No, I just entered the carbs via NS and insulin via the pump. So just basic OpenAPS mode for meals. I´m beginner...
I did a manual bolus
and ate my carbs for breakfast
(5,5 units, 60g carbs)
Paper
@PaperT1D
Sep 08 2018 09:01
what do you have your max_iob set to in your preferences?
ideeagit
@ideeagit
Sep 08 2018 09:03
7
Paper
@PaperT1D
Sep 08 2018 09:06
did you have a temp target set or is 130 your normal target?
ideeagit
@ideeagit
Sep 08 2018 09:10
130 is my normal target, a second ago I adjusted it to 110
Paper
@PaperT1D
Sep 08 2018 09:23
are you running autosens?
ideeagit
@ideeagit
Sep 08 2018 09:28
For some reason the new setup script which i installed interactively did not ask if i want to use autosens, though i think it runs automatically cose i have autosens_min and autosens_max as variables [0,7;1,2] in my preferences.
Paper
@PaperT1D
Sep 08 2018 09:28
you can check with autosens-looplog
if you said yes to autotune i believe it automatically says yes to autosens
ideeagit
@ideeagit
Sep 08 2018 09:29
autosens-looplog command says there is a ratio of 1... Would it help sharing pics of my pref and log?
Preferences and Pump-loop-log. It is safe to share it here right, as long not posting serial number or NS secrets (passwords)...?
Paper
@PaperT1D
Sep 08 2018 09:30
possibly, im far from an expert, but i spend a shameful amount of hours staring at nightscout
yeah add ``` before and after
with autosens was just curious if there were any UAM (indicated by u's) after that meal
ideeagit
@ideeagit
Sep 08 2018 09:41
Low_temping.JPG
preferences.JPG
ideeagit
@ideeagit
Sep 08 2018 09:47
enable_UAM: false,
I switched UAM off
ideeagit
@ideeagit
Sep 08 2018 09:56
The first pic shows
Eventual BG is much higher than the target and Dev are also very high and a tick of
15, though it should not be reasonable to low temp
Doug
@dougboss
Sep 08 2018 14:01
@ericmtx thanks - tried that didnt help ... I already donate my data ... Still no SMB or openaps basal changes showing on the main graph, but the openaps pill shows them happening
Scott Leibrand
@scottleibrand
Sep 08 2018 15:18
What does ns-loop.log show on the rig?
@ideeagit you’ll probably get better results with UAM than without. What did the purple prediction lines (predBG arrays) show? Was BG predicted to drop low from the big bolus before eventually rising?
mkericson
@mkericson
Sep 08 2018 17:29
Have a new edison I've been running for about 3 weeks. Not sure but think something got corrupted with a bad charge cord. I've attempted to rerun the script and get the following: Removing any existing git in /root/myopenaps/.git
Removed any existing git
Checking openaps 0.2.1 installation with --nogit support
openaps 0.2.1-dev
Checking /root/myopenaps: mkdir: cannot create directory ‘/root/myopenaps’: File exists
/root/myopenaps initialized
mv: error writing ‘./oref0-runagain.sh’: No space left on device
mv: failed to extend ‘./oref0-runagain.sh’: No space left on device
/root/src/decocare/ already exists; pulling latest 0.1.0-dev
fatal: unable to write new index file
Couldn't pull latest decocare 0.1.0-dev
root@MarksAPS3:~# du -xh -d 3 | egrep "[1-9][0-9][0-9]M|[0-9]G"
118M ./src/decocare
231M ./src
246M .
root@MarksAPS3:~# dir
crontab.old.txt crontab.txt kernel.config myopenaps src
  • Any thoughts?
ideeagit
@ideeagit
Sep 08 2018 17:57
@scottleibrand okay UAM is then better even when I enter carbs? Yes, in the very beginning after the meal bolus the purple prediction lines predicted to drop very low, but then settled at a normal level. For info: I entered carbs in NS.
Scott Leibrand
@scottleibrand
Sep 08 2018 17:59
Yes, UAM provides an alternate prediction independent of carb entry. When you do enter carbs, it uses both to make a better prediction of what’s going to happen than it can do with the COB based prediction alone.
It’s fairly common to see zero temping right after a full meal bolus: until it sees carb absorption, the algorithm assumes it might be slow to ramp up, which can result in a low before all the carbs absorb. So it’d rather zero temp initially and then give extra insulin as soon as it’s clear it’ll be needed.
Paper
@PaperT1D
Sep 08 2018 18:58
Yeah,
yeah
Damnit I hate iPhone sometimes. Anyway, your IOB had you predicted to go low. I’d assume that’s why it zero/low temps.