These are chat archives for nightscout/intend-to-bolus

17th
Sep 2018
Scott Leibrand
@scottleibrand
Sep 17 2018 00:18
@marafie cd ~/src/oref0 first.
Zach Gohr
@zgohr
Sep 17 2018 02:13
@rsilvers129 If you ever get things figured out, please let me know. We’ve had similar results. One other thing that seems to help us quite a bit is putting an emphasis on being at target when eating, especially foods with lower glycemic index. But no silver bullets.
Raymond Richmond
@PedanticAvenger
Sep 17 2018 02:17
Anyone have a link handy to docs about setting up g5 bluetooth direct to edison rather than via xdrip or receiver? Want to research before I make a choice.
tepidjuice
@tepidjuice
Sep 17 2018 02:19
Don't want to order from Mouser due to the postage cost.
rsilvers129
@rsilvers129
Sep 17 2018 02:27
@zgohr Ok. I ran into some snags with Stringify where it didn’t work as expected, but think I am past that now. Doing a test right now.
alimhassam
@alimhassam
Sep 17 2018 03:21
@PedanticAvenger you could try xdrip-js see the documentation here. There is also now an xdrip-js option on the oref0-setup script in dev
Jens Heuschkel
@juehv
Sep 17 2018 07:24
Did somebody try NiZn AAA rechargeable batteries for the pump already?
Ryan Dalisky
@rdalisky
Sep 17 2018 13:25
Anyone running DEV with an enlite sensor yet?
Jens Heuschkel
@juehv
Sep 17 2018 13:27
@rdalisky yes on a Pi0 + HAT rig
Ryan Dalisky
@rdalisky
Sep 17 2018 13:29
@juehv Should work on my explorer then? If so I’ll jump on it this afternoon.
Raymond Richmond
@PedanticAvenger
Sep 17 2018 14:39
Thanks @alimhassam That is exactly the link I was looking for.
Ryan Dalisky
@rdalisky
Sep 17 2018 15:27
DEV working on 723 pump with explorer and MDT sensor.
rsilvers129
@rsilvers129
Sep 17 2018 16:58
Did OpenAPS get significantly more power efficient in the last year? On a 2500 battery, I went 15.5 hours and only got down to an indicated reading of 50%.
Dana Lewis
@danamlewis
Sep 17 2018 18:29
Not surprising. (And are you on master or dev? Dev has additional power savings due to the rework of radio code compare to master, but there have been plenty of changes to master in past year?
Jens Heuschkel
@juehv
Sep 17 2018 18:35
@rdalisky think it will work, yes. Give us feedback if you have some issues :)
Samuchco
@Samuchco
Sep 17 2018 18:58
Can some one translate this code for me please?
1-59/2 /root/src/edison_wifi/wifi.sh google.com 2>&1 | logger -t wifi-reset
Samuchco
@Samuchco
Sep 17 2018 19:10
specifically the 1-59/2 . What does it do?
Daiwenqian
@Daiwenqian
Sep 17 2018 19:19
Hey all! I have recently returned to my project of building an OpenAPS system. I set my project aside about 1.5 years ago. The last part that I worked on was flashing my edison board and setting up the login. I have since forgotten the login for my edison for jubilinux. Does anyone have an idea on how to either enter recovery mode, or force a new flash of jubilinux?
Jeremy Cunningham
@jpcunningh
Sep 17 2018 19:28
@Samuchco, it appears to me you have a fragment of a crontab line. The 1-59/2 is saying for values 1-59 of the field (minute, hour, day of month, etc) run the line every second value. However, you appear to be missing the some of the fields. There should be 5 fields before the command, minute, hour, day of month, month, and day of week.
1-59/2 doesn't appear to be a valid day of week, so maybe some asterisks are missing... I would guess the line would possibly be as shown below to run the command every 2 minutes:
1-59/2 * * * * /root/src/edison_wifi/wifi.sh google.com 2>&1 | logger -t wifi-reset
Dana Lewis
@danamlewis
Sep 17 2018 19:54
@Daiwenqian you can just start the flash over.
Daiwenqian
@Daiwenqian
Sep 17 2018 19:57
@danamlewis I am trying to start the flash over. In my previous attempt I had already set up a custom login and psw. :(
Daiwenqian
@Daiwenqian
Sep 17 2018 20:15
Nevermind.... I found my password. I are dumb
marafie
@marafie
Sep 17 2018 20:42
Hi... I reinstalled the oref0 setup
And at the end got this

Downloading Go pump binaries from: https://github.com/ecc1/medtronic/releases/download/v2018.08.08/medtronic-arm-spi.tar.xz
./
./openaps.jq
./cgmpage
./sniff

tar: Skipping to next header
xz: (stdin): Compressed data is corrupt
tar: Child died with signal 13
tar: Error is not recoverable: exiting now
Couldn't download and extract Go pump binaries
root@raspberrypi:~#
root@raspberrypi:~#

Samuchco
@Samuchco
Sep 17 2018 21:53
@jpcunningh for some reason, the copy and paste omitted the asterisks. Thank you
alimhassam
@alimhassam
Sep 17 2018 22:07
@marafie it seems like the go lib tar didn't get downloaded correctly. We should really fix the run again script, but right now you should probably just try to run oref0-setup again
Daiwenqian
@Daiwenqian
Sep 17 2018 22:26
So...I accidentally cntrl-c'd in the middle of Pushover Api set up. Am I doomed to have to go through the whole setup process again?
alimhassam
@alimhassam
Sep 17 2018 22:28
Unfortunately yes @Daiwenqian
You could copy paste your previous answers
Daiwenqian
@Daiwenqian
Sep 17 2018 22:32
ok, it's all good. I just thought I would have to flash it again
Any ideas on the error
message Command /usr/bin/git clone -q https://github.com/openaps/openaps.git /tmp/pip-k5j55A-build failed with error code 128 in None
Storing debug log for failure in /root/.pip/pip.log
Couldn't install openaps w/ nogit
It looks like it couldn't resolve the github hostname
Ok, just rerunning it, and it looks like it might work. Fingers crossed.
Daiwenqian
@Daiwenqian
Sep 17 2018 22:42
My software dev wife stepped in and now won't let me work on the rig, because she wants to. :/
But either way, it's going through the loading process.
Daiwenqian
@Daiwenqian
Sep 17 2018 23:35
Okay, I got oref0 installed on my edison and explorer board. I currently have a 723 pump, will be getting a 722 soon. I just wanted to check if my log looked correct so far. I realize it isn't doing a complete loop.
Starting oref0-pump-loop at Mon Sep 17 17:11:02 MDT 2018 with 17 second wait_for_silence:
Waiting up to 4 minutes for new BG: ls: cannot access /tmp/pump_loop_completed: No such file or directory
Radio ok. Listening: .No interfering pump comms detected from other rigs (this is a good thing!)
Preflight OK. Profile less than 60m old; Profile valid. Refreshed pumphistory and meal.json
Checking pump clock: "2018-09-17T17:10:49-06:00" is within 90s of current time: Mon Sep 17 17:11:47 MDT 20    18
Pump clock is more than 55s off: attempting to reset it
Waiting for ntpd to synchronize... OK!
Setting pump time to Mon Sep 17 17:11:47 MDT 2018
Setting CGM time to Mon Sep 17 17:11:54 MDT 2018
AttributeError: 'NoneType' object has no attribute 'ReadSystemTime'
Temp refreshed
Warning: Autotune has not been run. All microboluses will be disabled until you manually run autotune or a    dd it to run nightly in your loop.
{"carbs":0,"nsCarbs":0,"bwCarbs":0,"journalCarbs":0,"mealCOB":0,"currentDeviation":-2,"maxDeviation":3.28,    "minDeviation":-1.98,"slopeFromMaxDeviation":-0.96,"slopeFromMinDeviation":0,"allDeviations":[-2,-2,-1,1,2    ,3],"lastCarbTime":0,"bwFound":false}
{"iob":0,"activity":0,"basaliob":0,"bolusiob":0,"netbasalinsulin":0,"bolusinsulin":0,"time":"2018-09-17T23    :11:01.000Z","iobWithZeroTemp":{"iob":0,"activity":0,"basaliob":0,"bolusiob":0,"netbasalinsulin":0,"bolusi    nsulin":0,"time":"2018-09-17T23:11:01.000Z"},"lastBolusTime":1537207510000,"lastTemp":{"date":0}}
{"delta":0,"glucose":94,"noise":1,"short_avgdelta":-1,"long_avgdelta":-0.63,"date":1537225687934}
Autosens ratio: 1; Basal unchanged: 1.1; ISF unchanged: 50; CR: 15
currenttemp: { duration: 0, rate: 0, temp: 'absolute' } lastTempAge: 25620432 m tempModulus: 12 m
SMB disabled (!microBolusAllowed)
Carb Impact: -1 mg/dL per 5m; CI Duration: 0 hours; remaining CI (~2h peak): 0 mg/dL per 5m
UAM Impact: -1 mg/dL per 5m; UAM Duration: 0 hours
minPredBG: 89 minIOBPredBG: 89 minZTGuardBG: 94 minUAMPredBG: 89 avgPredBG: 94 COB: 0 / 0
BG projected to remain above 95 for 0 minutes
BG projected to remain above 68 for 240 minutes
naive_eventualBG: 94 bgUndershoot: -26.5 zeroTempDuration: 240 zeroTempEffect: 220 carbsReq: -74
undefined 12
2018-09-17T23:12:04.842Z
Checking deliverAt: 2018-09-17T23:12:04.842Z is within 1m of current time: Mon Sep 17 17:12:05 MDT 2018
and that smb-suggested.json is less than 1m old
enact/smb-suggested.json: {"temp":"absolute","bg":94,"tick":"+0","eventualBG":90,"insulinReq":0,"reservoir    ":"53.4","deliverAt":"2018-09-17T23:12:04.842Z","sensitivityRatio":1,"predBGs":{"IOB":[94,93,92,92,91,90,9    0,89,89,89,89,89,89],"ZT":[94,94,94,94,94,94,94,95,95,96,96]},"COB":0,"IOB":0,"reason":"COB: 0, Dev: -4, B    GI: 0, ISF: 50, CR: 15, Target: 95, minPredBG 89, minGuardBG 89, IOBpredBG 89; Eventual BG 90 < 95, settin    g 0.7U/hr. ","duration":30,"rate":0.7}
Temp refreshed: monitor/temp_basal.json: {"duration":0,"rate":0,"temp":"absolute"}
enact/smb-enacted.json: "Rate: 0 Duration: 0"
Temp refreshed: monitor/temp_basal.json: {"duration":0,"rate":0,"temp":"absolute"}
Checking pump status (suspended/bolusing): {"status":"normal","bolusing":false,"suspended":false}
Temp refreshed: monitor/temp_basal.json: {"duration":0,"rate":0,"temp":"absolute"}
Couldn't smb_enact_temp
oref0-pump-loop failed. pump_loop_completed more than 15m old; waiting for 40s silence before mmtuning
Radio ok. Listening: .No interfering pump comms detected from other rigs (this is a good thing!)
Listening for 40s silence before mmtuning: .No interfering pump comms detected from other rigs (this is a     good thing!)
Am I on the right path to get the read only suggestions functioning?