These are chat archives for nightscout/intend-to-bolus

5th
Oct 2018
Nolan322
@Nolan322
Oct 05 2018 00:29

when I rerun the setup script I get this:

Removing any existing git in /root/myopenaps/.git
Removed any existing git
Checking openaps 0.2.1 installation with --nogit support
openaps 0.2.1-dev
Checking /root/myopenaps: mkdir: cannot create directory ‘/root/myopenaps’: File exists
/root/myopenaps initialized
/root/src/decocare/ already exists; pulling latest 0.1.0-dev
fatal: unable to connect to github.com:
github.com: Name or service not known

Couldn't pull latest decocare 0.1.0-dev
root@Zane:~#

Can someone help me troubleshoot?

Dana Lewis
@danamlewis
Oct 05 2018 00:29
rig is probably not successfully online; check for connectivity
Nolan322
@Nolan322
Oct 05 2018 00:30
@danamlewis edit-wifi?
Scott Leibrand
@scottleibrand
Oct 05 2018 01:38
@tzachi-dar @ecc1 Also, the S/N is broadcast in the clear on all rig-pump communication, so anyone capable of using it is also capable of learning it, unless you’re using the pump but not looping with it.
Benjamin Mammon
@bmammon
Oct 05 2018 03:37
@scottleibrand thanks, I'll try changing DIA to 5 hours and increasing insulinPeakTime to 100 mins
Scott Leibrand
@scottleibrand
Oct 05 2018 03:40
Have you run the new autotune insulinPeakTime tuning feature to see what it recommends?
Benjamin Mammon
@bmammon
Oct 05 2018 03:42
I don't think so! I didn't know that existed
Do I have to do something special or just update to latest branch?
Scott Leibrand
@scottleibrand
Oct 05 2018 04:19
It has to be run manually using oref0 dev. See the command-line help or take a look at the PR to see the new arguments.
peterfulvi
@peterfulvi
Oct 05 2018 13:47
im trying to rerun setup on my rig which is running Lookout to run xdrip with nightscout and keep getting this output
Removing any existing git in /root/myopenaps/.git
Removed any existing git
Checking openaps 0.2.1 installation with --nogit support
openaps 0.2.1-dev
Checking /root/myopenaps: mkdir: cannot create directory ‘/root/myopenaps’: File                                                                                                                      exists
/root/myopenaps initialized
/root/src/decocare/ already exists; pulling latest 0.1.0-dev
Already on '0.1.0-dev'
Your branch is up-to-date with 'origin/0.1.0-dev'.
Already up-to-date.
Installing decocare 0.1.0-dev
running develop
running egg_info
writing requirements to decocare.egg-info/requires.txt
writing decocare.egg-info/PKG-INFO
writing top-level names to decocare.egg-info/top_level.txt
writing dependency_links to decocare.egg-info/dependency_links.txt
reading manifest file 'decocare.egg-info/SOURCES.txt'
reading manifest template 'MANIFEST.in'
warning: no files found matching 'CHANGES.*'
writing manifest file 'decocare.egg-info/SOURCES.txt'
running build_ext
Creating /home/.rootfs/usr/local/lib/python2.7/dist-packages/decocare.egg-link (                                                                                                                     link to .)
decocare 0.1.0-dev is already the active version in easy-install.pth
Installing mm-press-key.py script to /usr/local/bin
Installing mm-send-comm.py script to /usr/local/bin
Installing mm-set-suspend.py script to /usr/local/bin
Installing mm-temp-basals.py script to /usr/local/bin
Installing mm-decode-history-page.py script to /usr/local/bin
Installing mm-latest.py script to /usr/local/bin
Installing mm-bolus.py script to /usr/local/bin
Installing mm-set-rtc.py script to /usr/local/bin
Installing mm-pretty-csv script to /usr/local/bin

Installed /root/src/decocare
Processing dependencies for decocare==0.1.0-dev
Searching for argcomplete==1.9.4
Best match: argcomplete 1.9.4
Adding argcomplete 1.9.4 to easy-install.pth file

Using /home/.rootfs/usr/local/lib/python2.7/dist-packages
Searching for python-dateutil==2.6.1
Best match: python-dateutil 2.6.1
Adding python-dateutil 2.6.1 to easy-install.pth file

Using /home/.rootfs/usr/local/lib/python2.7/dist-packages
Searching for pyserial==3.4
Best match: pyserial 3.4
Adding pyserial 3.4 to easy-install.pth file

Using /home/.rootfs/usr/local/lib/python2.7/dist-packages
Searching for six==1.11.0
Best match: six 1.11.0
Adding six 1.11.0 to easy-install.pth file

Using /home/.rootfs/usr/local/lib/python2.7/dist-packages
Finished processing dependencies for decocare==0.1.0-dev
/root/src/oref0/ already exists; pulling latest
Already up-to-date.
Checking oref0 installation
* master
npm ERR! extraneous: oref0@0.6.2 /home/.rootfs/usr/lib/node_modules/oref0/node_modules/oref0
Installing latest oref0 package
npm WARN deprecated crypto@0.0.3: This package is no longer supported. It's now a built-in Node module. If you've depended on crypto, you should switch to the one that's built-in.
npm WARN deprecated node-uuid@1.4.8: Use uuid module instead
npm WARN deprecated hoek@2.16.3: The major version is no longer supported. Please update to 4.x or newer
/home/.rootfs/usr/lib
└── (empty)

npm ERR! Linux 3.10.17-poky-edison+
npm ERR! argv "/home/.rootfs/usr/bin/node" "/usr/bin/npm" "install" "-g" "oref0"
npm ERR! node v6.13.0
npm ERR! npm  v3.10.10
npm ERR! path /home/.rootfs/usr/lib/node_modules/.staging/aws-sign2-13a73de6
npm ERR! code EXDEV
npm ERR! errno -18
npm ERR! syscall rename

npm ERR! EXDEV: cross-device link not permitted, rename '/home/.rootfs/usr/lib/node_modules/.staging/aws-sign2-13a73de6' -> '/home/.rootfs/usr/lib/node_modules/oref0/node_modules/aws-sign2'
npm ERR!
npm ERR! If you need help, you may report this error at:
npm ERR!     <https://github.com/npm/npm/issues>

npm ERR! Please include the following file with any support request:
npm ERR!     /root/src/oref0/npm-debug.log
npm ERR! code 1
Checking mmeowlink installation
peterfulvi
@peterfulvi
Oct 05 2018 15:08
Ok im hitting a brick wall. I updated my node.js to the latest, reinstalled oref0 and still end up here
```
Using /home/.rootfs/usr/local/lib/python2.7/dist-packages
Finished processing dependencies for decocare==0.1.0-dev
/root/src/oref0/ already exists; pulling latest
Already up-to-date.
Checking oref0 installation
  • master
    Installing latest oref0 package
    npm WARN deprecated crypto@0.0.3: This package is no longer supported. It's now a built-in Node module. If you've depended on crypto, you should switch to the one that's built-in.
    npm WARN deprecated node-uuid@1.4.8: Use uuid module instead
    npm WARN deprecated hoek@2.16.3: The major version is no longer supported. Please update to 4.x or newer
    /home/.rootfs/usr/bin/bt-pan -> /home/.rootfs/usr/lib/node_modules/oref0/bin/bt-pan
    /home/.rootfs/usr/bin/l -> /home/.rootfs/usr/lib/node_modules/oref0/bin/oref0-tail-log.sh
    /home/.rootfs/usr/bin/mm-format-ns-glucose -> /home/.rootfs/usr/lib/node_modules/oref0/bin/mm-format-ns-glucose.sh
    /home/.rootfs/usr/bin/mm-format-ns-profile -> /home/.rootfs/usr/lib/node_modules/oref0/bin/mm-format-ns-profile.sh
    /home/.rootfs/usr/bin/mm-format-ns-pump-history -> /home/.rootfs/usr/lib/node_modules/oref0/bin/mm-format-ns-pump-history.sh
    /home/.rootfs/usr/bin/mm-format-ns-treatments -> /home/.rootfs/usr/lib/node_modules/oref0/bin/mm-format-ns-treatments.sh
    /home/.rootfs/usr/bin/mm-stick -> /home/.rootfs/usr/lib/node_modules/oref0/bin/mm-stick.sh
    /home/.rootfs/usr/bin/monitor-xdrip -> /home/.rootfs/usr/lib/node_modules/oref0/bin/monitor-xdrip.sh
    /home/.rootfs/usr/bin/nightscout -> /home/.rootfs/usr/lib/node_modules/oref0/bin/nightscout.sh
    /home/.rootfs/usr/bin/ns-dedupe-treatments -> /home/.rootfs/usr/lib/node_modules/oref0/bin/ns-dedupe-treatments.sh
    /home/.rootfs/usr/bin/ns-get -> /home/.rootfs/usr/lib/node_modules/oref0/bin/ns-get.sh
    /home/.rootfs/usr/bin/ns-status -> /home/.rootfs/usr/lib/node_modules/oref0/bin/ns-status.js
    /home/.rootfs/usr/bin/ns-upload -> /home/.rootfs/usr/lib/node_modules/oref0/bin/ns-upload.sh
    /home/.rootfs/usr/bin/ns-upload-entries -> /home/.rootfs/usr/lib/node_modules/oref0/bin/ns-upload-entries.sh
    /home/.rootfs/usr/bin/oref0 -> /home/.rootfs/usr/lib/node_modules/oref0/bin/oref0.sh
    /home/.rootfs/usr/bin/oref0-append-local-temptarget -> /home/.rootfs/usr/lib/node_modules/oref0/bin/oref0-append-local-temptarget.sh
    /home/.rootfs/usr/bin/oref0-autosens-loop -> /home/.rootfs/usr/lib/node_modules/oref0/bin/oref0-autosens-loop.sh
    /home/.rootfs/usr/bin/oref0-autotune -> /home/.rootfs/usr/lib/node_modules/oref0/bin/oref0-autotune.sh
    /home/.rootfs/usr/bin/oref0-autotune-core -> /home/.rootfs/usr/lib/node_modules/oref0/bin/oref0-autotune-core.js
    /home/.rootfs/usr/bin/oref0-autotune-export-to-xlsx -> /home/.rootfs/usr/lib/node_modules/oref0/bin/oref0-autotune-export-to-xlsx.py
    /home/.rootfs/usr/bin/oref0-autotune-prep -> /home/.rootfs/usr/lib/node_modules/oref0/bin/oref0-autotune-prep.js
    /home/.rootfs/usr/bin/oref0-autotune-recommends-report -> /home/.rootfs/usr/lib/node_modules/oref0/bin/oref0-autotune-recommends-report.sh
    /home/.rootfs/usr/bin/oref0-bluetoothup -> /home/.rootfs/usr/lib/node_modules/oref0/bin/oref0-bluetoothup.sh
    /home/.rootfs/usr/bin/oref0-calculate-iob -> /home/.rootfs/usr/lib/node_modules/oref0/bin/oref0-calculate-iob.js
    /home/.rootfs/usr/bin/oref0-copy-fresher -> /home/.rootfs/usr/lib/node_modules/oref0/bin/oref0-copy-fresher
    /home/.rootfs/usr/bin/oref0-crun -> /home/.rootfs/usr/lib/node_modules/oref0/bin/oref0-conditional-run.sh
    /home/.rootfs/usr/bin/oref0-delete-future-entries -> /home/.rootfs/usr/lib/node_modules/oref0/bin/oref0-delete-future-entries.sh
    /home/.rootfs/usr/bin/oref0-detect-sensitivity -> /home/.rootfs/usr/lib/node_modules/oref0/bin/oref0-detect-sensitivity.js
    /home/.rootfs/usr/bin/oref0-determine-basal -> /home/.rootfs/usr/lib/node_modules/oref0/bin/oref0-determine-basal.js
    /home/.rootfs/usr/bin/oref0-dexusb-cgm-loop -> /home/.rootfs/usr/lib/node_modules/oref0/bin/oref0-dexusb-cgm-loop.py
    /home/.rootfs/usr/bin/oref0-dex-is-fresh -> /home/.rootfs/usr/lib/node_modules/oref0/bin/oref0-dex-i
Sorry
Error: Cannot find module 'yargs'
    at Function.Module._resolveFilename (module.js:548:15)
    at Function.Module._load (module.js:475:25)
    at Module.require (module.js:597:17)
    at require (internal/module.js:11:18)
    at Object.<anonymous> (/root/src/oref0/bin/oref0-get-profile.js:45:16)
    at Module._compile (module.js:653:30)
    at Object.Module._extensions..js (module.js:664:10)
    at Module.load (module.js:566:32)
    at tryModuleLoad (module.js:506:12)
    at Function.Module._load (module.js:498:3)
Could not run oref0-get-profile
Martin Haeberli
@mhaeberli
Oct 05 2018 18:51
I have some G5 related issues - like signal loss overnight sometimes, with a recent transmitter, recoverable by rebooting iPhone. What is the best forum for discussion? thx
Dana Lewis
@danamlewis
Oct 05 2018 21:18
@mhaeberli I'd talk to Dexcom about that?
Martin Haeberli
@mhaeberli
Oct 05 2018 22:11
k thx @danamlewis