These are chat archives for nightscout/intend-to-bolus

11th
Oct 2018
alimhassam
@alimhassam
Oct 11 2018 01:04
thanks!
it's just to play around with, see if i can get something to work consistently.
Eric
@ecc1
Oct 11 2018 01:05
sure, let me know if there's anything I can answer or help with
dan lightner
@danimaniac
Oct 11 2018 16:34
Insurance coverage recently switched to Admelog. Anybody pumping Admelog through the OpenAPS short acting insulin action curve? I started this morning, but wondered if anyone had any issues? I think the action curves are similar enough...yes?
wfeddern
@wfeddern
Oct 11 2018 19:15
Anyone know the fix to get a rasperry pi rig to do a reboot? it just hangs when I try shutdown -r now
Jon Cluck
@cluckj
Oct 11 2018 19:19
@wfeddern reboot -f?
The pibakery serial console block is broken...
wfeddern
@wfeddern
Oct 11 2018 19:28
@cluckj that worked, thanks.
Abigail Cember
@acember
Oct 11 2018 19:39
@danimaniac What is Admelog?
Scott Leibrand
@scottleibrand
Oct 11 2018 20:42
It’s biosimilar Humalog. Should have a similar curve.
Biosimilar is the equivalent of generic for large biological molecules like insulin (vs. small molecule drugs, where they can prove that the drug ingredient is molecularly identical).
dan lightner
@danimaniac
Oct 11 2018 20:49
@acember As @scottleibrand mentions, ADMELOG is an insulin lispro with an amino acid sequence identical to Humalog. It is manufactured by Sanofi and has a similar, but not identical action curve. I'll report back if any issues occur although I do not expect any.
GMG
@ggirling
Oct 11 2018 22:49

I'm trying to set up a new rig and when I run the cd && ~/src/oref0/bin/oref0-setup.sh it returns the following error:

Could not run nightscout autoconfigure-device-crud

Do I need to remove some directories and if so, can anyone advise what the full command is?

GMG
@ggirling
Oct 11 2018 23:03
After getting confirmation that auto configure for NS has run, the full message is this
added process://ns/nightscout/ns NIGHTSCOUT_HOST API_SECRET
Traceback (most recent call last):
  File "/usr/local/bin/openaps-import", line 26, in <module>
    class ImportToolApp (cli.ConfigApp):
  File "/usr/local/bin/openaps-import", line 37, in ImportToolApp
    MAP = get_importable( )
  File "/usr/local/bin/openaps-import", line 21, in get_importable
    mod = entry.load( )
  File "/home/.rootfs/usr/lib/python2.7/dist-packages/pkg_resources.py", line 2188, in load
    self.require(env, installer)
  File "/home/.rootfs/usr/lib/python2.7/dist-packages/pkg_resources.py", line 2202, in require
    items = working_set.resolve(reqs, env, installer)
  File "/home/.rootfs/usr/lib/python2.7/dist-packages/pkg_resources.py", line 644, in resolve
    raise VersionConflict(dist, req)
pkg_resources.VersionConflict: (six 1.8.0 (/home/.rootfs/usr/lib/python2.7/dist-packages), Requirement.parse('six>=1.9'))
Could not run nightscout autoconfigure-device-crud