These are chat archives for nightscout/intend-to-bolus

28th
Oct 2018
Zach Gohr
@zgohr
Oct 28 2018 00:38
just got pens of fiasp to try mixing with humalog. any tips for exactly how to do that?
Why not
@Whynot2018_gitlab
Oct 28 2018 11:11
@scottleibrand It was experimental.Everyone has this Carelink stick. I believe It's very good opportunity for Openaps to try out.
tepidjuice
@tepidjuice
Oct 28 2018 11:31
Is it possible to have openaps be aware when I manually change from basal pattern A to B on my pump?
alimhassam
@alimhassam
Oct 28 2018 11:52
@tepidjuice it's possible but you'd need to do some dev work
tepidjuice
@tepidjuice
Oct 28 2018 12:01
@alimhassam like?
alimhassam
@alimhassam
Oct 28 2018 12:21
it includes figuring out what dev work is needed :). but from my understanding you might need
1, look at @ecc1 mdt basal command to enhance it retrieve alternate basal patterns if needed
2, Then also properly use and retrieve the changebasalpattern from the pump history.
3, Testing all this.
4, Then depending what you want to do with that information there might be additional things.
Why not
@Whynot2018_gitlab
Oct 28 2018 13:09
@alimhassam do you know how to setup local web interface? Some of the values are missing. At the top left corner BG bar shows only
0

mg/dL
BG NaN min ago
Looped 2 min ago
Is there any file that we could change or add?
alimhassam
@alimhassam
Oct 28 2018 14:08
@Whynot2018_gitlab I'm not sure I don't use it that much
N3FM
@N3FM
Oct 28 2018 15:11
@zgohr which pump/reservoir? Are you trying for a 50:50 mix?
Why not
@Whynot2018_gitlab
Oct 28 2018 16:11
Where stored the latest blood sugar? /monitor/glucose.json
Scott Leibrand
@scottleibrand
Oct 28 2018 18:03
@Whynot2018_gitlab most people don’t have equipment or skills to solder, so acquiring an Explorer board / HAT is easier.
tynbendad
@tynbendad
Oct 28 2018 18:33
(most people, myself included, have trouble assembling a rileylink kit ;)
Ivica Suran
@isuran
Oct 28 2018 18:43
image.png
@Whynot2018_gitlab I get that values when xdrip is sending directly to rig
anybody knows error in uploaded entries. Database is 40MB large, so it's not mlab error. I'm also getting future readings error, that's solved in 0.7 but I need 0.6 for carelink this week until hat arrives
I suppose it's time zone problem.
Why not
@Whynot2018_gitlab
Oct 28 2018 19:06
@isuran error code 66 I don't know but make sure you are using the database username and password not the account username and password from Mlab.
Ivica Suran
@isuran
Oct 28 2018 19:07
nope, I get temp basal in ns, only openaps pill is emptz
empty
Arnoud82
@Arnoud82
Oct 28 2018 19:37
Good evening i have problem tying to setup a new sd for my Pi0 Hat

└── ajv@5.5.2
(node:1568) [DEP0022] DeprecationWarning: os.tmpDir() is deprecated. Use os.tmpdir() instead.
npm WARN deprecated crypto@0.0.3: This package is no longer supported. It's now a built-in Node module. If you've depended on crypto, you should switch to the one that's built-in.
npm ERR! cb() never called!
npm ERR! not ok code 0

npm ERR! oref0@0.7.0-dev global-install: npm install && sudo npm install -g && sudo npm link && sudo npm link oref0
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the oref0@0.7.0-dev global-install script.
npm ERR! This is most likely a problem with the oref0 package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! npm install && sudo npm install -g && sudo npm link && sudo npm link oref0
npm ERR! You can get their info via:
npm ERR! npm owner ls oref0
npm ERR! There is likely additional logging output above.
npm ERR! System Linux 4.14.71+
npm ERR! command "/usr/bin/node" "/usr/bin/npm" "run" "global-install"
npm ERR! cwd /root/src/oref0
npm ERR! node -v v8.11.1
npm ERR! npm -v 1.4.21
npm ERR! code ELIFECYCLE
npm WARN This failure might be due to the use of legacy binary "node"
npm WARN For further explanations, please read
/usr/share/doc/nodejs/README.Debian

npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR! /root/src/oref0/npm-debug.log
npm ERR! not ok code 0
No module named mmeowlink.vendors.mmeowlink
Installing latest mmeowlink
Collecting mmeowlink
Downloading https://files.pythonhosted.org/packages/5a/64/4e65171d73e6390a496177b124cbe936c203934ac21b07e4ad52736266cf/mmeowlink-0.11.1.tar.gz
Requirement already up-to-date: argcomplete in /usr/local/lib/python2.7/dist-packages (from mmeowlink)
Requirement already up-to-date: decocare in /usr/local/lib/python2.7/dist-packages (from mmeowlink)
Requirement already up-to-date: pyserial in /usr/local/lib/python2.7/dist-packages (from mmeowlink)
Requirement already up-to-date: python-dateutil in /usr/local/lib/python2.7/dist-packages (from mmeowlink)
Requirement already up-to-date: six>=1.5 in /usr/local/lib/python2.7/dist-packages (from python-dateutil->mmeowlink)
Building wheels for collected packages: mmeowlink
Running setup.py bdist_wheel for mmeowlink ... done
Stored in directory: /root/.cache/pip/wheels/d0/45/7f/889da6559802d95691541dccec3c9050e8202e8120ee33c820
Successfully built mmeowlink
Installing collected packages: mmeowlink
Successfully installed mmeowlink-0.11.1
cp: cannot stat 'preferences.json': No such file or directory
/root/src/oref0/bin/oref0-setup.sh: line 751: oref0-get-profile: command not found
Could not run oref0-get-profile
root@Alvleesklier:~#

i have used 3 diferend cards but keep getting this
Why not
@Whynot2018_gitlab
Oct 28 2018 19:42
use master branch
Arnoud82
@Arnoud82
Oct 28 2018 19:43
does that work with the pi0?
Ivica Suran
@isuran
Oct 28 2018 19:44
did you run it as root?
Arnoud82
@Arnoud82
Oct 28 2018 19:44
yes i always do this the same way and then it works fine
exept today
Jon Cluck
@cluckj
Oct 28 2018 20:36
Try running it a few times in a row, on the same installation
Arnoud82
@Arnoud82
Oct 28 2018 20:36
@cluckj what do i have to run a few times?
Jon Cluck
@cluckj
Oct 28 2018 20:37
oref0-setup.sh (that's what it looks like you were running)
Arnoud82
@Arnoud82
Oct 28 2018 20:38
ok gone try that im curently installing a new sd at the moment
Arnoud82
@Arnoud82
Oct 28 2018 21:01

@cluckj
moment@2.22.2 node_modules/moment

lodash@4.17.11 node_modules/lodash
(node:1168) [DEP0022] DeprecationWarning: os.tmpDir() is deprecated. Use os.tmpdir() instead.
npm WARN deprecated crypto@0.0.3: This package is no longer supported. It's now a built-in Node module. If you've depended on crypto, you should switch to the one that's built-in.
npm ERR! cb() never called!
npm ERR! not ok code 0

npm ERR! oref0@0.7.0-dev global-install: npm install && sudo npm install -g && sudo npm link && sudo npm link oref0
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the oref0@0.7.0-dev global-install script.
npm ERR! This is most likely a problem with the oref0 package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! npm install && sudo npm install -g && sudo npm link && sudo npm link oref0
npm ERR! You can get their info via:
npm ERR! npm owner ls oref0
npm ERR! There is likely additional logging output above.
npm ERR! System Linux 4.14.71+
npm ERR! command "/usr/bin/node" "/usr/bin/npm" "run" "global-install"
npm ERR! cwd /root/src/oref0
npm ERR! node -v v8.11.1
npm ERR! npm -v 1.4.21
npm ERR! code ELIFECYCLE
npm WARN This failure might be due to the use of legacy binary "node"
npm WARN For further explanations, please read
/usr/share/doc/nodejs/README.Debian

npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR! /root/src/oref0/npm-debug.log
npm ERR! not ok code 0
root@Alvleesklier:~/src/oref0#

was running npm run global-install
Jon Cluck
@cluckj
Oct 28 2018 21:03
Try it a couple more times...
if it fails after a couple retries, run each of the commands that global-install is running separately: npm install sudo npm install -g sudo npm link sudo npm link oref0
Arnoud82
@Arnoud82
Oct 28 2018 21:10
@cluckj it worked the second time i hope the last bit will work also
Jon Cluck
@cluckj
Oct 28 2018 21:12
Yay
I was having similar trouble last night, and I think it's a connectivity issue
Arnoud82
@Arnoud82
Oct 28 2018 21:14
oh ok i never had this before normaly it just works after install
Jon Cluck
@cluckj
Oct 28 2018 21:16
Yep
Ryan Dalisky
@rdalisky
Oct 28 2018 21:40
The two lights on my explorer board, next to the USB plug, are on. I tried to flash the radio, but I get an error stating that
libmraa.so.0 doesnt exist
Any suggestions? Just did a fresh install of Jubilinux.
LilDucky
@LilDucky
Oct 28 2018 21:42
@rdalisky have you installed the latest OpenAPS master and rebooted too? I just did this and had no issues
OpenAPS installs mraa
Jon Cluck
@cluckj
Oct 28 2018 21:43
(master does, dev doesn't)
LilDucky
@LilDucky
Oct 28 2018 21:44
@cluckj thanks. that explains some issues I had
Arnoud82
@Arnoud82
Oct 28 2018 21:45
@cluckj Completed oref0-pump-loop at Sun 28 Oct 22:44:51 CET 2018
:) it running thanks
Ryan Dalisky
@rdalisky
Oct 28 2018 21:46
@LilDucky I did a master install, was going to go back to DEV if it started working again.
Jon Cluck
@cluckj
Oct 28 2018 21:46
@Arnoud82 woo :confetti_ball:
Ryan Dalisky
@rdalisky
Oct 28 2018 21:48
Wait, I ran the BASH script until the setup portion, would I have to do that too to get mraa installed?
@rdalisky oh, oref0-setup.sh is what installs MRAA :)
Ryan Dalisky
@rdalisky
Oct 28 2018 21:54
@LilDucky Thanks, I'll see if I can get this thing working again.
LilDucky
@LilDucky
Oct 28 2018 22:56
@rdalisky you need to do the full monty - AFAIK it does the mraa shizz near the end of the setup process
Kelly Watson
@kellyisworking
Oct 28 2018 23:27
If anyone is coming to NS hackathon this weekend and needs a free, comfy place to stay, my husband and I have a spare room + bath open and an extra comfy sectional in north SF. DM me :smile:
n0rbertg
@n0rbertg
Oct 28 2018 23:57
When this phone gets released it would be an interesting project porting openaps. (it runs pure Linux, has BT) https://puri.sm/products/librem-5/