These are chat archives for nightscout/intend-to-bolus

4th
Nov 2018
Martin Haeberli
@mhaeberli
Nov 04 2018 00:15
seeing this new-to-me error: cgm-loop.log: Not an openaps environment, run: openaps init
Dana Lewis
@danamlewis
Nov 04 2018 00:15
usually requires a cd myopenaps
Martin Haeberli
@mhaeberli
Nov 04 2018 00:16
(right, but trying to understand how it is happening - this is showing up in papertrail)
in other words, where have I failed to cd myopenaps … just using a freshly installed dev
Dana Lewis
@danamlewis
Nov 04 2018 00:22
not sure, unless you ended up with an install inside an install? that's my only guess
Martin Haeberli
@mhaeberli
Nov 04 2018 00:23
k thx
Martin Haeberli
@mhaeberli
Nov 04 2018 00:50
got this error: sudo remote_syslog 2018-11-04 00:43:03 CRITICAL remote_syslog.go:244 Failed to start server: No destination hostname specified
but I (thought I) had edited vi /etc/log_files.yml
naboull1
@naboull1
Nov 04 2018 00:52
hey guys my loop isnt completing giving me a Error: pumphistory too old
how do i tell it to start fresh
Martin Haeberli
@mhaeberli
Nov 04 2018 01:02
solved papertrail issue - cockpit error on my part ...
Dana Lewis
@danamlewis
Nov 04 2018 01:08
@mhaeberli what was it, so we know for next time?
naboull1
@naboull1
Nov 04 2018 01:11
help please
Starting oref0-pump-loop at Sun 4 Nov 12:01:06 AEDT 2018 with 1 second wait_for_silence:
Waiting up to 4 minutes for new BG: ls: cannot access '/tmp/pump_loop_completed': No such file or directory
Radio ok. Listening: .No interfering pump comms detected from other rigs (this is a good thing!)
Preflight (x12 models do not support SMB safety checks, SMB will not be available.) OK. Old pumphistory-24h, waiting for 1 seconds of silence: Radio ok. Listening: .No interfering pump comms detected from other rigs (this is a good thing!)
Old pumphistory-24h refreshed
Profile less than 60m old; Profile valid. Refreshed pumphistory and meal.json
Checking pump clock: "2018-11-04T12:06:54+11:00" is within 90s of current time: Sun 4 Nov 12:06:54 AEDT 2018
Error: pumphistory too old
oref0-pump-loop failed. pump_loop_completed more than 15m old; waiting for 40s silence before mmtuning
Radio ok. Listening: .No interfering pump comms detected from other rigs (this is a good thing!)
Listening for 40s silence before mmtuning: .No interfering pump comms detected from other rigs (this is a good thing!)
mmtune: "916.660", 5, -54 No wait required.
If pump and rig are close enough, this error usually self-resolves. Stand by for the next loop.
Unsuccessful oref0-pump-loop at Sun 4 Nov 12:11:14 AEDT 2018
its been trying for an hour i feel like the pump history to old i the problem
naboull1
@naboull1
Nov 04 2018 01:20

could this be the problem?

Waiting up to 4 minutes for new BG: ls: cannot access '/tmp/pump_loop_completed': No such file or directory

Scott Leibrand
@scottleibrand
Nov 04 2018 01:36
Is this on a Pi Zero?
naboull1
@naboull1
Nov 04 2018 01:36
yes
Scott Leibrand
@scottleibrand
Nov 04 2018 01:37
It might be taking too long to refresh pumphistory. Dev is way better on that front, although I can’t recall if it has any issues with x12 pumps.
naboull1
@naboull1
Nov 04 2018 01:39
is there a command to install dev overwrite whats on there now? or do i format and start fresh?
Scott Leibrand
@scottleibrand
Nov 04 2018 01:53
you can upgrade to dev: see the openaps docs
you can't easily downgrade back to master: that's easiest as a reflash
lottainkeri
@lottainkeri
Nov 04 2018 07:19

NS does not register carbs when bolusing from the pump. Should it do so?

When looking at log I get this:

06:54:10 localhost Timed: out or other comms error - Received an error response Timeout - retrying: 2 of 3
Nov 04 06:54:11 localhost Timed: out or other comms error - Received an error response Timeout - retrying: 3 of 3
Nov 04 06:54:12 localhost root: Uploaded upload/ns-status.json to http://xxxxxxxxxxxxx.herokuapp.com
Nov 04 06:54:15 localhost remote_syslog: 2018-11-04 04:54:15 ERROR remote_syslog.go:73 Syslog error: dial tcp 169.46.82.178:12345: getsockopt: connection refused

Is this normal?

I'm using Edison + Medtronic 522

naboull1
@naboull1
Nov 04 2018 10:06

@scottleibrand
it seems to be working better now pumps responding to basal changes, however its not completing the loop successfully still

could smb be the cause of a incomplete loop?below is the last 3 lines for the loop

No smb_enact needed. Checking pump status (suspended/bolusing): (NOT VALID JSON: empty)
Couldn't smb_verify_status
oref0-pump-loop failed. pump_loop_completed more than 15m old; waiting for 45 s silence before mmtuning

Martin Haeberli
@mhaeberli
Nov 04 2018 10:31
Having distantly similar problems with dev on Edison after time change ; warning currentTempRate 0 != lastTemp rate 4.5 from pumphistory ; canceling temp . And regular mmtune . Pumphistory/temp mismatch; retrying Couldn’t smb_verify suggested
Any advice on how to fix remotely? (Without waking T1D?)Also : Merging Local tempTargets (Not valid JSON: EMPTY)
That is, mmtune happen frequently but always succeed with good signal
Martin Haeberli
@mhaeberli
Nov 04 2018 10:42
@danamlewis papertrail issue was that my selected copy and paste from docs of the various config files somehow lost the first line or two of the template. So for example the first line of one was to read ‘files:’ but read: ‘iles:’
Tim Howard
@tghoward
Nov 04 2018 13:02
howdy all, we have been using G4+share and edison rigs for a while and just got a G6 and i've got an explorer Hat to go along with it. I'd like to try setting the Hat up to talk directly with the G6. I think that means setting up Lookout, right? Any suggestions about order of operations here? Currently G6 is not setup with anything.
Tim Howard
@tghoward
Nov 04 2018 13:31
on the pi, I am re-running openaps-install.sh (from dev) in the root dir, logged in as root. ..

installation looks clean

openaps installed
openaps 0.2.1-dev
fatal: destination path 'oref0' already exists and is not an empty directory.
Switched to branch 'master'
Your branch is up-to-date with 'origin/master'.
Already up-to-date.
Press Enter to run oref0-setup with the current release (master branch) of oref0,

cancelling, switching to dev of oref0 and continuing

Jon Cluck
@cluckj
Nov 04 2018 13:40
the dev setup script will help you set up xdrip-js
Tim Howard
@tghoward
Nov 04 2018 13:41
@cluckj am there right now! Ok, choosing xdrip-js ...
Jon Cluck
@cluckj
Nov 04 2018 13:41
:thumbsup:
Tim Howard
@tghoward
Nov 04 2018 13:42
use Go library?
assume "yes"
Jon Cluck
@cluckj
Nov 04 2018 13:42
yes, and use the binaries
Tim Howard
@tghoward
Nov 04 2018 13:51
hmmm
> Logger@0.4.0 global-install /root/src/Logger
> ./bin/upgrade-node.sh && npm install && ./bin/logger-setup.sh

v8.11.1
Node version already at v8 - good to go
(node:2534) [DEP0022] DeprecationWarning: os.tmpDir() is deprecated. Use os.tmpdir() instead.
npm ERR! git clone git@github.com:github:xdrip-js/xdrip-js Cloning into bare repository '/root/.npm/_git-remotes/git-github-com-github-xdrip-js-xdrip-js-3198d564'...
npm ERR! git clone git@github.com:github:xdrip-js/xdrip-js Permission denied (publickey).
npm ERR! git clone git@github.com:github:xdrip-js/xdrip-js fatal: Could not read from remote repository.
npm ERR! git clone git@github.com:github:xdrip-js/xdrip-js 
npm ERR! git clone git@github.com:github:xdrip-js/xdrip-js Please make sure you have the correct access rights
npm ERR! git clone git@github.com:github:xdrip-js/xdrip-js and the repository exists.
npm ERR! Error: Not found : xdrip-js
still running though
full errors a bit longer than that. Otherwise it ran all the way through to the end.
I guess I'll provide the full error set ...
> Logger@0.4.0 global-install /root/src/Logger
> ./bin/upgrade-node.sh && npm install && ./bin/logger-setup.sh

v8.11.1
Node version already at v8 - good to go
(node:2534) [DEP0022] DeprecationWarning: os.tmpDir() is deprecated. Use os.tmpdir() instead.
npm ERR! git clone git@github.com:github:xdrip-js/xdrip-js Cloning into bare repository '/root/.npm/_git-remotes/git-github-com-github-xdrip-js-xdrip-js-3198d564'...
npm ERR! git clone git@github.com:github:xdrip-js/xdrip-js Permission denied (publickey).
npm ERR! git clone git@github.com:github:xdrip-js/xdrip-js fatal: Could not read from remote repository.
npm ERR! git clone git@github.com:github:xdrip-js/xdrip-js 
npm ERR! git clone git@github.com:github:xdrip-js/xdrip-js Please make sure you have the correct access rights
npm ERR! git clone git@github.com:github:xdrip-js/xdrip-js and the repository exists.
npm ERR! Error: Not found : xdrip-js
npm ERR!     at RegClient.<anonymous> (/usr/share/npm/node_modules/npm-registry-client/lib/request.js:300:14)
npm ERR!     at Request._callback (/usr/share/npm/node_modules/npm-registry-client/lib/request.js:238:65)
npm ERR!     at Request.self.callback (/usr/lib/nodejs/request/index.js:148:22)
npm ERR!     at emitTwo (events.js:126:13)
npm ERR!     at Request.emit (events.js:214:7)
npm ERR!     at Request.<anonymous> (/usr/lib/nodejs/request/index.js:896:14)
npm ERR!     at emitOne (events.js:121:20)
npm ERR!     at Request.emit (events.js:211:7)
npm ERR!     at IncomingMessage.<anonymous> (/usr/lib/nodejs/request/index.js:847:12)
npm ERR!     at emitNone (events.js:111:20)
npm ERR! If you need help, you may report this *entire* log,
npm ERR! including the npm and node versions, at:
npm ERR!     <http://github.com/npm/npm/issues>

npm ERR! System Linux 4.14.71+
npm ERR! command "/usr/bin/node" "/usr/bin/npm" "install"
npm ERR! cwd /root/src/Logger
npm ERR! node -v v8.11.1
npm ERR! npm -v 1.4.21
npm ERR! 
npm ERR! Additional logging details can be found in:
npm ERR!     /root/src/Logger/npm-debug.log
npm ERR! not ok code 0

npm ERR! Logger@0.4.0 global-install: `./bin/upgrade-node.sh && npm install && ./bin/logger-setup.sh`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the Logger@0.4.0 global-install script.
npm ERR! This is most likely a problem with the Logger package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     ./bin/upgrade-node.sh && npm install && ./bin/logger-setup.sh
npm ERR! You can get their info via:
npm ERR!     npm owner ls Logger
npm ERR! There is likely additional logging output above.
npm ERR! System Linux 4.14.71+
npm ERR! command "/usr/bin/node" "/usr/bin/npm" "run" "global-install"
npm ERR! cwd /root/src/Logger
npm ERR! node -v v8.11.1
npm ERR! npm -v 1.4.21
npm ERR! code ELIFECYCLE
npm WARN This failure might be due to the use of legacy binary "node"
npm WARN For further explanations, please read
/usr/share/doc/nodejs/README.Debian

npm ERR! 
npm ERR! Additional logging details can be found in:
npm ERR!     /root/src/Logger/npm-debug.log
npm ERR! not ok code 0
@cluckj thoughts?
Jon Cluck
@cluckj
Nov 04 2018 13:57
did that interrupt oref0-setup?
Tim Howard
@tghoward
Nov 04 2018 13:59
no, it continued to the end and wrote out a new crontab. I just rebooted as requested also
Jon Cluck
@cluckj
Nov 04 2018 13:59
oh good :)
PieterGit
@PieterGit
Nov 04 2018 14:08
are there already european openaps loopers that use the Dexcom G6. is it still online online (probably using dexcom share)
Tim Howard
@tghoward
Nov 04 2018 14:11
I'm confused about the permission denied message from xdrip-js.
instructions from here https://github.com/xdrip-js/xdrip-js/wiki don't suggest it is closed?
Jon Cluck
@cluckj
Nov 04 2018 14:12
yes, it's a weird message
Tim Howard
@tghoward
Nov 04 2018 14:12
@PieterGit , are you saying there are G6 users ... is there a write up of the approaches they've used?
@cluckj , whew ... glad you agree it is strange
Jon Cluck
@cluckj
Nov 04 2018 14:14
you should still be able to follow the Logger install guide to get it running
oref0-setup is just pulling the repo and installing it
Tim Howard
@tghoward
Nov 04 2018 14:20
here? https://github.com/xdrip-js/Logger
Ok, will try.
one thing that confuses me about that page is that it says uninstall npm sudo apt-get remove npm -y # if you installed npm but then a few lines down it wants to use npm to do the install, sudo npm run global-install
What am I missing here ...?
Jon Cluck
@cluckj
Nov 04 2018 14:22
your version of node is already updated to the right one, you want to start here: https://github.com/xdrip-js/Logger#installation
the cron entry is probably even in your cron already :)
Tim Howard
@tghoward
Nov 04 2018 14:22
Ah, ok!
Tim Howard
@tghoward
Nov 04 2018 14:28
hmm, still fails when trying to clone xdrip-js repo. I'll try manually next.
Tim Howard
@tghoward
Nov 04 2018 14:34
Aha! it may only be that github can't authenticate me. (https://stackoverflow.com/questions/12940626/github-error-message-permission-denied-publickey). Fixing this ....
Martin Haeberli
@mhaeberli
Nov 04 2018 14:43
Over here, things settled a bit once the zero temp in the pump expired; looping then resumed ...
Jon Cluck
@cluckj
Nov 04 2018 14:43
:thumbsup:
Tim Howard
@tghoward
Nov 04 2018 15:03
Drat. I don't think that was it ...
Jon Cluck
@cluckj
Nov 04 2018 15:06
fork it & try with the repo in your account? download the .zip?
Tim Howard
@tghoward
Nov 04 2018 15:10
I'll try the fork approach. I don't understand npm, but it looks like possibly npm is trying to find a specific commit that it can't find?
npm ERR! git clone git@github.com:github:thebookins/noble Cloning into bare repository '/root/.npm/_git-remotes/git-github-com-github-thebookins-noble-c7fd3dd9'...
npm ERR! git clone git@github.com:github:thebookins/noble fatal: remote error: 
npm ERR! git clone git@github.com:github:thebookins/noble    is not a valid repository name
same result with my own fork. It still wants to talk to the same repo
Tim Howard
@tghoward
Nov 04 2018 16:08
...fixed by updating npm with npm i -g npm Credit to @cluckj
PieterGit
@PieterGit
Nov 04 2018 17:13
@tghoward it was meant as a question but i forgot the question mark. according to the openaps docs Dexcom g6 should work (but only online). i think it is using Dexcom Share and share2nightscoutbridge. can a dexcom g6 user confirm that it can be used for looping?
Dana Lewis
@danamlewis
Nov 04 2018 17:50
Yes it can
(Not a g6er but have confirmation online looping works)
Martin Haeberli
@mhaeberli
Nov 04 2018 17:52
still seeing cgm-loop.log: Not an openaps environment, run: openaps init on both Edison rigs freshly updated to dev. was able to check one of them for a duplicate myopenaps directory; none found. I plan to spin up another Edison later today, update to dev the same way, and see what happens.
Jon Cluck
@cluckj
Nov 04 2018 18:03
share2nightscout bridge works on the G6, and the G6 works with xdrip+ and Logger (maybe soon for Lookout?)
Carl
@c-robertson
Nov 04 2018 18:07
just to clarify, does the G6 with xdrip+ and Logger enable offline looping?
Jon Cluck
@cluckj
Nov 04 2018 18:08
xdrip+ needs the rig bluetooth tethered to the phone to work offline
Carl
@c-robertson
Nov 04 2018 18:10
ok, thx for clarifying. planning to switch from Enlite to G6 soon, trying to understand the options/limitations...
Martin Haeberli
@mhaeberli
Nov 04 2018 18:16
we are looping w G6
Carl
@c-robertson
Nov 04 2018 18:49
the one nice thing about the Enlite is that offline is not an issue, because the rig can get all the data it needs direct from the pump. I have BT tether setup on both of my rigs, but that tends to burn battery. Hopefully noble does better...
alimhassam
@alimhassam
Nov 04 2018 18:51
Fyi logger/Lookout does the same with g5/g6
PieterGit
@PieterGit
Nov 04 2018 18:55
just checking... does g6 also work for european users? in the past some stuff only worked for US users (e.g. bluetooth for g4)
Carl
@c-robertson
Nov 04 2018 18:58
@alimhassam does that mean the rig will keep looping even in the absence of wifi/BT connectivity to the internet? seems contradictory to what @cluckj said...
Jon Cluck
@cluckj
Nov 04 2018 18:59
xdrip+ can send BG readings to the rig over Bluetooth regardless of internet access
You just need to configure xdrip+ to REST upload to the rig's bluetooth IP in addition to nightscout
Carl
@c-robertson
Nov 04 2018 19:05
ok, thx again for clarifying... does xdrip+/Logger/Lookout work on the Edison as well?
Jon Cluck
@cluckj
Nov 04 2018 19:05
If you use lookout/Logger, it'll work offline without needing to be tethered to your phone
T
Yes I think so
Carl
@c-robertson
Nov 04 2018 19:07
cool
Tim Howard
@tghoward
Nov 04 2018 19:29
@PieterGit ok, thanks for clarifying and re-asking. I am just catching up to all of this too!
alimhassam
@alimhassam
Nov 04 2018 20:35
@c-robertson logger/lookout get BG's directly from the g5/g6 to the rig using Bluetooth. Connectivity is not needed.
benfiscal
@benfiscal
Nov 04 2018 20:48
Does anyone know someone who successfully has used the CNL 2.4 attached to a pi0 rig to get CGM readings from the 640G to use with OpenAPS?
Martin Haeberli
@mhaeberli
Nov 04 2018 21:01
i can no longer bluetooth tether. bluetoothd doesnt seem to be automatically starting, which may be related. how is bluetoothd supposed to be started? how would I check (on newly installed dev build on Edison)
Eric
@ecc1
Nov 04 2018 21:03
It should be started by systemd, try "systemctl status bluetooth"
oops, that's on recent Pi systems where the system version of bluetoothd works fine. Disregard that for Edison, I don't have one handy to check
Martin Haeberli
@mhaeberli
Nov 04 2018 21:11
@ecc1 thx I understand not applicable to Edison but I’ll check anyway
but for the record (after manual start of bluetoothd) it reads
# systemctl status bluetoothbluetooth.service - Bluetooth service
   Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled)
   Active: inactive (dead)
     Docs: man:bluetoothd(8)
Eric
@ecc1
Nov 04 2018 21:21
if you do "sudo systemctl start bluetooth", and then do that status command again, do you see any errors?
Martin Haeberli
@mhaeberli
Nov 04 2018 21:30
@ecc1 yes, when it’s already running; no, if I had previously killed it. about to try to see what happens right after reboot
also, seeing:
Temp refreshgrep: enact/smb-enacted.json: No such file or directory
cp: cannot stat ‘enact/smb-enacted.json’: No such file or directory
enact/smb-enacted.json: cat: enact/smb-enacted.json: No such file or directory
(NOT VALID JSON: empty)
Checking pump status (suspended/bolusing): Couldn't smb_verify_status
oref0-pump-loop failed. If pump and rig are close enough, this error usually self-resolves. Stand by for the next loop.
Martin Haeberli
@mhaeberli
Nov 04 2018 21:42
@ecc1:
systemctl status bluetoothbluetooth.service - Bluetooth service
   Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled)
   Active: active (running) since Sun 2018-11-04 13:41:54 PST; 5s ago
     Docs: man:bluetoothd(8)
 Main PID: 6062 (bluetoothd)
   Status: "Running"
   CGroup: /system.slice/bluetooth.service
           └─6062 /usr/lib/bluetooth/bluetoothd

Nov 04 13:41:54 etghopenaps17 bluetoothd[6062]: Bluetooth daemon 5.23
Nov 04 13:41:54 etghopenaps17 systemd[1]: Started Bluetooth service.
Nov 04 13:41:54 etghopenaps17 bluetoothd[6062]: Starting SDP server
Nov 04 13:41:54 etghopenaps17 bluetoothd[6062]: Bluetooth management interface 1.3 initialized
Nov 04 13:41:54 etghopenaps17 bluetoothd[6062]: Sap driver initialization failed.
Nov 04 13:41:54 etghopenaps17 bluetoothd[6062]: sap-server: Operation not permitted (1)
Nov 04 13:41:54 etghopenaps17 bluetoothd[6062]: hci0 Load Connection Parameters failed: Unknown Command (0x01)
(already as root)
Eric
@ecc1
Nov 04 2018 21:49
That seems like an old version, but someone with a working system at hand will have to chime in, sorry
Martin Haeberli
@mhaeberli
Nov 04 2018 21:50
installed dev on top of working master yesterday. maybe I broke something
jatowle
@jatowle
Nov 04 2018 21:54
Hi everyone i am new to this and followed a link to this room in an article regaurding open APS for closed loop insulin pumps. I was wondering if i could ask some questions, if i am in the right room
Eric
@ecc1
Nov 04 2018 21:58
@jatowle welcome. Start by reading the docs at https://openaps.readthedocs.io/en/latest/index.html and then feel free to ask questions
jatowle
@jatowle
Nov 04 2018 22:05
Thanks eric
Martin Haeberli
@mhaeberli
Nov 04 2018 22:29

@ecc1 on another edison, one running master, I still see:

# systemctl status bluetoothbluetooth.service - Bluetooth service
   Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled)
   Active: inactive (dead)
     Docs: man:bluetoothd(8)

but bluetootctl works, as opplosed to hanging. (it’s version 5.48, btw)

Martin Haeberli
@mhaeberli
Nov 04 2018 23:33
what does this error mean - what should I look out for? ns-loop.log: Merging local temptargets: (NOT VALID JSON: empty)