These are chat archives for nightscout/intend-to-bolus

23rd
Jan 2019
Scott Leibrand
@scottleibrand
Jan 23 00:25
Lol
MDT is the Medtronic stock symbol.
renegadeandy
@renegadeandy
Jan 23 00:31
oh!
renegadeandy
@renegadeandy
Jan 23 02:30
image.png
Since upgrading to dev 0.7.0, my nightscout doesn't appear to receive data on the openaps pill any more
the loop is functioning fine
I also configured my nightscout from http to https but I doubt that would have caused this
I updated the preferences.json replacing the scheme appropriately
Jon Cluck
@cluckj
Jan 23 02:34
what does your ns-looplog say?
Patcalfe
@Patcalfe
Jan 23 02:36
I have this same issue^^^
renegadeandy
@renegadeandy
Jan 23 02:39
@cluckj
root@andyaps:/var/log/openaps# tail -n 50 ns-loop.log 

Starting oref0-ns-loop at Tue Jan 22 20:35:02 CST 2019:
No recent valid BG found. Most recent:
(NOT VALID JSON: empty)
{"sgv":110,"dateString":"2019-01-22T20:30:19.487-0600"}
Latest NS temptargets: (NOT VALID JSON: empty)
Merging local temptargets: (NOT VALID JSON: empty)
Temptargets merged: (NOT VALID JSON: empty)
Refreshed carbhistory; COB: 0
{"batteryVoltage":3661,"battery":47}
(NOT VALID JSON: empty)
(NOT VALID JSON: empty)
Completed oref0-ns-loop at Tue Jan 22 20:35:36 CST 2019

Starting oref0-ns-loop at Tue Jan 22 20:36:03 CST 2019:
No recent valid BG found. Most recent:
(NOT VALID JSON: empty)
{"sgv":105,"dateString":"2019-01-22T20:35:19.177-0600"}
Latest NS temptargets: (NOT VALID JSON: empty)
Merging local temptargets: (NOT VALID JSON: empty)
Temptargets merged: (NOT VALID JSON: empty)
Refreshed carbhistory; COB: 0
{"batteryVoltage":3655,"battery":46}
(NOT VALID JSON: empty)
No new treatments to upload
Completed oref0-ns-loop at Tue Jan 22 20:36:36 CST 2019

Starting oref0-ns-loop at Tue Jan 22 20:37:03 CST 2019:
No recent valid BG found. Most recent:
(NOT VALID JSON: empty)
{"sgv":105,"dateString":"2019-01-22T20:35:19.177-0600"}
Latest NS temptargets: (NOT VALID JSON: empty)
Merging local temptargets: (NOT VALID JSON: empty)
Temptargets merged: (NOT VALID JSON: empty)
Refreshed carbhistory; COB: 0
{"batteryVoltage":3659,"battery":47}
(NOT VALID JSON: empty)
(NOT VALID JSON: empty)
Completed oref0-ns-loop at Tue Jan 22 20:37:51 CST 2019

Starting oref0-ns-loop at Tue Jan 22 20:38:02 CST 2019:
No recent valid BG found. Most recent:
(NOT VALID JSON: empty)
{"sgv":105,"dateString":"2019-01-22T20:35:19.177-0600"}
Latest NS temptargets: (NOT VALID JSON: empty)
Merging local temptargets: (NOT VALID JSON: empty)
Temptargets merged: (NOT VALID JSON: empty)
Refreshed carbhistory; COB: 0
{"batteryVoltage":3658,"battery":47}
(NOT VALID JSON: empty)
Jon Cluck
@cluckj
Jan 23 02:44
does ~/myopenaps/ns.ini have the https?
Jon Cluck
@cluckj
Jan 23 02:50
and maybe ~/.bash_profile
and also maybe your cron
renegadeandy
@renegadeandy
Jan 23 02:54
gah
neither of those, they still have http
but whats the point in having it in preferences.json, if somewhere the codebase is still referencing ns.ini or .bash_profile?
Jon Cluck
@cluckj
Jan 23 02:56
so in the future those things that are found to be looking in those other places can be redirected to preferences ;)
renegadeandy
@renegadeandy
Jan 23 02:56
ive updated both of those locations and rebooted
well, perhaps we can consolidate ns.ini and the .bash_profile users to preferences.json in dev now in dev...?
@scottleibrand is there a reason the ns URL is defined in these 3 locations currently? Any reason why it is separated this way?
Jon Cluck
@cluckj
Jan 23 03:13
did that fix it?
renegadeandy
@renegadeandy
Jan 23 03:20
hmm, well I changed, rebooted (using reboot cmd), then It never regained connectivity to my bt-pan
so ive just done a h/w restart
hoping itll jump back to life now
renegadeandy
@renegadeandy
Jan 23 03:26

@cluckj it did not fix it:

root@andyaps:/var/log/openaps# tail -n 50 ns-loop.log 
No recent valid BG found. Most recent:
(NOT VALID JSON: empty)
{"sgv":85,"dateString":"2019-01-22T20:55:20.273-0600"}
Latest NS temptargets: (NOT VALID JSON: empty)
Merging local temptargets: (NOT VALID JSON: empty)
Temptargets merged: (NOT VALID JSON: empty)
Refreshed carbhistory; COB: 0
{"batteryVoltage":3628,"battery":43}
(NOT VALID JSON: empty)
(NOT VALID JSON: empty)
Completed oref0-ns-loop at Tue Jan 22 21:21:33 CST 2019

Starting oref0-ns-loop at Tue Jan 22 21:22:02 CST 2019:
No recent valid BG found. Most recent:
(NOT VALID JSON: empty)
{"sgv":85,"dateString":"2019-01-22T20:55:20.273-0600"}
Latest NS temptargets: (NOT VALID JSON: empty)
Merging local temptargets: (NOT VALID JSON: empty)
Temptargets merged: (NOT VALID JSON: empty)
Refreshed carbhistory; COB: 0
{"batteryVoltage":3633,"battery":43}
(NOT VALID JSON: empty)
(NOT VALID JSON: empty)
Completed oref0-ns-loop at Tue Jan 22 21:22:33 CST 2019

Starting oref0-ns-loop at Tue Jan 22 21:23:03 CST 2019:
No recent valid BG found. Most recent:
(NOT VALID JSON: empty)
{"sgv":85,"dateString":"2019-01-22T20:55:20.273-0600"}
Latest NS temptargets: (NOT VALID JSON: empty)
Merging local temptargets: (NOT VALID JSON: empty)
Temptargets merged: (NOT VALID JSON: empty)
Refreshed carbhistory; COB: 0
{"batteryVoltage":3625,"battery":42}
(NOT VALID JSON: empty)
(NOT VALID JSON: empty)
Completed oref0-ns-loop at Tue Jan 22 21:23:35 CST 2019

Starting oref0-ns-loop at Tue Jan 22 21:24:02 CST 2019:
No recent valid BG found. Most recent:
(NOT VALID JSON: empty)
{"sgv":85,"dateString":"2019-01-22T20:55:20.273-0600"}
Latest NS temptargets: (NOT VALID JSON: empty)
Merging local temptargets: (NOT VALID JSON: empty)
Temptargets merged: (NOT VALID JSON: empty)
Refreshed carbhistory; COB: 0
{"batteryVoltage":3638,"battery":44}
(NOT VALID JSON: empty)
(NOT VALID JSON: empty)
Completed oref0-ns-loop at Tue Jan 22 21:24:30 CST 2019

I have checked preferences.json, ns.ini, .bash_profile.

Darn i didnt change crontab

changed cron
i expect ill need to reboot again
so doing so now
image.png

@cluckj bingo! @Patcalfe check these places:

1/Your preferences.json nightscout url
2/Your ns.ini nightscout url(/root/myopenaps/ns.ini)
3/Your .bash_profile ns url
4/Your crontab ns url (crontab -l)

renegadeandy
@renegadeandy
Jan 23 03:31
@scottleibrand ^^ -- any plans to consolidate nightscout urls to just the one place? 0.7.0 added it to preferences, and i hope we can consolidate all code to grab from a single point?
Patcalfe
@Patcalfe
Jan 23 03:32
I'll check em now, thanks.
renegadeandy
@renegadeandy
Jan 23 03:32
image.png
Neat! Since getting 0.7.0 of the loop, i now see the specific basal rates!
Jon Cluck
@cluckj
Jan 23 03:33
:thumbsup:
Patcalfe
@Patcalfe
Jan 23 03:41
where do i find my bash_profile
i've checked the others....all good on those fronts.
Jon Cluck
@cluckj
Jan 23 03:45
@Patcalfe ~/.bash_profile
you may have a different issue, what does your ns-looplog look like?
Patcalfe
@Patcalfe
Jan 23 03:47
Uploaded
Starting ns-loop at Tue Jan 22 19:45:02 PST 2019:
ns://JSON/shell/cgm/ns-glucose.json
reporting cgm/ns-glucose.json
ns://JSON/shell/settings/temptargets.json
reporting settings/temptargets.json
get-profile://text/shell/settings/profile.json
reporting settings/profile.json
Refreshed temptargetsns://JSON/shell/monitor/carbhistory.json
reporting monitor/carbhistory.json
and meal-carbs
{"batteryVoltage":3493, "battery":23}
Uploaded
I'm still pretty new at all of this....
linux is confusing
Patcalfe
@Patcalfe
Jan 23 04:03
my nightscout http is in all of the related files.
renegadeandy
@renegadeandy
Jan 23 04:15
can you do tail -n 50 ns-loop.log
id like to see a bit more of it
Patcalfe
@Patcalfe
Jan 23 04:17
tail: cannot open ‘ns-loop.log’ for reading: No such file or directory
haha
renegadeandy
@renegadeandy
Jan 23 04:18
you need to be in the correct directory
what directory are you in?
Patcalfe
@Patcalfe
Jan 23 04:18
yeah, i figured as soon as i got that...just a sec.
renegadeandy
@renegadeandy
Jan 23 04:18
type pwd
Patcalfe
@Patcalfe
Jan 23 04:21
root/myopenaps
Patcalfe
@Patcalfe
Jan 23 04:27
where is it located?
i'm lost.
i cant' find any log files
Scott Leibrand
@scottleibrand
Jan 23 04:29
@renegadeandy if you know what needs to be done to move to reading the URL from preferences, feel free to PR. It hasn’t been a priority yet for anyone else because it’s so easy to just fix it in oref0-runagain and run it.
@Patcalfe logs are in /var/log/openaps/
Patcalfe
@Patcalfe
Jan 23 04:32
Uploaded
Starting ns-loop at Tue Jan 22 20:28:02 PST 2019:
ns://JSON/shell/cgm/ns-glucose.json
reporting cgm/ns-glucose.json
ns://JSON/shell/settings/temptargets.json
reporting settings/temptargets.json
get-profile://text/shell/settings/profile.json
reporting settings/profile.json
Refreshed temptargetsns://JSON/shell/monitor/carbhistory.json
reporting monitor/carbhistory.json
and meal-carbs
{"batteryVoltage":3444, "battery":16}
Uploaded
Starting ns-loop at Tue Jan 22 20:29:03 PST 2019:
ns://JSON/shell/cgm/ns-glucose.json
reporting cgm/ns-glucose.json
ns://JSON/shell/settings/temptargets.json
reporting settings/temptargets.json
get-profile://text/shell/settings/profile.json
reporting settings/profile.json
Refreshed temptargetsns://JSON/shell/monitor/carbhistory.json
reporting monitor/carbhistory.json
and meal-carbs
{"batteryVoltage":3464, "battery":19}
Uploaded
Starting ns-loop at Tue Jan 22 20:30:03 PST 2019:
ns://JSON/shell/cgm/ns-glucose.json
reporting cgm/ns-glucose.json
ns://JSON/shell/settings/temptargets.json
reporting settings/temptargets.json
get-profile://text/shell/settings/profile.json
reporting settings/profile.json
Refreshed temptargetsns://JSON/shell/monitor/carbhistory.json
reporting monitor/carbhistory.json
and meal-carbs
{"batteryVoltage":3470, "battery":20}
Uploaded
Starting ns-loop at Tue Jan 22 20:31:02 PST 2019:
ns://JSON/shell/cgm/ns-glucose.json
reporting cgm/ns-glucose.json
ns://JSON/shell/settings/temptargets.json
reporting settings/temptargets.json
get-profile://text/shell/settings/profile.json
reporting settings/profile.json
Refreshed temptargetsns://JSON/shell/monitor/carbhistory.json
reporting monitor/carbhistory.json
and meal-carbs
{"batteryVoltage":3466, "battery":19}
cool thanks
renegadeandy
@renegadeandy
Jan 23 04:36
@Patcalfe I don't know how to help you :( Not the same issue as me i don't think.
@scottleibrand That's where I shall begin!
Patcalfe
@Patcalfe
Jan 23 04:36
ok, no problem, thanks for looking.
Scott Leibrand
@scottleibrand
Jan 23 04:53
@Patcalfe are you using oref0 0.6.x (master branch)? The dev branch has quite a bit better upload code, so you might want to try switching if you can’t figure it out on master.
ellabells
@ellabells
Jan 23 15:56
@danamlewis Hi Dana, @Kdisimone tagged you in a facebook post in Looped, but I think you have not seen it and it's causing me safety concern as my daughter is sick so we have had to stop looping as it's too dangerous that the rig keeps putting her on a 0 temp basal when ever she eats. Katie kindly took a long look at my logs and rig and NS... and says she's stumped. This is what she wrote -The carbs are being read by the rig; I can see in cat monitor/carbhistory.json that the meal entries are being read by openaps with a correct value in the "carb_input" value.
However, her carbs are decayed (or appear to be decayed) immediately. Repeatedly 50g carbs are down to 17g within minutes without any corresponding BG increases to justify.
Two things I don't understand..."bwFound": false what is that telling us? Secondly, there was a carbImpact value that seemed quite low in the pump logs (although not in her preferences.json) and I'm not sure if that is a symptom of what we are seeing or a cause.
Can you please help? I've searched the docs and done a really thorough look at her logs...nothing explains this to me. Thank you.
Abigail Cember
@acember
Jan 23 16:48
@ellabells Have you noticed that the 'sensitivity' parameter has been changed? I'm wondering if that's the key, especially as sensitivity tends to fluctuate wildly when people are sick.
ellabells
@ellabells
Jan 23 16:52
@acember It's been like this since I built the rig on Tuesday last week and she was not ill then. So I don't think there is any correlation with her being sick.
Dave9111
@Dave9111
Jan 23 18:18
@ellabells Has she been looping for a while previous to her being sick? Depending on the safety settings in the preferences.json file your temp basal will be set to zero if she has hit the IOB (Insulin on Board) limits after a meal bolus. For instance, if the software has calculated that the max IOB is 6 units and she just ate a meal and bolused 5 units and she had 1 unit of insulin on board prior to the meal, the safety limit will be hit and the temp basal will immediately be set to zero. It will stay at zero until some insulin is consumed and the calculated IOB drops below the max safety values (which is calculated).
The first three lines of the preferences.json file are what controls the limits on IOB and thus basal... "max_iob": ,
"max_daily_safety_multiplier":, and "current_basal_safety_multiplier":
Read the docs further if you want to better understand this... it gets a little complicated.
Regarding the very fast rate of decay for the carbs: I don't understand that and I've never seen that before. I'd be tempted to reload her rig and go through the setup again.
If she is very new to looping, you are probably smart to get her off of it for the moment, and fall back to what you know works until she gets better. I've seen my daughter get sick which can create highs which are very weak, add a little fast acting insulin and she can crash quickly which means that her insulin sensitivity is abnormally high. That said, once OpenAPS is tuned in, it works quite well even when my daughter is sick as long as she can hold down some food once in a while.. She still goes runs high when she is sick, but OpenAPS does a good job to keep it from getting out of control.
Dave9111
@Dave9111
Jan 23 18:24
@renegadeandy Hey Andy...I thought you figured out that this issue was only happening at work and not away from work? If you have an RFI problem between the radio on your rig and your pump (which is what it sounded like yesterday), no software is going to fix that. You need to find out what is creating the interference and silence or shield it.
Abigail Cember
@acember
Jan 23 19:16
@ellabells I misunderstood from your post that your concerns were specific to being sick, which can definitely change things, as we all know. If you're just concerned about those zero temps, as @Dave9111 explained, they will occur quite frequently after a bolus if the system decides that you already have enough insulin on board. I get zero-temps all the time after eating dinner, especially if I've done my own larger bolus instead of letting super micro bolus take care of it all. These zero temps have actually been really helpful in preventing lows that I used to get around midnight -- so they are a useful part of the code for many people, although I know of at least one person who's disabled them. If your daughter seems to be high because of them, then some adjustment to the parameters is needed. I've messed around with the preferences quite a bit, so please feel free to PM me if you want to ask questions!
Scott Leibrand
@scottleibrand
Jan 23 19:35
It sounds like @ellabells is concerned with COB decaying too fast, and the rest of the symptoms result from that.
What CR does the pump-loop.log show? It might be worth pasting one from right after the meal entry.
Bwfound false just means you didn’t use the pump Bolus Wizard to enter carbs, but rather entered them from Nightscout.
Dave9111
@Dave9111
Jan 23 20:02
From what I have seen after watching Openaps work for almost 5 months, zero temp are a very important tool.. I certainly would not disable zero temps!
Dana Lewis
@danamlewis
Jan 23 20:12

There is something else going on here.

@ellabells, can you post your images here as well? And also include one of your actual full pump log at the time around when you pulled your Ns screen shot? I’d also like to know what branch you’re running (master or dev?), and what type of pump and rig you’re using?

ellabells
@ellabells
Jan 23 20:34
@danamlewis I'm so new to Gitter..struggling to work out how to post images. I'm so sleep deprived at the moment as my daughter is really very sick (bronchitis) I've PM'd you in FB Messenger to ask something.
Scott Leibrand
@scottleibrand
Jan 23 20:42
You can drag and drop the image files into Gitter, or use Ctrl-V to paste them, depending on which kind of computer you’re using.
Dana Lewis
@danamlewis
Jan 23 20:42
No worries! Send pics via Fbk if needed. The other info we need is which branch (master or dev), type of pump, and what type of rig you’re using
Scott Leibrand
@scottleibrand
Jan 23 20:43
And you can also copy and paste the logs as text instead of images.
Abigail Cember
@acember
Jan 23 20:55
While we're on this topic: Can I change the variables maxCarbAbsorptionRate and assumedCarbAbsorptionRate in preferences.json, or are they only set up to be hard coded? @scottleibrand
Dave9111
@Dave9111
Jan 23 21:00
@ellabells I'm using Firefox on Windows 7 and I cannot copy paste images... I think I also tried it with Chrome. The image link via ! [ alt ] ( http:// ) also does not work with google drive images at least.. no idea why. I got it to work with a google picture link once and then it didn't work.
Gitter has a sandbox so you can try things out ..... https://gitter.im/gitterHQ/sandbox If you are wondering where the "`" character is.... is it on the top left of the keyboard beneath the tilde ~. Get some sleep! I've been there!
renegadeandy
@renegadeandy
Jan 23 21:42
@acember I am pretty sure you can update them in there, the loop should pick them up automatically
Scott Leibrand
@scottleibrand
Jan 23 21:45
@acember I believe that would require a code change to support customizing those.
Abigail Cember
@acember
Jan 23 22:44
Yeah, it looked to me like they're hardcoded in determine_basal(), but I wasn't sure whether maybe there's another place where they can get read in from a .json or some function. @renegadeandy Have you actually tried that? Because it doesn't seem to me that just any variable can be altered by giving it a new value in preferences -- only ones that are being actively "checked for" have their values returned. ( @scottleibrand Am I right about that?)
Dana Lewis
@danamlewis
Jan 23 23:50
If anyone’s wanting a 512 and hasn’t found another pump to get started..let me know. 2 more of those coming in. (Not home to ship them out for another ~2 weeks so just FYI on earliest timeline for those)