These are chat archives for nightscout/intend-to-bolus

31st
Jan 2019
tuzoenduro
@tuzoenduro
Jan 31 09:29
@ecc1 sorry life happened and I could not post this before... for the two sudos, I get this :
root@panfila:~# sudo which bluetoothctl
/usr/bin/bluetoothctl
root@panfila:~# sudo which bluetoothd
/usr/sbin/bluetoothd
viq
@viq
Jan 31 10:33
@tuzoenduro then you should be using the ones coming from package. If you want to doublecheck whether you have some other copies of it, something like find /usr/local -iname '*bluetooth*' should list them
tuzoenduro
@tuzoenduro
Jan 31 11:19
hello @viq that bit of code threw this at me
/usr/local/lib/node_modules/oref0/bin/oref0-bluetoothup.sh
/usr/local/bin/oref0-bluetoothup
thing is I dont really know what to do with that...
one other question, as I just started looping there are a lot of things that I don't understand... is it normal the rig does not read the COB from NS?
when I see the hat display it says COB as 0, even if I put 5g through NS or through a shortcut on my phone...
tuzoenduro
@tuzoenduro
Jan 31 11:29
I haven't yet bolused for a meal yet as I have been connected to the pump for the first time since this morning, so I have not seen if going through the bolus wizard on the pump updates COB or not...
Dana Lewis
@danamlewis
Jan 31 12:30
Rig should read carbs from NS
tuzoenduro
@tuzoenduro
Jan 31 13:28
@danamlewis actually, the rig posted the carbs from the bolus wizard into NS, so I can see the NS pill but when I see through the log it always says cob=0
I get this :
Checking deliverAt: 2019-01-31T12:50:37.062Z is within 1m of current time: Thu 31 Jan 13:50:37 CET 2                                                                                                           019
and that smb-suggested.json is less than 1m old
enact/smb-suggested.json: {"temp":"absolute","bg":95,"tick":"+13","eventualBG":73,"insulinReq":0,"re                                                                                                           servoir":"121.5\n","deliverAt":"2019-01-31T12:50:37.062Z","sensitivityRatio":1,"COB":0,"IOB":1.576}
"COB: 0, Dev: 68, BGI: -2, ISF: 57, CR: 7, Target: 80, minPredBG 47, minGuardBG 13, IOBpredBG 67, UA                                                                                                           MpredBG 39; minGuardBG 13<60 98m left and 0 ~ req 0U/hr: no temp required"
UAM: [95,99,99,96,94,91,88,85,82,79,76,73,70,67,64,61,59,56,53,51,48,46,43,41,39]
IOB: [95,103,110,116,121,125,128,129,130,130,129,127,124,121,118,115,112,109,107,104,102,99,97,95,93                                                                                                           ,90,89,87,85,83,82,80,79,77,76,75,74,73,72,71,71,70,69,69,68,68,67]
ZT:  [95,93,90,88,85,83,80,77,75,72,70,68,66,64,62,60,59,58,57,56,56,55,55,55,55,56,57,57,59,60,61,6                                                                                                           3,65,67,69,71,74,76,79]
No smb_enact needed. Checking pump status (suspended/bolusing): {"status":"normal","bolusing":false,                                                                                                           "suspended":false}
Temp refreshed: monitor/temp_basal.json: {"duration":98,"temp":"absolute","rate":0}
No bolus needed. Settings less than 30 minutes old. grep: enact/bolused.json: No such file or direct                                                                                                           ory
Your instance of oref0 [0.7.0-dev, dev] is up-to-date.
Completed oref0-pump-loop at Thu 31 Jan 13:50:49 CET 2019
Updating HAT Display...
tuzoenduro
@tuzoenduro
Jan 31 13:41
I'm guessing there is some setting I did not do right, but I cannot find which or where, if this sounds familiar to someone I could use the help..
Jon Cluck
@cluckj
Jan 31 13:54
it looks like it decayed those carbs pretty quickly, because of the increase in BG
tuzoenduro
@tuzoenduro
Jan 31 14:04
@cluckj is it normal that they decay so fast? shouldn't they last longer? I can see in one of the loops that they were put in... but on the next one they are back to 0

actually on the same loop it does it... it reads carbs in NS, but puts them as 0 on the rig COB...

```

Pump history updated through 2019-01-31T14:35:34+01:00 with 2 new records; meal.j son refreshed: {"carbs":40,"nsCarbs":40,"bwCarbs":0,"journalCarbs":0,"mealCOB":0, "currentDeviation":5.33,"maxDeviation":0,"minDeviation":-4.33,"slopeFromMaxDeviat ion":0,"slopeFromMinDeviation":2.627,"allDeviations":[5,-3,-3,-4,-4,-4],"lastCarb Time":1548936962000,"bwFound":false}
Listening for 4s: .No interfering pump comms detected from other rigs (this is a good thing!)
Continuing oref0-pump-loop at Thu 31 Jan 14:44:10 CET 2019
Checking that pump clock: "2019-01-31T14:43:20+01:00" is within 90s of current ti me: 2019-01-31T14:44:12+0100
Temp refreshed: monitor/temp_basal.json: {"duration":53,"temp":"absolute","rate": 0}
{"carbs":40,"nsCarbs":40,"bwCarbs":0,"journalCarbs":0,"mealCOB":0,"currentDeviati on":5.33,"maxDeviation":0,"minDeviation":-4.33,"slopeFromMaxDeviation":0,"slopeFr omMinDeviation":2.627,"allDeviations":[5,-3,-3,-4,-4,-4],"lastCarbTime":154893696 2000,"bwFound":false}
Warning: Autotune has not been run. All microboluses will be disabled until you m anually run autotune or add it to run nightly in your loop.
{"iob":3.557,"activity":0.0168,"basaliob":0.026,"bolusiob":3.53,"netbasalinsulin" :-0.6,"bolusinsulin":4.6,"time":"2019-01-31T13:43:25.000Z","iobWithZeroTemp":{"io b":3.557,"activity":0.0168,"basaliob":0.026,"bolusiob":3.53,"netbasalinsulin":-0. 6,"bolusinsulin":4.6,"time":"2019-01-31T13:43:25.000Z"},"lastBolusTime":154894145 6000,"lastTemp":{"rate":0,"timestamp":"2019-01-31T14:35:34+01:00","started_at":"2 019-01-31T13:35:34.000Z","date":1548941734000,"duration":8.85}}
{"delta":1,"glucose":221,"noise":null,"short_avgdelta":3.44,"long_avgdelta":6.76, "date":1548941910535,"last_cal":0}
Autosens ratio: 1; Basal unchanged: 0.95; ISF unchanged: 57; CR: 7
currenttemp: { duration: 53, temp: 'absolute', rate: 0 } lastTempAge: 9 m tempMod ulus: 2 m
SMB disabled (!microBolusAllowed)
Last carbs 89 minutes ago; remainingCATime: 5.2 hours; 100% carbs absorbed
Carb Impact: 5.8 mg/dL per 5m; CI Duration: 0 hours; remaining CI (~2h peak): 0 m g/dL per 5m
UAM Impact: 5.8 mg/dL per 5m; UAM Duration: 0.6 hours
minPredBG: 66 minIOBPredBG: 51 minZTGuardBG: 93 minUAMPredBG: 39 avgPredBG: 93 CO B: 0 / 40
BG projected to remain above 90 for 145 minutes
BG projected to remain above 65 for 190 minutes
naive_eventualBG: 18 bgUndershoot: 47 zeroTempDuration: 190 zeroTempEffect: 171 c arbsReq: -15
2019-01-31T13:44:48.531Z
Checking deliverAt: 2019-01-31T13:44:48.531Z is within 1m of current time: Thu 31 Jan 14:44:48 CET 2019
and that smb-suggested.json is less than 1m old
enact/smb-suggested.json: {"temp":"absolute","bg":221,"tick":"+1","eventualBG":53 ,"insulinReq":0,"reservoir":"118.1\n","deliverAt":"2019-01-31T13:44:48.531Z","sen sitivityRatio":1,"COB":0,"IOB":3.557}
"COB: 0, Dev: 35, BGI: -5, ISF: 57, CR: 7, Target: 90, minPredBG 66, minGuardBG 3 5, IOBpredBG 52, UAMpredBG 39; minGuardBG 35<65 53m left and 0 ~ req 0U/hr: no te mp required"
UAM: [221,221,220,217,214,209,203,196,190,183,176,169,163,156,149,143,137,131,125 ,119,113,108,103,98,93,88,84,80,76,72,69,65,62,59,57,54,52,49,47,46,44,42,41,40,3 9]
IOB: [221,222,221,220,218,215,211,207,202,197,191,185,178,172,165,159,152,146,140 ,134,129,123,118,113,108,104,99,95,91,88,84,81,78,75,72,69,67,65,63,61,59,58,57,5 5,54,53,52]
ZT: [221,216,211,205,199,193,187,181,175,168,162,156,151,145,140,134,130,125,121 ,117,113,110,107,104,102,99,98,96,95,94,94,93,93,94,94]
No smb_enact needed. Checking pump status (suspended/bolusing): {"status":"normal ","bolusing":false,"suspended":false}
Temp refreshed: monitor/temp_basal.json: {"duration":52,"temp":"absolute","rate": 0}
No bolus needed. glucose.json newer than pump_loop_completed
Your instance of oref0 [0.7.0-dev, dev] is up-to-date.
Completed oref0-pump-loop at Thu 31 Jan 14:44:53 CET 2019
Updating HAT Display...
```

Dana Lewis
@danamlewis
Jan 31 14:06
@tuzoenduro what CGM do you use and how do you get BGs to your rig?
tuzoenduro
@tuzoenduro
Jan 31 14:07
I can never get those tags right.. but you can see the NS COB as 40, and then the COB in the colored line of the rig appear as 0
I am reading the BGS directly from NS... I post them from my enlites through a 640 pump
but I'm connected to a 722...
Dana Lewis
@danamlewis
Jan 31 14:08
ok. for now, i would hold off on looping, that seems like an issue related to the 640 setup
(i heard another example of this, which to me affirms that it's related somew to the configuration using 640 as the uploader)
tuzoenduro
@tuzoenduro
Jan 31 14:10
I am getting a transmitter for the 722 soon, so I will try again.. but I had talked to the guys that coded the 640 uploader and we got a modified version which did not upload anything other than the BGs
Dana Lewis
@danamlewis
Jan 31 14:10
@cluckj ^ (headinghatng back to bed but dropping that note there to follow up on later, in case you can help debug t)
tuzoenduro
@tuzoenduro
Jan 31 14:10
thank you @danamlewis
Jon Cluck
@cluckj
Jan 31 14:17
Last carbs 89 minutes ago; remainingCATime: 5.2 hours; 100% carbs absorbed
hmm
tuzoenduro
@tuzoenduro
Jan 31 14:23
yeah, that is weird... the carbs I put through NS were done maybe 5 minutes before that loop
Jon Cluck
@cluckj
Jan 31 14:28
I've gotta go for a few hours, but I'll take a closer look when I get back
tuzoenduro
@tuzoenduro
Jan 31 14:30
Thanks. If you need me to do anything just guide me through it
Jon Cluck
@cluckj
Jan 31 20:44
@tuzoenduro can I see your nightscout? (pasting it in a DM is fine)
tuzoenduro
@tuzoenduro
Jan 31 20:48
@cluckj
How do i dm?
Jon Cluck
@cluckj
Jan 31 20:55
hover over my picture and "chat privately"
Dana Lewis
@danamlewis
Jan 31 21:11
(pics in the docs of that here, if needed - click the drop down in this section to see it: https://openaps.readthedocs.io/en/latest/docs/Understanding%20OpenAPS-Overview/communication-support-channels.html#gitter)
tuzoenduro
@tuzoenduro
Jan 31 21:18
@danamlewis i was on the phone, could not see the chat msg
Dana Lewis
@danamlewis
Jan 31 21:18
no worries. if you can't end up finding it, @cluckj may be able to start it for you so it shows up in your column on the left side as a chat option
EmericSch
@EmericSch
Jan 31 21:52
Hi, I am fairly new to the idea of looping.
Now I am hunting for parts to build the thing.
I found edi2arduin.al.k. but in the documentation it says EDI2.SPON. Will the edi2arduin.al.k. still work?
https://uk.rs-online.com/web/p/processor-microcontroller-development-kits/8330895/
Thx