These are chat archives for nightscout/intend-to-bolus

14th
Mar 2019
Deweyoxberg
@Deweyoxberg
Mar 14 00:45
Anyone ever see this type of error before? Wondering why the parsing failed:
Mar 14 06:54:08 DiabeticinJapan autosens-loop.log: Could not parse input data:  SyntaxError: /root/myopenaps/monitor/pumphistory-24h-zoned.json: Unexpected end of JSON input
Mar 14 06:54:08 DiabeticinJapan autosens-loop.log:     at JSON.parse (<anonymous>)
Mar 14 06:54:08 DiabeticinJapan autosens-loop.log:     at Object.Module._extensions..json (module.js:672:27)
Mar 14 06:54:08 DiabeticinJapan autosens-loop.log:     at Module.load (module.js:566:32)
Mar 14 06:54:08 DiabeticinJapan autosens-loop.log:     at tryModuleLoad (module.js:506:12)
Mar 14 06:54:08 DiabeticinJapan autosens-loop.log:     at Function.Module._load (module.js:498:3)
Mar 14 06:54:08 DiabeticinJapan autosens-loop.log:     at Module.require (module.js:597:17)
Mar 14 06:54:08 DiabeticinJapan autosens-loop.log:     at require (internal/module.js:11:18)
Mar 14 06:54:08 DiabeticinJapan autosens-loop.log:     at Object.<anonymous> (/home/.rootfs/usr/local/lib/node_modules/oref0/bin/oref0-detect-sensitivity.js:53:32)
Mar 14 06:54:08 DiabeticinJapan autosens-loop.log:     at Module._compile (module.js:653:30)
Mar 14 06:54:08 DiabeticinJapan autosens-loop.log:     at Object.Module._extensions..js (module.js:664:10)
Mar 14 06:54:08 DiabeticinJapan autosens-loop.log: Failed to refresh autosens: using old autosens.json: {"ratio":1}
Mar 14 06:54:08 DiabeticinJapan autosens-loop.log: Completed oref0-autons-loop at Thu Mar 14 06:54:07 JST 2019
Resolved itself without intervention, but it messed up BG for the fourish hours this was recurring.
zasteph
@zasteph
Mar 14 03:11
i started a new rig this pm, with intel edison and G4-upload; it looks amazing so far, thank you all! The rig is crashing every now and then (every 1h to 1.5h). I had the log tail on tha screen all the time so far, would that be a problem? Where should I look for the crash cause? Thank you!
viq
@viq
Mar 14 07:37
@zasteph in /var/log/ you should have all system logs in either messages or syslog
Abigail Cember
@acember
Mar 14 16:11
Hey guys, another autosens question: Does autosens take into account whether you have any exercise logged? I'm wondering if I shouldn't tell nightscout about the large amounts of carbohydrates I eat before running, because I don't want autosens to think that I can normally absorb that many without any bolus and change my ratio accordingly.
Scott Leibrand
@scottleibrand
Mar 14 16:23
If you set an activity mode for exercise it will introduce negative deviations to help jump-start detection of post-exercise sensitivity. And autosens doesn’t detect carb ratio, so the deviations after carb entry will be ignored by autosens. Autotune does, but it’s better to announce the carbs (possibly with a slight underestimate) to make sure it doesn’t misattribute the carb rise as you needing higher basals.
Abigail Cember
@acember
Mar 14 17:03
Sorry, I meant autotune. So what will it do if it simply has no bloodsugar data for an two hours or so after those carbs are logged in NS? -- I don't wear my sensor while running. (The reason I'm putting the carbs in NS is really just for my own record keeping., but I won't do that if it will screw something up.)
Scott Leibrand
@scottleibrand
Mar 14 17:18
I'm not sure whether carbs will get decayed properly over the CGM gap. If they don't, you could enter fewer carbs, but it's still good to have some sort of carb entry so the system knows to ignore any BG rise.
Riko L
@Ricco555
Mar 14 17:46
what is the recommended way of switching between multiple wifi + BT tethering ? According to openaps guide or through connman?
samueldemers2
@samueldemers2
Mar 14 21:44
@Ricco555 I manage to add a second wifi and BT tethering using theses guides
Hi to all. I manage to get an Edison rig working. Now, I'm back to setup my second rig, a pi0/HAT. I ran everything without much trouble, but it doesn't loop. Here is the log.

root@sadem2:~# l
/usr/local/bin/oref0-pump-loop: line 488: /dev/spidev0.0: Permission denied

Starting oref0-pump-loop at Wed 13 Mar 17:51:44 EDT 2019 with 26 second wait_for_silence:
Waiting up to 4 minutes for new BG: jq: error: Could not open file monitor/glucose.json: No such file or directory
jq: error: Could not open file monitor/glucose.json: No such file or directory
date: invalid date ‘@’
First loop: not waiting

Listening for 26s: .No interfering pump comms detected from other rigs (this is a good thing!)
Continuing oref0-pump-loop at Wed 13 Mar 17:52:14 EDT 2019
Preflight No updates to pump-loop.log in 5m - killing processes
/usr/local/bin/oref0-pump-loop: line 488: /dev/spidev0.0: Permission denied

Starting oref0-pump-loop at Thu 14 Mar 17:38:05 EDT 2019 with 17 second wait_for_silence:
Waiting up to 4 minutes for new BG: First loop: not waiting

Listening for 17s: .No interfering pump comms detected from other rigs (this is a good thing!)
Continuing oref0-pump-loop at Thu 14 Mar 17:38:28 EDT 2019
Preflight fail. Retry 1 of preflight
Preflight fail. Listening for 4s: .No interfering pump comms detected from other rigs (this is a good thing!)
Continuing oref0-pump-loop at Thu 14 Mar 17:39:45 EDT 2019
Retry 2 of preflight
Preflight fail. Listening for 17s: .No interfering pump comms detected from other rigs (this is a good thing!)
Continuing oref0-pump-loop at Thu 14 Mar 17:40:40 EDT 2019
Retry 3 of preflight
Preflight fail. Couldn't preflight
oref0-pump-loop failed. pump_loop_completed more than 15m old; waiting for 39 s silence before mmtuning
"HAT Display Updated"
Listening for 39s: .No interfering pump comms detected from other rigs (this is a good thing!)
Continuing oref0-pump-loop at Thu 14 Mar 17:41:56 EDT 2019
Listening for 39 s silence before mmtuning: Listening for 39s: .No interfering pump comms detected from other rigs (this is a good thing!)
Continuing oref0-pump-loop at Thu 14 Mar 17:42:36 EDT 2019
mmtune:
No wait required.
If pump and rig are close enough, this error usually self-resolves. Stand by for the next loop.
Unsuccessful oref0-pump-loop at Thu 14 Mar 17:43:11 EDT 2019
grep: monitor/temp_basal.json: No such file or directory

Does anybody have any idea what might be wrong ?