These are chat archives for nightscout/intend-to-bolus

23rd
Mar 2019
Jon Cluck
@cluckj
Mar 23 00:00
apt-get remove jq
run jq --version after that's finished, to make sure it's gone
Travis Cannell
@diabeticpilot
Mar 23 00:01
ok removed and checked
Jon Cluck
@cluckj
Mar 23 00:03
maybe apt-get update too, just 'cause
Travis Cannell
@diabeticpilot
Mar 23 00:04
root@beartravel:~# apt-get -y -t jessie-backports install jq
Reading package lists... Done
Building dependency tree
Reading state information... Done
jq is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@beartravel:~#
oh that's an idea
:(
still 1.4.1
Jon Cluck
@cluckj
Mar 23 00:07
uh oh
is that blank for anyone else?
Travis Cannell
@diabeticpilot
Mar 23 00:08
yes, that is blank for me
Jon Cluck
@cluckj
Mar 23 00:11
ugh.
sorry
Travis Cannell
@diabeticpilot
Mar 23 00:14
hmmm how do I instlal from that? is there a command like wget or....
Jon Cluck
@cluckj
Mar 23 00:15
if you scroll down, there's install instructions
Travis Cannell
@diabeticpilot
Mar 23 00:23
hmmm i can't figure this out. I am going to try just master + manual Logger
Jon Cluck
@cluckj
Mar 23 00:27
I'm looking for a way around it :)
Travis Cannell
@diabeticpilot
Mar 23 00:34
OK lmk what you find. Master died too :(
Jon Cluck
@cluckj
Mar 23 00:38
cd && wget http://cdn-fastly.deb.debian.org/debian/pool/main/j/jq/jq_1.5+dfsg-1.3~bpo8+1_i386.deb
then dpkg -i jq_1.5+dfsg-1.3~bpo8+1_i386.deb
@diabeticpilot ^
Travis Cannell
@diabeticpilot
Mar 23 00:46
Resolving cdn-fastly.deb.debian.org (cdn-fastly.deb.debian.org)... 151.101.52.204, 2a04:4e42:d::204
Connecting to cdn-fastly.deb.debian.org (cdn-fastly.deb.debian.org)|151.101.52.204|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 59968 (59K) [application/x-debian-package]
Saving to: ‘jq_1.5+dfsg-1.3~bpo8+1_i386.deb.1’

jq_1.5+dfsg-1.3~bpo 100%[=====================>]  58.56K  --.-KB/s   in 0.08s

2019-03-22 17:45:39 (727 KB/s) - ‘jq_1.5+dfsg-1.3~bpo8+1_i386.deb.1’ saved [59968/59968]

root@beartravel:~# dpkg -i jq_1.5+dfsg-1.3~bpo8+1_i386.deb
(Reading database ... 37059 files and directories currently installed.)
Preparing to unpack jq_1.5+dfsg-1.3~bpo8+1_i386.deb ...
Unpacking jq (1.5+dfsg-1.3~bpo8+1) over (1.5+dfsg-1.3~bpo8+1) ...
dpkg: dependency problems prevent configuration of jq:
 jq depends on libjq1 (= 1.5+dfsg-1.3~bpo8+1); however:
  Package libjq1 is not installed.
 jq depends on libonig2 (>= 5.9.5); however:
  Package libonig2 is not installed.

dpkg: error processing package jq (--install):
 dependency problems - leaving unconfigured
Processing triggers for man-db (2.7.0.2-5) ...
Errors were encountered while processing:
 jq
weird errors... I might need to reflash
I think with a fresh reflash I can get master to work
Jon Cluck
@cluckj
Mar 23 00:46
do apt-get install jq then try that again
Travis Cannell
@diabeticpilot
Mar 23 00:47
root@beartravel:~# apt-get install jq
Reading package lists... Done
Building dependency tree
Reading state information... Done
jq is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 jq : Depends: libjq1 (= 1.5+dfsg-1.3~bpo8+1) but it is not installable
      Depends: libonig2 (>= 5.9.5) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
root@beartravel:~#
not letting me install jq
Jon Cluck
@cluckj
Mar 23 00:49
we can do the same manual install for those dependencies
wget http://cdn-fastly.deb.debian.org/debian/pool/main/j/jq/libjq1_1.5+dfsg-1.3~bpo8+1_i386.deb (then install it)
(with the dpkg -i command)
then wget http://cdn-fastly.deb.debian.org/debian/pool/main/libo/libonig/libonig2_5.9.5-3.2+deb8u1_i386.deb
install that, then try the jq .deb file
Travis Cannell
@diabeticpilot
Mar 23 00:57
OK that worked! 1.5.1 now
going to install dev and then run setup
Jon Cluck
@cluckj
Mar 23 00:58
:thumbsup:
way easier than a reflash :)
Travis Cannell
@diabeticpilot
Mar 23 00:58
and i've done that 3 times today :)
Jon Cluck
@cluckj
Mar 23 01:09
:sweat_smile:
Igone Porto
@igoneporto_twitter
Mar 23 13:28
Good afternoon. Yesterday afternoon i started with my pi hat version. I had been checking the proposals for several days and decided it was a good moment so as to start. It worked perfectly in my parents house (i included 2 wifis... My parents take care of my baby mosr of the time so i am at their house a lot of time). I went out and discovered i was having a teethering problem but solved it. Went to my house and it became dark. No ssh. It says it does not find anything so as to connect with. I have tried to change the battery, change the usb port, try through serial, .. the battery is out. Bought a new one this morning and even doesnt work. U can just see in the edison the low battery and charging leds. But is just a flash that least half a second. Suggestions? I have directly bought equipment for a new rig cause i suspect the Explorer hat is died. Suggestions? Proposals?
Ebgineer
@Ebgineer
Mar 23 17:24
@igoneporto_twitter Can you try powering the pi from a wall charger instead of the battery? That might tell you if the problem is the battery or the pi.
Igone Porto
@igoneporto_twitter
Mar 23 17:32
Hello @Ebgineer didnt work. Try different chargers. 2 computers, 4 wall chargers. Same result. 0.
Ebgineer
@Ebgineer
Mar 23 20:32
@igoneporto_twitter Sounds bad. Are you able to connect the pi directly to a monitor using an HDMI cable? You could use that to see if it responds at all when powered on.
j4cbo
@j4cbo
Mar 23 22:56
@diabeticpilot did you get a special issuance or do sport?