These are chat archives for nightscout/intend-to-bolus

8th
Apr 2019
John McElmurray
@jm991
Apr 08 03:35

thanks for the instructions to use jubilinux 0.3! https://github.com/openaps/docs/blob/7128440b989e3602a3d64fe05831adc9c104d11a/docs/docs/Build%20Your%20Rig/edison-install.md

worked like a peach and i'm up and running

vsherbeck
@vsherbeck
Apr 08 09:34
I'm back up and running but... the rig is crashing nightscout again. Fortunately this time I can log into ssh so maybe I can do something about it.
vsherbeck
@vsherbeck
Apr 08 09:43
https://imgur.com/dKPA0pu
https://imgur.com/6VHojpx
A couple imgurs of my papertrail logs
Martin Haeberli
@mhaeberli
Apr 08 10:56
Is it possible that your lab database is full?
Ralsty12
@Ralsty12
Apr 08 12:36
@vsherbeck how did you sort the
Error with spi_serial
vsherbeck
@vsherbeck
Apr 08 14:11
@Ralsty12 I started over from 0--reflashed the drive, then setup
Jon Cluck
@cluckj
Apr 08 14:12
@vsherbeck the fix for that is easy, hold on a sec :)
vsherbeck
@vsherbeck
Apr 08 14:13
Maybe my database is full...? I need to check that out. And ooh, there's guides for it...
Jon Cluck
@cluckj
Apr 08 14:17
@vsherbeck replace ~/src/openaps-menu/scripts/getvoltage.sh with the following: https://raw.githubusercontent.com/openaps/openaps-menu/54865cfbb93bb2f5ce3caa74bcb99f0a3b25f59b/scripts/getvoltage.sh
and clear out your devicestatus collection in mlab
Andrew Baugh
@baughaw
Apr 08 15:30
@vsherbeck Are you running on Heroku?
Raymond Richmond
@PedanticAvenger
Apr 08 15:39
Hmmm, @cluckj re: the bluetooth issues above. I just had the same issue on a rig that has been running for a long time, I THINK I've fixed it but I suspect the root cause was running an update..... I'll keep an eye on it.
Jon Cluck
@cluckj
Apr 08 15:51
@PedanticAvenger which kind of update?
Raymond Richmond
@PedanticAvenger
Apr 08 15:51
The only event I have was doing OS updates via apt that correlates at all to my tethering ceasing to work.
But really that doesn't make any sense.
But only correlation....
Jon Cluck
@cluckj
Apr 08 15:53
it makes sense; what was your fix?
Raymond Richmond
@PedanticAvenger
Apr 08 15:55
Bash it till it worked? :) Till I stopped to think I went through a run-again and seemed to be able to make it work. But I'm still watching, could be simply a case of it working in test-bench scenario and could still be failing in the real world. I agree with the "conflict between system and openaps trying to start it" thought.
Jon Cluck
@cluckj
Apr 08 16:00
hah
could have been a config thing that an apt package overwrote, that runagain over-overwrote
Raymond Richmond
@PedanticAvenger
Apr 08 16:28
Could indeed be the case. At this point I'd rather anyone be able to focus on a jubilinux upgrade and install docs/code changing to reflect that. Better to drop this stuff and move along with something reasonably current.
Jon Cluck
@cluckj
Apr 08 16:42
I've been working on that, lots of moving parts though :)
stuff to get master working is in: https://github.com/cluckj/oref0/tree/master and dev is mostly working out-of-the-box
Alfredo kachy
@kachytronico
Apr 08 16:44
I already have everything working. I had to manually edit log_files.yml
Thanks a thousand.
Jon Cluck
@cluckj
Apr 08 16:45
@kachytronico great :D
Alfredo kachy
@kachytronico
Apr 08 16:45
@cluckj
The connection is stable and has not failed again.
Jon Cluck
@cluckj
Apr 08 16:47
:thumbsup:
Raymond Richmond
@PedanticAvenger
Apr 08 19:19
@cluckj I think we are reasonably close to seeing dev as it currently is move to master so maybe we should think about if it is worth looking to closely at current master. And yes, when I say reasonably I understand the variability involved. :)
Jon Cluck
@cluckj
Apr 08 19:38
:laughing:
vsherbeck
@vsherbeck
Apr 08 20:06
So I cleaned out the devicestatus collection in mLab. I'm no where near a full database at this time. I am running on heroku...
Would the command to replace that be something like that 'cd ~/src/ && rm -rf' one ? @cluckj
vsherbeck
@vsherbeck
Apr 08 20:11
or wait... that replacement looks more like something from heroku cli
or... no... I don't know anymore haha. I'm no programmer
marafie
@marafie
Apr 08 20:15
Hi.. can the rig switch between offline looping and online looping at the same time when their is no internet connection ?
In the old setup my rig used to get the BG from the NS... but after updating it gets it from Xdrip as a source and only works when the android mobile is close to it
It’s connects via BT and gets the BG
Jon Cluck
@cluckj
Apr 08 21:05
@vsherbeck cd ~/src/openaps-menu/scripts/ && rm getvoltage.sh && wget https://raw.githubusercontent.com/openaps/openaps-menu/54865cfbb93bb2f5ce3caa74bcb99f0a3b25f59b/scripts/getvoltage.sh
Riko L
@Ricco555
Apr 08 21:23
If pump (Medtronic 722) is set to receive BG from Contour Next Meter, can it interfere with openaps communication with the pump?
Abigail Cember
@acember
Apr 08 22:38
Random: Are any of you geeks located in Boston? (Seems likely)
Riko L
@Ricco555
Apr 08 22:40
sorry.. half a globe away from Boston.. sleepy time. GN.