These are chat archives for nightscout/intend-to-bolus

11th
Apr 2019
Jonathan Arms
@phinious_arms_twitter
Apr 11 00:25 UTC

I'm trying to set up my first rig. I'm not a developer so it's challenging. I got stuck trying when I'm trying to save my OpenAPS parameters to my rig. I get the followign error. Any suggestions on what I'm doing wrong or missing? This is the error message: W: Failed to fetch http://http.debian.net/debian/dists/jessie-updates/InRelease Unable to find expected entry 'main/binary-i386/Packages' in Release file (Wrong sources.list entry or malformed file)

W: Failed to fetch http://http.debian.net/debian/dists/jessie-backports/main/binary-i386/Packages 404 Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.
Error executing command, exiting
Couldn't setup node 8
root@JonathanRig723:~#

marafie
@marafie
Apr 11 07:40 UTC

``` curl https://raw.githubusercontent.com/openaps/oref0/$BRANCH/bin/openaps-install.sh > /tmp/openaps-install.sh $BRANCH
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- 0:00:03 --:--:-- 0curl: (60) SSL certificate problem: certificate is not yet valid
More details here: http://curl.haxx.se/docs/sslcerts.html

curl performs SSL certificate verification by default, using a "bundle"
of Certificate Authority (CA) public keys (CA certs). If the default
bundle file isn't adequate, you can specify an alternate file
using the --cacert option.
If this HTTPS server uses a certificate signed by a CA represented in
the bundle, the certificate verification probably failed due to a
problem with the certificate (it might be expired, or the name might
not match the domain name in the URL).
If you'd like to turn off curl's verification of the certificate, use
the -k (or --insecure) option.
root@jubilinux:~# ```

i am getting this error when i use the instructions in
marafie
@marafie
Apr 11 07:46 UTC
i am facing this and i cant downlaod the openaps files
the net works ok
marafie
@marafie
Apr 11 10:38 UTC
after several hours trying to fix the issues i am facing
i get this

``` Starting oref0-pump-loop at Thu Apr 11 13:36:02 +03 2019 with 10 second wait_for_silence:
Waiting up to 4 minutes for new BG: jq: monitor/glucose.json: No such file or directory
jq: monitor/glucose.json: No such file or directory
ls: cannot access /tmp/pump_loop_completed: No such file or directory
Radio ok. Listening: .No interfering pump comms detected from other rigs (this is a good thing!)
Preflight OK. Profile less than 60m old; Profile valid. touch: failed to get attributes of ‘monitor/glucose.json’: No such file or directory
Couldn't touch /tmp/pump_loop_enacted -r monitor/glucose.json
oref0-pump-loop failed. pump_loop_completed more than 15m old; waiting for 40s silence before mmtuning
Radio ok. Listening: .No interfering pump comms detected from other rigs (this is a good thing!)

The CC111x is located at /dev/spidev5.1
RileyLink OK
Version: subg_rfspy 0.8
OK ```

marafie
@marafie
Apr 11 11:09 UTC
all the errors which i have been facing , i think are realted to that jessie is no longer supported
Riko L
@Ricco555
Apr 11 13:57 UTC

How much data volume does openaps need per month?

@Volberger judging from the log size sent to papertrail, ~2-5MB per day outbound. I would assume similar for the inbound traffic as it needs to read data from NS, and also when autotune runs. So in total I would assume around 5-10MB per day if openaps cycles normally.

Dana Lewis
@danamlewis
Apr 11 14:21 UTC
@marafie how do you get your BGs to the rig? Looks like it’s missing your glucose
marafie
@marafie
Apr 11 14:21 UTC
@danamlewis xdrip
i think all the issues i am facing are from the jessie
i updated to jubilinux 0.3.0
and flashed
and now i am updating
but no idea why do i now i am getting issues like
Err:27 http://cdn-fastly.deb.debian.org/debian stretch/main i386 iproute all 1:4.9.0-1+deb9u1
Unable to connect to cdn-fastly.deb.debian.org:http:
Err:28 http://cdn-fastly.deb.debian.org/debian stretch/main i386 publicsuffix all 20181003.1334-0+deb9u1
Unable to connect to cdn-fastly.deb.debian.org:http:
Err:29 http://cdn-fastly.deb.debian.org/debian stretch/main i386 xxd i386 2:8.0.0197-4+deb9u1
Unable to connect to cdn-fastly.deb.debian.org:http:
Get:3 http://security.debian.org stretch/updates/main i386 libpython2.7-dev i386 2.7.13-2+deb9u3 [28.2 MB]
Get:3 http://security.debian.org stretch/updates/main i386 libpython2.7-dev i386 2.7.13-2+deb9u3 [28.2 MB]
87% [3 libpython2.7-dev 25.2 MB/28.2 MB 89%]
is this normal ?
i do have a net connection
but still no idea why i am getting this
Katja Jacob
@straykatz
Apr 11 14:43 UTC
@kachytronico @cluckj Hi, I tried Alfredo's writeup a few times, but I do not get farther than this:
Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
root@blue:~# sudo service cron stop
root@blue:~# killall bluetoothd
root@blue:~# bluetoothd &
[1] 1620
root@blue:~# sudo hciconfig hci0 name $HOSTNAME
Can't get device info: No such device
root@blue:~#
Can't get device info: No such device
root@blue:~# bluetoothctl
[bluetooth]# power off
No default controller available
[bluetooth]# power on
No default controller available
[bluetooth]#
marafie
@marafie
Apr 11 14:46 UTC
@danamlewis i ran setup
got this
Successfully built mmeowlink
Installing collected packages: mmeowlink, six
Found existing installation: six 1.10.0
Not uninstalling six at /usr/lib/python2.7/dist-packages, outside environment /usr
Successfully installed mmeowlink-0.11.1 six-1.12.0
/root/src/oref0/bin/oref0-setup.sh: line 587: oref0-get-profile: command not found
Could not run oref0-get-profile
marafie
@marafie
Apr 11 14:51 UTC
oref0-get-profile --updatePreferences preferences_from_args.json > pref$ .....
marafie
@marafie
Apr 11 14:57 UTC
many commands like npm are missing
marafie
@marafie
Apr 11 15:02 UTC
tried to install npm

Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
npm : Depends: nodejs (>= 6.11~) but 4.8.2~dfsg-1 is to be installed
Depends: node-abbrev (>= 1.1.1~) but 1.0.9-1 is to be installed
Depends: node-ansi-regex (>= 3.0~) but 2.0.0-1 is to be installed
Depends: node-cacache (>= 10.0.4~) but it is not going to be installed

any clue
for the past 4 days i tried 2 intel edison and 1 respi zero, and was not successful in any
marafie
@marafie
Apr 11 15:13 UTC
in the docs their are many images for jubilinux, i used V0.3.0 is this the correct one ?
Scott Leibrand
@scottleibrand
Apr 11 15:20 UTC
Yes, you’ll want jubilinux 0.3.0. Are you sure the rig has good Internet connectivity? If you got into a bad state with packages, it may be easiest to reflash and try again.
marafie
@marafie
Apr 11 15:20 UTC
will try now again
thanks
marafie
@marafie
Apr 11 15:26 UTC
@scottleibrand after flashing, i will use the boot strap script ?
marafie
@marafie
Apr 11 15:46 UTC

Wifi SSID: iPhone
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
curl: (60) SSL certificate problem: certificate is not yet valid
More details here: https://curl.haxx.se/docs/sslcerts.html

curl performs SSL certificate verification by default, using a "bundle"
of Certificate Authority (CA) public keys (CA certs). If the default
bundle file isn't adequate, you can specify an alternate file
using the --cacert option.
If this HTTPS server uses a certificate signed by a CA represented in
the bundle, the certificate verification probably failed due to a
problem with the certificate (it might be expired, or the name might
not match the domain name in the URL).
If you'd like to turn off curl's verification of the certificate, use
the -k (or --insecure) option.

@scottleibrand i flashed and used the bootstrap script
got this at the end
any suggestions ?
marafie
@marafie
Apr 11 16:08 UTC
i used the -k and got the following

vim is already the newest version (2:8.0.0197-4+deb9u1).
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
npm : Depends: nodejs (>= 6.11~) but 4.8.2~dfsg-1 is to be installed
Depends: node-abbrev (>= 1.1.1~) but 1.0.9-1 is to be installed
Depends: node-ansi-regex (>= 3.0~) but 2.0.0-1 is to be installed
Depends: node-cacache (>= 10.0.4~) but it is not going to be installed
Depends: node-config-chain (>= 1.1.11~) but it is not going to be installed
Depends: node-glob (>= 7.1.2~) but 7.1.1-1 is to be installed
Depends: node-hosted-git-info (>= 2.6~) but 2.1.5-1 is to be installed
Depends: node-ini (>= 1.3.5~) but 1.1.0-1 is to be installed
Depends: node-npm-package-arg but it is not going to be installed
Depends: node-jsonstream (>= 1.3.2~) but 1.0.3-4 is to be installed
Depends: node-libnpx (>= 10.0.1~) but it is not going to be installed
Depends: node-lockfile (>= 1.0.3~) but 0.4.1-1 is to be installed
Depends: node-lru-cache (>= 4.1.1~) but 4.0.2-1 is to be installed
Depends: node-move-concurrently (>= 1.0.1~) but it is not going to be installed
Depends: node-normalize-package-data (>= 2.4~) but 2.3.5-2 is to be installed
Depends: node-gyp (>= 3.6.2~) but 3.4.0-1 is to be installed
Depends: node-resolve-from (>= 4.0~) but 2.0.0-1 is to be installed
Depends: node-npmlog (>= 4.1.2~) but 0.0.4-1 is to be installed
Depends: node-osenv (>= 0.1.5~) but 0.1.0-1 is to be installed
Depends: node-read-package-json (>= 2.0.13~) but 1.2.4-1 is to be installed
Depends: node-request (>= 2.83~) but 2.26.1-1 is to be installed
Depends: node-retry (>= 0.10.1~) but 0.6.0-1 is to be installed
Depends: node-rimraf (>= 2.6.2~) but 2.5.4-2 is to be installed
Depends: node-semver (>= 5.5~) but 5.3.0-1 is to be installed
Depends: node-sha (>= 2.0.1~) but 1.2.3-1 is to be installed
Depends: node-slide (>= 1.1.6~) but 1.1.4-1 is to be installed
Depends: node-strip-ansi (>= 4.0~) but 3.0.1-1 is to be installed
Depends: node-tar (>= 4.4~) but 2.2.1-1 is to be installed
Depends: node-boxen (>= 1.2.1~) but it is not going to be installed
Depends: node-latest-version (>= 3.0~) but it is not going to be installed
Depends: node-which (>= 1.3~) but 1.2.11-1 is to be installed
E: Unable to correct problems, you have held broken packages.
root@jubilinux:~#

Riko L
@Ricco555
Apr 11 16:45 UTC

If I have ISF in NS profile set to 18 (324 mg/dL/U), where do autosense gets the value of 180? Am I wrong in assuming that autosense should use the value from NS profile and correct it by a factor depending on detected sensitivity (or resistance) ?
This is the output from autosense-loop.log

Starting oref0-autosens-loop at Thu Apr 11 11:19:03 CEST 2019:
Warning: could not parse settings/temptargets.json
Calculating sensitivity using 8h of non-exluded data
Setting lastSiteChange to 2019-04-10T18:26:09.000Z using timestamp 2019-04-10T20:26:09+02:00
+++--21h-------++++-22h=--++------+-23h---!!10g(x!xxxx0h=xxxx)++-----+1h+-++-+------2h=---+++++++++3h++++-+-+----4
h=---+--+---+-5h++++++++++++6h=++-+----!!u(x!35g(xxxxxxxxxxxx8h=xxxxxx!!)u(x!xxx9hxx!!x!xx)+-++10h=++++++++++++11h
++ 
Using most recent 97 deviations since 2019-04-10T18:26:09.000Z
58% of non-meal deviations positive (>50% = resistance)
37% of non-meal deviations negative (>50% = sensitivity)
RMS deviation: 4.28
Insulin resistance detected: ISF adjusted from 180 to 154

for the record, autotune recommends ISF of 450.

Dana Lewis
@danamlewis
Apr 11 16:47 UTC
OpenAPS doesn’t use any values from Ns profile
It’s using value from pump for autotune and autosens calms
Riko L
@Ricco555
Apr 11 16:59 UTC
sorry, what does it mean "autosens calms"? the pump is in sync with the NS profile related to the ISF, and I've limited autosense max and min to 1,2 and 0,8
based on that autosense should have the lowest value of 324*0,8 = 259 . Am I missing something?
Dana Lewis
@danamlewis
Apr 11 17:05 UTC
Sorry, typo
What does your autotune say currently? That’s the isf that autosens is using
Riko L
@Ricco555
Apr 11 17:07 UTC
this is the first part of autotune_recommendation:
Parameter      | Pump        | Autotune    | Days Missing
---------------------------------------------------------
ISF [mg/dL/U]  | 360.000     | 450.000     |
Carb Ratio[g/U]| 40.000      | 35.210      |
but the pump has 3 values of ISF depending of the time, the lowest is during 07 - 21h and the value is 324
Dana Lewis
@danamlewis
Apr 11 17:14 UTC
K. I am out with family and the gitter app won’t let me read the autosens log you posted. Maybe @cluckj or someone on. A computer today can help investigate. But if I remember correctly you ran into this problem before, too? may be an edge case that needs fixing..
Remind us, master or dev? And what hardware?
Riko L
@Ricco555
Apr 11 17:16 UTC
yes. struggling with this thing all along. HW is Edison. and it's on latest dev
Dana Lewis
@danamlewis
Apr 11 17:18 UTC
K ty
Riko L
@Ricco555
Apr 11 17:22 UTC
I'll wait if someone else can help out, don't let me take your time from family.
cannot figure out why it reduces the ISF to such low levels. I would shut down the autosense for time being and use only autotune, but not sure how and what impact would it produce.
Dana Lewis
@danamlewis
Apr 11 17:23 UTC
Worth a try, set your max and min to 1?
Then should just use autotune value
Riko L
@Ricco555
Apr 11 17:23 UTC
thanks. will do that and monitor for a day/two :+1:
Dana Lewis
@danamlewis
Apr 11 17:28 UTC
If it doesn’t change the isf being used that should also give a clue for debugging
Riko L
@Ricco555
Apr 11 17:47 UTC
I see it changed ISF to 180 (with Autosense ratio 1), so now I have to figure out where did 180 came from.
Riko L
@Ricco555
Apr 11 17:54 UTC
ok.. I think I have found it.. it came from autotune.json inside myopenaps/settings.
^ is this auto-generated, if yes from where? And how does it relate to autotune_recommendation / pump setting which is totally off, like stated above ?
marafie
@marafie
Apr 11 20:00 UTC
@scottleibrand any suggestion is r guidance on how can I solve the errors I am facing ?.. this is the 1st time for me to install v0.3.0
Or
Scott Leibrand
@scottleibrand
Apr 11 20:22 UTC
@marafie “certificate is not yet valid” means your rig time hasn’t been updated to current time, usually because you don’t have a fully working Internet connection. Maybe try again on another wifi?
Riko L
@Ricco555
Apr 11 21:01 UTC
@marafie try this first:
$ sudo apt-get update
$ curl -sL https://deb.nodesource.com/setup_8.x | sudo -E bash -
$ sudo apt-get install -y nodejs