These are chat archives for nightscout/intend-to-bolus

27th
Apr 2019
Raymond Richmond
@PedanticAvenger
Apr 27 01:42
@scottleibrand Is there a branch of the xdrip offline pulled against dev? I'd like to test this against a clean start on 0.3.0 and dev
Scott Leibrand
@scottleibrand
Apr 27 03:58
I’m not sure what you mean. Isn’t that the branch in the PR?
Chad A. Harper
@chadharper0131
Apr 27 07:27

having a wee bit of trouble with the setup script ---> root@pi:/home/pi# curl -s https://raw.githubusercontent.com/openaps/oref0/dev/bin/openaps-install.sh > /tmp/openaps-install.sh && bash /tmp/openaps-install.sh
Enter your rig's new hostname (this will be your rig's name in the future, so make sure to write it down): pi

Current default time zone: 'US/Arizona'
Local time is now: Sat Apr 27 00:17:29 MST 2019.
Universal Time is now: Sat Apr 27 07:17:29 UTC 2019.

Get:1 http://raspbian.raspberrypi.org/raspbian stretch InRelease [15.0 kB]
Hit:2 http://archive.raspberrypi.org/debian stretch InRelease
Fetched 15.0 kB in 1s (10.2 kB/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Hit:1 http://archive.raspberrypi.org/debian stretch InRelease
Hit:2 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
acpid is already the newest version (1:2.0.28-1).
locate is already the newest version (4.6.0+git+20161106-2).
ntp is already the newest version (1:4.2.8p10+dfsg-3+deb9u2).
ntpdate is already the newest version (1:4.2.8p10+dfsg-3+deb9u2).
screen is already the newest version (4.5.0-6).
strace is already the newest version (4.15-2).
sudo is already the newest version (1.8.19p1-2.1).
tcpdump is already the newest version (4.9.2-1~deb9u1).
vim is already the newest version (2:8.0.0197-4+deb9u1).
python-pip is already the newest version (9.0.1-2+rpt2).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
PermitRootLogin yes
Acquire::ForceIPv4 "true";
Reading package lists... Done
Building dependency tree
Reading state information... Done
sudo is already the newest version (1.8.19p1-2.1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Hit:1 http://archive.raspberrypi.org/debian stretch InRelease
Hit:2 http://raspbian.raspberrypi.org/raspbian stretch InRelease
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
acpid is already the newest version (1:2.0.28-1).
git is already the newest version (1:2.11.0-3+deb9u4).
lm-sensors is already the newest version (1:3.4.0-4).
locate is already the newest version (4.6.0+git+20161106-2).
python is already the newest version (2.7.13-2).
python-dev is already the newest version (2.7.13-2).
python-numpy is already the newest version (1:1.12.1-3).
screen is already the newest version (4.5.0-6).
software-properties-common is already the newest version (0.96.20.2-1).
strace is already the newest version (4.15-2).
tcpdump is already the newest version (4.9.2-1~deb9u1).
vim is already the newest version (2:8.0.0197-4+deb9u1).
watchdog is already the newest version (5.15-2).
python-pip is already the newest version (9.0.1-2+rpt2).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists... Done
Building dependency tree
Reading state information... Done
jq is already the newest version (1.5+dfsg-1.3).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
-----------------------------> and one more page of terminal output! <---------------------------

Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already up-to-date: openaps in /usr/local/lib/python3.5/dist-packages (0.1.5)
Requirement already satisfied, skipping upgrade: gitpython in /usr/local/lib/python3.5/dist-packages (from openaps) (2.1.11)
Requirement already satisfied, skipping upgrade: argcomplete in /usr/local/lib/python3.5/dist-packages (from openaps) (1.9.4)
Requirement already satisfied, skipping upgrade: dexcom-reader>=0.1.8 in /usr/local/lib/python3.5/dist-packages (from openaps) (0.1.10)
Requirement already satisfied, skipping upgrade: mock in /usr/local/lib/python3.5/dist-packages (from openaps) (2.0.0)
Requirement already satisfied, skipping upgrade: decocare>0.0.26 in /usr/local/lib/python3.5/dist-packages (from openaps) (0.0.30)
Requirement already satisfied, skipping upgrade: python-dateutil in /usr/local/lib/python3.5/dist-packages (from openaps) (2.8.0)
Requirement already satisfied, skipping upgrade: pyserial in /usr/lib/python3/dist-packages (from openaps) (3.2.1)
Requirement already satisfied, skipping upgrade: nose in /usr/local/lib/python3.5/dist-packages (from openaps) (1.3.7)
Requirement already satisfied, skipping upgrade: gitdb2>=2.0.0 in /usr/local/lib/python3.5/dist-packages (from gitpython->openaps) (2.0.5)
Requirement already satisfied, skipping upgrade: pbr>=0.11 in /usr/local/lib/python3.5/dist-packages (from mock->openaps) (5.1.3)
Requirement already satisfied, skipping upgrade: six>=1.9 in /usr/lib/python3/dist-packages (from mock->openaps) (1.12.0)
Requirement already satisfied, skipping upgrade: smmap2>=2.0.0 in /usr/local/lib/python3.5/dist-packages (from gitdb2>=2.0.0->gitpython->openaps) (2.0.5)
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already up-to-date: openaps-contrib in /usr/local/lib/python3.5/dist-packages (0.0.15)
Requirement already satisfied, skipping upgrade: recurrent in /usr/local/lib/python3.5/dist-packages (from openaps-contrib) (0.2.5)
Requirement already satisfied, skipping upgrade: parsedatetime in /usr/local/lib/python3.5/dist-packages (from recurrent->openaps-contrib) (2.4)
Requirement already satisfied, skipping upgrade: future in /usr/local/lib/python3.5/dist-packages (from parsedatetime->recurrent->openaps-contrib) (0.17.1)
installed /etc/udev/rules.d/80-medtronic-carelink.rules
installed /etc/udev/rules.d/80-dexcom.rules
Installing bash completion script /etc/bash_completion.d/python-argcomplete.sh
/usr/bin/json -> /usr/lib/node_modules/json/lib/json.js
  • json@9.0.6
    updated 1 package in 1.467s
    openaps installed
    File "/usr/local/bin/openaps", line 160
    except (OSError), e:
                  ^
    SyntaxError: invalid syntax
    root@pi:/home/pi#
anyone have any idea how to fix, what to do, anything??
any help would be appreciated. Im using a raspberry pi 3b+ and a RFM69HCW radio bonnet. (still dont have the bonnet, theyre out of stock everywhere! but as soon as i find one: i wanna be rtg! --->
marafie
@marafie
Apr 27 08:04
Hi .... I am trying to install nightwatch on S9 it refuses to work....is their any similar app were someone can monitor his kid BG??
This doesn’t work with S9
marafie
@marafie
Apr 27 09:15
Any guidelines how can a parent monitor his logs BG without using the browser ?
Like having nightwatch or being able to setup xdrip plus ?
His kids
Jon Cluck
@cluckj
Apr 27 13:13
@marafie xdrip+ or NSClient are pretty good
viq
@viq
Apr 27 14:11
I have mine displayed on pebble
NSewar
@nsewar01
Apr 27 15:03
Controller 69:A0:39:09:60:3F aps02 [default]
root@normsaps02:~# sudo bt-pan client A4:50:46:43:1D:2C
Traceback (most recent call last):
File "/usr/local/bin/bt-pan", line 228, in <module>
if name == 'main': sys.exit(main())
File "/usr/local/bin/bt-pan", line 196, in main
try: iface = net.Connect(opts.uuid)
File "/usr/lib/python2.7/dist-packages/dbus/proxies.py", line 145, in call
**keywords)
File "/usr/lib/python2.7/dist-packages/dbus/connection.py", line 651, in call_blocking
message, timeout)
dbus.exceptions.DBusException: org.bluez.Error.Failed: Input/output error
Im trying to bluetooth tether edison rig to phone but get aabove error message when I run sudo bt-pan client AA:BB:CC:DD:EE:FF any ideas please?
viq
@viq
Apr 27 15:13
Looks like a timeout, I assume you have tried multiple times? And that you have the addresses right?
NSewar
@nsewar01
Apr 27 15:32
yes
thanks......what is timing out? What is python?
Martin Haeberli
@mhaeberli
Apr 27 15:49

getting repeated iterations of:

Apr 27 08:44:06 etghopenaps04 pushover.log:  enact/suggested.json more than 5 minutes old
Apr 27 08:44:06 etghopenaps04 ns-loop.log:  -rw-r--r-- 1 root root 0 Apr 26 17:01 monitor/pushover-sent
Apr 27 08:44:08 etghopenaps04 autosens-loop.log:  Could not parse input data:  { Error: Cannot find module '/root/myopenaps/monitor/pumphistory-24h-zoned.json'
Apr 27 08:44:08 etghopenaps04 autosens-loop.log:      at Function.Module._resolveFilename (module.js:548:15)
Apr 27 08:44:08 etghopenaps04 autosens-loop.log:      at Function.Module._load (module.js:475:25)
Apr 27 08:44:08 etghopenaps04 autosens-loop.log:      at Module.require (module.js:597:17)
Apr 27 08:44:09 etghopenaps04 autosens-loop.log:      at require (internal/module.js:11:18)
Apr 27 08:44:09 etghopenaps04 autosens-loop.log:      at Object.<anonymous> (/root/src/oref0/bin/oref0-detect-sensitivity.js:53:32)
Apr 27 08:44:09 etghopenaps04 autosens-loop.log:      at Module._compile (module.js:653:30)
Apr 27 08:44:09 etghopenaps04 autosens-loop.log:      at Object.Module._extensions..js (module.js:664:10)
Apr 27 08:44:09 etghopenaps04 autosens-loop.log:      at Module.load (module.js:566:32)
Apr 27 08:44:09 etghopenaps04 autosens-loop.log:      at tryModuleLoad (module.js:506:12)
Apr 27 08:44:09 etghopenaps04 autosens-loop.log:      at Function.Module._load (module.js:498:3) code: 'MODULE_NOT_FOUND' }
Apr 27 08:44:09 etghopenaps04 autosens-loop.log:  Failed to refresh autosens: using old autosens.json: {"ratio":0.98}
Apr 27 08:44:09 etghopenaps04 autosens-loop.log:  Completed oref0-autosens-loop at Sat Apr 27 08:44:07 PDT 2019

on a jubilunux 0.2.0 Edison Explorer rig that had previously been working.

same rig reporting mmtunes like:

pr 27 08:17:57 etghopenaps04 pump-loop.log:  mmtune: "916.700", 3, -79 -- "916.750", 3, -81 
Apr 27 08:24:08 etghopenaps04 pump-loop.log:  mmtune: "916.700", 3, -77 -- "916.750", 3, -83

but not able to successfully read pump history any more and loop.

advice sought

Craig Brenner
@cbrenner
Apr 27 20:09
Hi All,
Wondering if someone currently using Fiasp could point me to a reference or provide some guidance on best practices for Fiasp usage with and without Loop or OpenAPS. I know there is a configuration option for using the Fiasp insulin model with OpenAPS.
  • What about basal rates? Do you need to make any changes in the basal rate start times since the peak is earlier in Fiasp?
  • Assume that with the peak being earlier, you don't plan you basal rate change for 1-2 hours before it is needed but perhaps right at the time of need or perhaps 30 mins earlier?
  • What about pre-meal targets and pre-bolusing? I understand that many people are NOT prebolusing with Fiasp although my son's Endo says he knows many that still need to prebolus.
  • Any other best practices, advice, or caveats to consider?
    Thanks!
viq
@viq
Apr 27 20:20
I heard that for some people fiasp just stops working after some months. Also I heard of people having to change sites more often because of it crystalising. But all that is just second or third hand information, I have no personal experience.
oleg-post
@oleg-post
Apr 27 21:01

Hi. Having run script curl -s https://raw.githubusercontent.com/openaps/oref0/dev/bin/openaps-install.sh > /tmp/openaps-install.sh && bash /tmp/openaps-install.sh I ran SUDO POWEROFF and got

sudo: unable to resolve host raspberrypi

What is it?

viq
@viq
Apr 27 21:13
@oleg-post you can safely ignore it, or if you care edit /etc/hosts so the line that has localhost in it also has
raspberrypi
oleg-post
@oleg-post
Apr 27 21:14
@viq OK! But the reboot doesn't work.
@viq In file /etc/host the right name of host is mentioned.
@oleg-post sudo shutdown -h now doesn't work either.
viq
@viq
Apr 27 21:19
What happens if you ping -c 3 raspberrypi?
oleg-post
@oleg-post
Apr 27 21:21
@viq nothing
viq
@viq
Apr 27 21:21
And sudo id?
oleg-post
@oleg-post
Apr 27 21:22
@viq
uid=0(root) gid=0(root) groups=0(root)
viq
@viq
Apr 27 21:23
Then sudo works and that message isn't really important, nor does it cause the issue with shutdown or reboot
oleg-post
@oleg-post
Apr 27 21:25
@viq the main problem that shutdown and reboot doesn't work. I thought that it because of resolve.
how can I make shutdown and reboot work?
viq
@viq
Apr 27 21:27
It's not affecting sudo; I don't believe those commands would generally be affected by that either. So that is not the source of your problem, and you don't need to look around there for a solution
Hm
oleg-post
@oleg-post
Apr 27 21:29
I am following the installation process from APS docs. and I stack at first reboot command.
viq
@viq
Apr 27 21:30
I'm not sure to be honest, I'll let others chime in