Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Jan 31 2019 15:51
    xen0n starred openaps/oref0
  • Jan 31 2019 15:12
    cclauss opened #1191
  • Jan 31 2019 15:09
    cclauss edited #1190
  • Jan 31 2019 15:08
    cclauss edited #1189
  • Jan 31 2019 15:07
    cclauss edited #1190
  • Jan 31 2019 15:07
    cclauss opened #1190
  • Jan 31 2019 15:00
    cclauss synchronize #1189
  • Jan 31 2019 14:52
    cclauss opened #1189
  • Jan 31 2019 14:10
  • Jan 31 2019 14:06
    Owaisaaa starred openaps/docs
  • Jan 31 2019 12:20
    cclauss synchronize #22
  • Jan 31 2019 12:16
    cclauss opened #22
  • Jan 31 2019 12:11
    cclauss edited #21
  • Jan 31 2019 12:09
    cclauss opened #21
  • Jan 31 2019 11:31
    tuzoenduro commented #1406
  • Jan 31 2019 11:25
    cclauss opened #140
  • Jan 30 2019 05:53
  • Jan 29 2019 16:03
    tzachi-dar commented #1406
  • Jan 29 2019 14:46
    rostag starred openaps/oref0
  • Jan 27 2019 22:06
    PieterGit synchronize #1176
jmcrawford
@jmcrawford
@elnjensen What does your /etc/wpa_supplicant/wpa_supplicant.conf look like?
Hannah Crabtree
@lollydaggle
this is a silly question - at what point in the setup script do I need to have my devices plugged in? can't get openaps use pump model or openaps use cgm iter_glucose to work
I'm suspicious RE: my carelink working but the CGM should communicate
Eric Jensen
@elnjensen
Interestingly there's is essentially zero documentation on wpa-roam vs. wpa-conf. Lots of pages where people post their configs, but no mention of it in man pages at all.
Scott Leibrand
@scottleibrand
yeah, I had to do some serious digging to find any info on it
Eric Jensen
@elnjensen
So I think a lot of the declarations about what it does or doesn't do are, shall we say, not well documented...
@jmcrawford Give me a sec to sanitize the wpa_supplicant.conf file...
Scott Leibrand
@scottleibrand
@elnjensen agreed
perhaps someone should read the code and update the man pages...
Eric Jensen
@elnjensen
But which code? Is it a part of /etc/network/interfaces, or of wpa-supplicant? I guess must be the latter?
Scott Leibrand
@scottleibrand
dunno, or I probably would've done it. :)
but I can't read core OS code effectively
Eric Jensen
@elnjensen
@jmcrawford OK, here's my /etc/wpa_supplicant/wpa_supplicant.conf. Nothing special in here, just a few networks and the kind of setup you commonly see recommended:
country=US
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
        ssid="aaa"
        psk="****"
        priority=1
        }

network={
        ssid="xxx"
        psk="****"
        scan_ssid=1
        priority=2
        }

network={
        ssid="yyy"
        psk="****"
        priority=3
        }
Scott Leibrand
@scottleibrand
@lollydaggle I would plug everything in before I start, but it shouldn't matter
G. Kidd
@garykidd
pi@raspberrypi:~ $ cd && ~/src/oref0/bin/oref0-setup.sh
Usage: oref0-setup.sh <--dir=directory> <--serial=pump_serial_#> [--tty=/dev/ttySOMETHING] [--max_iob=0] [--ns-host=https://mynightscout.azurewebsites.net] [--api-secret=myplaintextsecret] [--cgm=(G4|G5|MDT)] [--enable='autosens meal']
Start interactive setup? [Y]/n y
What would you like to call your loop directory? [myopenaps] APS401
Ok, APS401 it is.
What is your pump serial number? #########
Ok, ########## it is.
What Kind of CGM are you using? (i.e. G4, G5, MDT) G5
Ok, G5 it is.
Are you using mmeowlink? If not, press enter. If so, what TTY port (i.e. /dev/ttySOMETHING)? /dev/ttyACM0
Ok, TTY /dev/ttyACM0 it is.
Are you using Nightscout? If not, press enter.
If so, what is your Nightscout host? (i.e. https://mynightscout.azurewebsites.net)? https://######.azurewebsites.net
Ok, https://projectfeedback.azurewebsites.net it is.
And what is your Nightscout api secret (i.e. myplaintextsecret)? #############
Ok, ########## it is.
Do you need any advanced features? y/[N] y
Enable automatic sensitivity adjustment? y/[N] y
Enable advanced meal assist? y/[N] y
Setting up oref0 in /home/pi/APS401 for pump ######## with G5 CGM,
NS host https://##########.azurewebsites.net, TTY /dev/ttyACM0, advanced features  autosens  meal 
Continue? y/[N] y
Checking /home/pi/APS401: true
/home/pi/APS401 already exists
/home/pi/src/oref0/ already exists; pulling latest
fatal: unable to connect to github.com:
github.com[0: 192.30.253.112]: errno=No route to host

Couldn't pull latest oref0
Eric Jensen
@elnjensen
I think all the magic happens in /etc/network/interfaces.
Scott Leibrand
@scottleibrand
@garykidd you're not online?
Hannah Crabtree
@lollydaggle
Hmm, I re-ran the setup script anyway. I'm getting my favorite python error when I run the CGM:
Scott Leibrand
@scottleibrand
@garykidd also you missed blacking out one instance of your NS URL
Hannah Crabtree
@lollydaggle
'NoneType' object has no attributes 'iter_records'
Scott Leibrand
@scottleibrand
heh, that's the same one I'm fighting with trying to get openxshareble working
you can also do lsusb to see if the CGM is recognized
G. Kidd
@garykidd
hmmmm...seems strange b/c the computer and my pi on same network i'm ssh'ing into pi ...and this computer has internet access.....
just rebooting pi to see if that'll work
Hannah Crabtree
@lollydaggle
this is my pump/carelink error: serial.serialutil.SerialException: Attempting to use a port that is not open. Wondering if the carelink is fried at this point.
Scott Leibrand
@scottleibrand
dunno, but it might be a good time to start thinking about something more capable like a TI stick
Hannah Crabtree
@lollydaggle
@scottleibrand already on top of it! Ordered the TI and Edison this morning.
Scott Leibrand
@scottleibrand
:-)
did you see the Explorer board post?
Hannah Crabtree
@lollydaggle
Yeah, I put my name in. I know I'll eventually want to get there. I'm trying to take it one step at a time.
Scott Leibrand
@scottleibrand
:+1:
Tim Mecklem
@tmecklem
@danamlewis did you get my name for 2? It looks like the form has a quantity field now and I don’t remember it having that before.
Eric Jensen
@elnjensen
@scottleibrand Downloaded the source code for wpa-supplicant, and the string wpa-roam doesn't appear in any file in the source tree. Don't think I'll chase this unicorn any farther - just happy to have it working! Any place in the docs that /etc/network/interfaces is described? I could take a look and see if a modest PR there would make sense. (And BTW, now that this is setup, it seems I don't need to every run wpa_cli scan - it just finds a new network pretty quickly on its own.)
Dana Lewis
@danamlewis
@tmecklem yep! Added the field after a few of you quick twitch folks had already started inputting :)
Tim Mecklem
@tmecklem
:D
Dana Lewis
@danamlewis
And when you actually order/pay you'll be able to confirm or adjust how many you want. We're nearing 75 already (wow!) so we'll likely round the order up to have a few spares for people who discover this later.
Tim Mecklem
@tmecklem
My wife and her friend are at their T1D meetup tonight and they’ve both been closed loop for a while now. I suspect from the interest there will be a hotspot of openaps fans here around Cincinnati soon.
G. Kidd
@garykidd
@scottleibrand yup....have fun with that...oh well
Tim Street
@tim2000s
👍👍
Dana Lewis
@danamlewis
@tmecklem nice :)
Tim Mecklem
@tmecklem
And judging from their BGs, they didn’t have a presentation tonight :)
G. Kidd
@garykidd
@scottleibrand I re-installed everthing...same error...agian
Tim Street
@tim2000s
You have any numbers for the uk @scottleibrand Or @danamlewis
G. Kidd
@garykidd
MODULE NOT FOUND
Dana Lewis
@danamlewis
@tim2000s numbers - you mean number of boards ordered or something else?
I didn't ask geo on the form so I just have a hunch based on names that I know
G. Kidd
@garykidd
pi@raspberrypi:~/APS401 $ openaps report invoke raw-cgm/raw-entries.json
cgm://JSON/oref0_glucose/raw-cgm/raw-entries.json
raw-cgm/raw-entries.json  raised  'NoneType' object has no attribute 'iter_records'
Traceback (most recent call last):
  File "/usr/local/bin/openaps-report", line 82, in <module>
    app( )
  File "/usr/local/lib/python2.7/dist-packages/openaps/cli/__init__.py", line 51, in __call__
    self.run(self.args)
  File "/usr/local/bin/openaps-report", line 75, in run
    output = app(args, self)
  File "/usr/local/lib/python2.7/dist-packages/openaps/cli/subcommand.py", line 52, in __call__
    return self.method.main(args, app)
  File "/usr/local/lib/python2.7/dist-packages/openaps/reports/invoke.py", line 40, in main
    output = task.method(args, app)
  File "/usr/local/lib/python2.7/dist-packages/openaps/uses/use.py", line 45, in __call__
    output = self.main(args, app)
  File "/usr/local/lib/python2.7/dist-packages/openaps/vendors/dexcom.py", line 532, in main
    iter_glucose = self.get_glucose_data(params, args)
  File "/usr/local/lib/python2.7/dist-packages/openaps/vendors/dexcom.py", line 513, in get_glucose_data
    return itertools.takewhile(self.comparison, self.dexcom.iter_records('EGV_DATA'))
AttributeError: 'NoneType' object has no attribute 'iter_records'
wait...I selected G5...but is there raw with G5.....maybe the report name and the data don't match?
Tim Street
@tim2000s
Sorry @danamlewis I meant users. I requested a couple of boards.
I know of myself and three others in the U.K. Just wondering how many we had.