Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Jan 31 2019 15:51
    xen0n starred openaps/oref0
  • Jan 31 2019 15:12
    cclauss opened #1191
  • Jan 31 2019 15:09
    cclauss edited #1190
  • Jan 31 2019 15:08
    cclauss edited #1189
  • Jan 31 2019 15:07
    cclauss edited #1190
  • Jan 31 2019 15:07
    cclauss opened #1190
  • Jan 31 2019 15:00
    cclauss synchronize #1189
  • Jan 31 2019 14:52
    cclauss opened #1189
  • Jan 31 2019 14:10
  • Jan 31 2019 14:06
    Owaisaaa starred openaps/docs
  • Jan 31 2019 12:20
    cclauss synchronize #22
  • Jan 31 2019 12:16
    cclauss opened #22
  • Jan 31 2019 12:11
    cclauss edited #21
  • Jan 31 2019 12:09
    cclauss opened #21
  • Jan 31 2019 11:31
    tuzoenduro commented #1406
  • Jan 31 2019 11:25
    cclauss opened #140
  • Jan 30 2019 05:53
  • Jan 29 2019 16:03
    tzachi-dar commented #1406
  • Jan 29 2019 14:46
    rostag starred openaps/oref0
  • Jan 27 2019 22:06
    PieterGit synchronize #1176
Hannah Crabtree
@lollydaggle
Yeah, I put my name in. I know I'll eventually want to get there. I'm trying to take it one step at a time.
Scott Leibrand
@scottleibrand
:+1:
Tim Mecklem
@tmecklem
@danamlewis did you get my name for 2? It looks like the form has a quantity field now and I don’t remember it having that before.
Eric Jensen
@elnjensen
@scottleibrand Downloaded the source code for wpa-supplicant, and the string wpa-roam doesn't appear in any file in the source tree. Don't think I'll chase this unicorn any farther - just happy to have it working! Any place in the docs that /etc/network/interfaces is described? I could take a look and see if a modest PR there would make sense. (And BTW, now that this is setup, it seems I don't need to every run wpa_cli scan - it just finds a new network pretty quickly on its own.)
Dana Lewis
@danamlewis
@tmecklem yep! Added the field after a few of you quick twitch folks had already started inputting :)
Tim Mecklem
@tmecklem
:D
Dana Lewis
@danamlewis
And when you actually order/pay you'll be able to confirm or adjust how many you want. We're nearing 75 already (wow!) so we'll likely round the order up to have a few spares for people who discover this later.
Tim Mecklem
@tmecklem
My wife and her friend are at their T1D meetup tonight and they’ve both been closed loop for a while now. I suspect from the interest there will be a hotspot of openaps fans here around Cincinnati soon.
G. Kidd
@garykidd
@scottleibrand yup....have fun with that...oh well
Tim Street
@tim2000s
👍👍
Dana Lewis
@danamlewis
@tmecklem nice :)
Tim Mecklem
@tmecklem
And judging from their BGs, they didn’t have a presentation tonight :)
G. Kidd
@garykidd
@scottleibrand I re-installed everthing...same error...agian
Tim Street
@tim2000s
You have any numbers for the uk @scottleibrand Or @danamlewis
G. Kidd
@garykidd
MODULE NOT FOUND
Dana Lewis
@danamlewis
@tim2000s numbers - you mean number of boards ordered or something else?
I didn't ask geo on the form so I just have a hunch based on names that I know
G. Kidd
@garykidd
pi@raspberrypi:~/APS401 $ openaps report invoke raw-cgm/raw-entries.json
cgm://JSON/oref0_glucose/raw-cgm/raw-entries.json
raw-cgm/raw-entries.json  raised  'NoneType' object has no attribute 'iter_records'
Traceback (most recent call last):
  File "/usr/local/bin/openaps-report", line 82, in <module>
    app( )
  File "/usr/local/lib/python2.7/dist-packages/openaps/cli/__init__.py", line 51, in __call__
    self.run(self.args)
  File "/usr/local/bin/openaps-report", line 75, in run
    output = app(args, self)
  File "/usr/local/lib/python2.7/dist-packages/openaps/cli/subcommand.py", line 52, in __call__
    return self.method.main(args, app)
  File "/usr/local/lib/python2.7/dist-packages/openaps/reports/invoke.py", line 40, in main
    output = task.method(args, app)
  File "/usr/local/lib/python2.7/dist-packages/openaps/uses/use.py", line 45, in __call__
    output = self.main(args, app)
  File "/usr/local/lib/python2.7/dist-packages/openaps/vendors/dexcom.py", line 532, in main
    iter_glucose = self.get_glucose_data(params, args)
  File "/usr/local/lib/python2.7/dist-packages/openaps/vendors/dexcom.py", line 513, in get_glucose_data
    return itertools.takewhile(self.comparison, self.dexcom.iter_records('EGV_DATA'))
AttributeError: 'NoneType' object has no attribute 'iter_records'
wait...I selected G5...but is there raw with G5.....maybe the report name and the data don't match?
Tim Street
@tim2000s
Sorry @danamlewis I meant users. I requested a couple of boards.
I know of myself and three others in the U.K. Just wondering how many we had.
Dana Lewis
@danamlewis
that sounds about right
G. Kidd
@garykidd
@scottleibrand is it becuae there isnt a --no-raw added to openaps use oref0_glucose maybe?
in raw-cgm/raw-entries.json call/
David
@davidkeddydb
Ok, so i made a mistake on the pump today that i see could cause others a problem. Had a high fat meal, meant to square wave some and didn't so I canceled the blous after .1 delivered. I then re-entered and squared as I wanted. COB sees it now as double the carbs. I should have just bolused the amount rather than entering carb amount.
G. Kidd
@garykidd
pick it up tomorrow I guess.
I've seen double entries before in NS without even doing that...I think if you take a big bolus that straddles two NS uploads it might pick it up as two entries....as well.
Scott Leibrand
@scottleibrand
@davidkeddydb yeah, unfortunately that behavior is different between different pumps too
@garykidd yeah, it's possible that you need to add --no-raw - not sure if anyone has thoroughly tested the --G5 support in oref0-setup yet
Tim Street
@tim2000s
I'm running G5 but it's through mobile. I don't have a receiver.
G. Kidd
@garykidd
that part seems easy but I would've thought the NS would kick in for me but nada
@tim2000s that means you're using share and/or NS then for BG?
@tim2000s did you need to add --no-raw to oref0_glucose calls in oref0-setup script?
Im actually thinking the continual sudo wpa cli scans are making my router conk out.....same with my damn * * * * * /home/pi/bin/bt-pan client XX:YY:ZZ:AA:BB:CC in cron causing BT issues in car.....so many links...so many possible broken links...
G. Kidd
@garykidd
@scottleibrand might you be around tomorrow night...I thought I'd have energy tonight....but no dice.
Scott Leibrand
@scottleibrand
perhaps. nothing scheduled yet, but we'll see
G. Kidd
@garykidd
before I hit the hay...any ideas....maybe that NO MODULE FOUND error is OK and it'll start to set basals over time...i was wathcing the damn tail loop log mor ethan NS and now I am wondering if it might kick in on NS
even with that error
Scott Leibrand
@scottleibrand
not sure what "no module found" thing you're talking about
G. Kidd
@garykidd
pi@raspberrypi:~/APS401 $ tail -F /var/log/openaps/pump-loop.log
Listening: .No comms detected
Old pumphistory: 
Error, retrying
Starting pump-loop at Fri 30 Sep 21:06:28 EDT 2016:
Listening: .No comms detected
Old pumphistory: 
Error, retrying
Starting pump-loop at Fri 30 Sep 21:07:28 EDT 2016:
Listening: .Starting pump-loop at Fri 30 Sep 21:10:02 EDT 2016:
Listening: .No comms detected
Old pumphistory: Refreshed pumphistory
Could not parse input data:  { [Error: Cannot find module '/home/pi/APS401/monitor/glucose.json'] code: 'MODULE_NOT_FOUND' }
determine-basal://text/shell/enact/suggested.json
reporting enact/suggested.json
Old pumphistory-24h refreshed
Profile less than 60m old
temp_basal.json less than 5m old
Pumphistory less than 5m old
Settings refreshed
Pumphistory-24 less than 20m old
Completed pump-loop at Fri 30 Sep 21:11:28 EDT 2016
Scott Leibrand
@scottleibrand
oh, you just mean your glucose.json being empty
G. Kidd
@garykidd
sorry...almost.....;MODULE_NOT_FOUND'
yeah...I guess....I am so tired.
Scott Leibrand
@scottleibrand
that won't fix itself.
tomorrow you can work on getting your reports fixed up for your G5, and/or figuring out what's wrong with your NS setup
G. Kidd
@garykidd
happens after every time it Refreshed pumphistory
Scott Leibrand
@scottleibrand
yeah, that's when it checks for updated BG data
but monitor/glucose.json is empty, so it never finds any there
the pump-loop doesn't actually try to pull the BG data: that's happening in the cgm-loop
so all the pump-loop is telling you is "nope, still empty"