Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Jan 31 2019 15:51
    xen0n starred openaps/oref0
  • Jan 31 2019 15:12
    cclauss opened #1191
  • Jan 31 2019 15:09
    cclauss edited #1190
  • Jan 31 2019 15:08
    cclauss edited #1189
  • Jan 31 2019 15:07
    cclauss edited #1190
  • Jan 31 2019 15:07
    cclauss opened #1190
  • Jan 31 2019 15:00
    cclauss synchronize #1189
  • Jan 31 2019 14:52
    cclauss opened #1189
  • Jan 31 2019 14:10
  • Jan 31 2019 14:06
    Owaisaaa starred openaps/docs
  • Jan 31 2019 12:20
    cclauss synchronize #22
  • Jan 31 2019 12:16
    cclauss opened #22
  • Jan 31 2019 12:11
    cclauss edited #21
  • Jan 31 2019 12:09
    cclauss opened #21
  • Jan 31 2019 11:31
    tuzoenduro commented #1406
  • Jan 31 2019 11:25
    cclauss opened #140
  • Jan 30 2019 05:53
  • Jan 29 2019 16:03
    tzachi-dar commented #1406
  • Jan 29 2019 14:46
    rostag starred openaps/oref0
  • Jan 27 2019 22:06
    PieterGit synchronize #1176
Scott Leibrand
@scottleibrand
you can just run the corrected line if you want
openaps alias add gather '! bash -c "(openaps monitor-pump || openaps monitor-pump) 2>/dev/null >/dev/null && echo refreshed pumphistory || (echo unable to refresh pumphistory; exit 1) 2>/dev/null"'
you're using a 512?
peterfulvi
@peterfulvi
ok i just ran it. Yes thhe 512
Scott Leibrand
@scottleibrand
ok, so that was probably the problem then. so few people have 512s that we didn't notice that curly quote mark until now
peterfulvi
@peterfulvi
great. Thank You. Im trying to learn to do PR's.
Scott Leibrand
@scottleibrand
I probably should've had you PR this one, but I just fixed it since " vs ” is so hard to see
peterfulvi
@peterfulvi
image.png
Thisis what it says now
Scott Leibrand
@scottleibrand
looks like you didn't replace the gather alias? openaps alias show gather again?
peterfulvi
@peterfulvi
do i just run those commands?
Scott Leibrand
@scottleibrand
peterfulvi
@peterfulvi
I ran it. Then rebooted. I'll do it again.
Scott Leibrand
@scottleibrand
no need to reboot
just run it and then confirm with openaps alias show gather that it changed
slight chance you might need to stop your cron or do it multiple times to get it to stick, if something else is updating the openaps.ini at the same time
hilarykoch
@hilarykoch
I’ve lost the purple prediction line in NS since successfully starting OpenAPS. I have openaps listed in SHOW_FORECAST in NS. Is there something else I need?
peterfulvi
@peterfulvi
image.png
Scott Leibrand
@scottleibrand
@peterfulvi that looks good now
should be able to run killall -g openaps; openaps gather now
@hilarykoch did you click the ... next to 24HR and enable it there?
Matt Walker
@walker0
@hilarykoch check that the tick box is still ticked
hilarykoch
@hilarykoch
BINGO! Thank YOU!
peterfulvi
@peterfulvi
Hows that
hilarykoch
@hilarykoch
So running successfully for two hours. Woot! The BG range is taken from the pump, right? Unless specified through NS as a temp target? And the ranges set for NS in Heroku don’t affect OpenAPS, right?
peterfulvi
@peterfulvi
image.png
Dana Lewis
@danamlewis
@hilarykoch correct
hilarykoch
@hilarykoch
Great. Thank you!
Dana Lewis
@danamlewis
:+1: :smile:
Scott Leibrand
@scottleibrand
@peterfulvi weird. does another openaps alias show gather show the curly quotes again?
if so, you might need to add the killall to that command too: killall -g openaps; openaps alias add gather '! bash -c "(openaps monitor-pump || openaps monitor-pump) 2>/dev/null >/dev/null && echo refreshed pumphistory || (echo unable to refresh pumphistory; exit 1) 2>/dev/null"'
peterfulvi
@peterfulvi
image.png
Scott Leibrand
@scottleibrand
yep, that looks like the race condition I was talking about. try the killall version
peterfulvi
@peterfulvi
image.png
I ran it this is what it looks like after the kill all
Scott Leibrand
@scottleibrand
ok, I give up on this method. go ahead and re-run oref0-setup.
peterfulvi
@peterfulvi
Ok thanks for your time. Im goin home to my kids now and i,ll have at it tomorrow night on my third shift? I'll keep you posted
Scott Leibrand
@scottleibrand
k
have a good evening
peterfulvi
@peterfulvi
Thanks
dan lightner
@danimaniac
I am currently sourcing my openAPS compatible pump (should be arriving this weekend), Edison, Explorer board, and battery. The production and dev documentation provides instruction for setting up the rig using a Pi, Windows, and Mac. Where would I find setup instructions for using my debian based linux laptop? I like to think I can follow directions pretty well, but...
Scott Leibrand
@scottleibrand
that should be pretty similar to the Pi, but no guarantees: no one has actually tried that yet AFAIK
you might have enough RAM to skip the swap space stuff
hilarykoch
@hilarykoch
I’m trying to setup Bluetooth. Following the directions here. Is the first step this (with the MAC address from my phone)?? cd && ~/src/oref0/bin/oref0-setup.sh --btmac=AA:BB:CC:DD:EE:FF
katie disimone
@Kdisimone
yes, mac address of phone
hilarykoch
@hilarykoch
If so, it looks like it is trying to take me through the interactive setup again...
Scott Leibrand
@scottleibrand
it's best if you add that --btmac=AA:BB:CC:DD:EE:FF to the end of your existing command from the runagain
katie disimone
@Kdisimone
yes but it will ask you an additonal question about the MAC address this time
Scott Leibrand
@scottleibrand
(or from your bash history) to avoid interactive