Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Jan 31 2019 15:51
    xen0n starred openaps/oref0
  • Jan 31 2019 15:12
    cclauss opened #1191
  • Jan 31 2019 15:09
    cclauss edited #1190
  • Jan 31 2019 15:08
    cclauss edited #1189
  • Jan 31 2019 15:07
    cclauss edited #1190
  • Jan 31 2019 15:07
    cclauss opened #1190
  • Jan 31 2019 15:00
    cclauss synchronize #1189
  • Jan 31 2019 14:52
    cclauss opened #1189
  • Jan 31 2019 14:10
  • Jan 31 2019 14:06
    Owaisaaa starred openaps/docs
  • Jan 31 2019 12:20
    cclauss synchronize #22
  • Jan 31 2019 12:16
    cclauss opened #22
  • Jan 31 2019 12:11
    cclauss edited #21
  • Jan 31 2019 12:09
    cclauss opened #21
  • Jan 31 2019 11:31
    tuzoenduro commented #1406
  • Jan 31 2019 11:25
    cclauss opened #140
  • Jan 30 2019 05:53
  • Jan 29 2019 16:03
    tzachi-dar commented #1406
  • Jan 29 2019 14:46
    rostag starred openaps/oref0
  • Jan 27 2019 22:06
    PieterGit synchronize #1176
Eric
@ecc1
not sure the setup script is doing the right thing. it should clone and then build, not do a "go get" if there's no local source yet
Eric
@ecc1
sorry, my mistake. setup is pulling the master branch of the medtronic repo, which had lagged behind dev. I've updated them both now
Dave Acklam
@dcacklam
@ecc1
That fixes it.
tzachi-dar
@tzachi-dar
Should rpi 4 works as a rig just like rpi 3?
tynbendad
@tynbendad
about the radio hack that attempts to guess your pump's serial number - has anyone tried to detect a hack in progress (e.g., from an explorer or explorer hat rig)?
is it feasible?
Eric
@ecc1
@tynbendad not sure what hack you mean, but it's trivial to snoop on pump comms in progress and extract the serial number, since it's not encrypted in any way. Impossible to detect, since it's receive-only
tynbendad
@tynbendad
Oh, ok that's worse than i thought. Thought they had to try every serial number, but maybe that's just for pumps that aren't using comms.
jaybaron1
@jaybaron1
Thanks for sharing.
Dave Acklam
@dcacklam
@tzachi-dar rpi4 works as a rig but the battery circuitry on the explorer hat is too weak to power it.
@tzachi-dar So only really good for a desktop rig.
Use a pi3A+ or pizero for portable
tzachi-dar
@tzachi-dar
Thanks @dcacklam is using pi3A+ with a battery a reasonable thing to do? Seems like it's power usage is relatively high.
Dave Acklam
@dcacklam
@tzachi-dar just use a 6000mah battery
Caleb Seekell
@jauntySerpent
My backup rig isn't working at the moment so I'm unable to test a completely fresh install, but there appears to be issues with the current master branch of oref0 (0.7.0) and token-based NS authentication. I'm finally getting around to updating my rig with token auth instead of api_secret, but I've been troubleshooting an issue for the past several weeks where the rig does not include the token in several GET requests, resulting in an permissions error and prevents the rig from downloading BG data.
Jul 21 07:00:07 ********* heroku/router at=info method=GET path="/api/v1/entries/sgv.json?count=288" host=*********.herokuapp.com request_id=a57e9b7b-cd93-4c10-8903-f73eb9f70d52 fwd="*********" dyno=web.1 connect=0ms service=5ms status=401 bytes=560 protocol=https
Jul 21 07:00:07 ********* app/web.1 Resolving secret/token to permissions failed
Jul 21 07:00:12 ********* heroku/router at=info method=GET path="/api/v1/entries/sgv.json?count=12" host=*********.herokuapp.com request_id=ee5eef71-627b-4f36-81fd-2eefeb116d9b fwd="*********" dyno=web.1 connect=0ms service=473ms status=401 bytes=560 protocol=https
Jul 21 07:00:12 ********* app/web.1 Resolving secret/token to permissions failed
The current version of dev does not have this problem, and I finally found this commit which seems to describe the issue perfectly openaps/oref0@89a90b8 . Can anyone else confirm whether they are seeing this issue?
Dana Lewis
@danamlewis

I am not sure if that’s the only thing broken in master but you’re not the only one who needed to switch to dev recently and found it resolved the/an issue.

If we can get some volunteers to test some fresh installs and report back (here or in the open PR of dev to master), we could do a release (dev to master) and get master back to a working state.

old-square-eyes
@old-square-eyes
How do I disable Autotune, but leave it to run each night on my rig?
I just want to manually observe recommendations
I keep dropping low and it keeps recommending more insulin. I can't figure out why.
I'm entering carbs.
Constantly getting negative IOB
image.png
old-square-eyes
@old-square-eyes
image.png
Do I just change "enable": " autotune ", to "enable": "",?
In prefs
Caleb Seekell
@jauntySerpent
@danamlewis I am happy to test as soon as I get my backup rig running.
old-square-eyes
@old-square-eyes
Or do I delete the whole line
refields
@refields
For a few days now there has been no activity on my nightscout
image.png
image.png
I didnt change anything in nightscout settings, Dexcom Share is on with connectivity, and Heroku plug size is
58.2 MiB of 500 MiB. Anyone know what else I can try or check?
Eric
@ecc1
@refields have you checked if your mongodb is full?
is your openaps successfully uploading to NS? what do the logs say?
refields
@refields
@ecc1 it looks like my mongodb is full
image.png
how do I clear it to zero?
refields
@refields
openaps is creating new logs in paper trail but not looping
Most recent logs:
image.png
refields
@refields
@ecc1 I dont think those instructions apply anymore since the mLab migration to Atlas which happened in November 2020. Are there instructions for doing this in the Atlas UI?
Eric
@ecc1
@refields I found this using Google; you can too. I don't use a hosted mongo service, so YMMV: https://nightscout.github.io/troubleshoot/troublehoot/#database-full
refields
@refields
@ecc1 this worked. thank you again. I promise I did try Google initially, and unsuccessfully. I think I even had to do this once before. The problem is life goes on fine for 6-12 months with the CGM-rig working properly and then something goes awry and I forget all the steps. Really appreciate it.
Eric
@ecc1
@refields glad it worked. I have a repeating 6 month reminder on my calendar to do this, btw
tzachi-dar
@tzachi-dar
@ecc1 @refields openaps/oref0#1232 has a script that deletes old NS entries every night. Actually it does not delete them but rather copy them locally. Fill free to use it.
Foxy7
@Foxy7
@kellyisworking thanks for the link.
refields
@refields
@ecc1 thats a great idea will do the same. Thank you @tzachi-dar
Milan
@milanlakhani
Hi all :) we are trying to collect tracing data on an OpenAPS Raspberry Pi rig for our voluntary safety project, we were wondering if anyone here would have time to send us some trace logs of their rig while their loop is running if we send them instructions on how to do this? Also if anyone would like to look at our safety analysis so far? :)