These are chat archives for nightscout/ios

26th
Jul 2015
jwedding
@jwedding
Jul 26 2015 16:57
Tried adding in a second site to Nightscouter using https://public-423e36-guest.nightscout.net/ and it's crashing again.
kenstack
@kenstack
Jul 26 2015 17:41
The latest version of the repo for nightscouter now displays the bg too but nothing else - no graph etc like the old one. I'm going to work on nsapple more this week I realize now that ions let have some of the same issues with optionals from the pebble endpoint that nightscouter did - is there any docs on what pebble endpoint output looks like based on config settings ?
Jason Calabrese
@jasoncalabrese
Jul 26 2015 17:54
there are some tests for the pebble endpoint that might help, but it hasn't been well defined
lots of history with the pebble stuff
Pete
@someoneAnyone
Jul 26 2015 17:55
I'm working through some the issue now
Jason Calabrese
@jasoncalabrese
Jul 26 2015 17:56
the main settings that effect the output are display units, iob, and raw
Pete
@someoneAnyone
Jul 26 2015 18:00
why is pebble endpoint showing a number for direction instead of a string like before?
I've seen endpoints with direction":"Flat" and the sample one above is showing direction": 9
sorry its showing direction":"9"
Jason Calabrese
@jasoncalabrese
Jul 26 2015 18:02
direction should be a string, with things like Flat, trend should be a number
maybe thats something with xdrip?
Pete
@someoneAnyone
Jul 26 2015 18:03
I tend to see "Flat" but the sample site listed above https://public-423e36-guest.nightscout.net/pebble is not. That's why my code isn't displaying a bg
Jason Calabrese
@jasoncalabrese
Jul 26 2015 18:04
was just looking at that one and see the same, don't know where that is coming from
Pete
@someoneAnyone
Jul 26 2015 18:04
I bail when the object doesn't look correct
Jason Calabrese
@jasoncalabrese
Jul 26 2015 18:04
asking in the xdrip room
kenstack
@kenstack
Jul 26 2015 18:13
here is something strange - Ive been using the same uploader for probably a year now (one version old) - as of 2 days ago its uploading duplicates - I have changed nothing except moving from an adult receiver to a pediatric (kid broke the usb on the one adult one...) - one had a local time stamp, the other GMT - same data. Was doing this for about 24 hours now stopped. Kid is at camp so I cant debug on the phone... when the dup would come in bgdelta was always zero
Pete
@someoneAnyone
Jul 26 2015 18:13
odd reloaded the pebble end point and now a string appears.
kenstack
@kenstack
Jul 26 2015 18:13
@someoneAnyone this may be adding to the issues btw - I just noticed this when my code got funky on graphing
Jason Calabrese
@jasoncalabrese
Jul 26 2015 18:17
wonder if it's just 9 missing somewhere