Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Tanguy PELADO
    @tpelado
    yes, that is correct
    but I suspect there might be some old files still there
    the thing is : i've done this on multiple nodes, and only some of them are behaving like this
    image.png
    update was at 1700
    you can see it running twice and never running again
    Nicolas Charles
    @ncharles
    what does rudder agent info say ?
    Tanguy PELADO
    @tpelado
     root@NPERF:~# rudder agent info
    Hostname: NPERF
    UUID: 3
    Key hash: MD5=2
    Certificate creation: Dec  7 17:06:26 2021 GMT
    Certificate expiration: Dec  5 17:06:26 2031 GMT
    Certificate fingerprint: 54
    Policy server: rudder-v2
    Roles: rudder-agent
    Report mode: full-compliance
    Run interval: 5 min
    Agent is enabled
    Agent is not forced in audit mode
    Configuration id: 20211207-170708-
    Policy updated: 2021-12-07 18:07:33
    Inventory sent: 2021-12-07 18:06:35
    Version: Rudder agent 6.2.11-debian11
    root@NPERF:~#
    i've removed some of the values, reckon they shouldn't be needed for troubleshooting
    Nicolas Charles
    @ncharles
    this is interesting - it ought to be running
    can you check if cf-execd is running ?
    Tanguy PELADO
    @tpelado
    root@NPERF:~# ps aux | grep cf-exec[d]
    root@NPERF:~#
    there's no process running with that name
    Nicolas Charles
    @ncharles
    that's the cause of the issue
    Tanguy PELADO
    @tpelado
    I've tried the same on a "good" node and the process is running as expected.
    now, why isn't it running
    Nicolas Charles
    @ncharles
    you can check with journalctl -u rudder-cf-execd
    Tanguy PELADO
    @tpelado
    image.png
    welp. Died and never really started again.
    I've restarted the service manually
    it now runs fine
    will check if the agent sends an inventory
    is it normal that the service isn't enabled systemd wise?
    Nicolas Charles
    @ncharles
    it should be enabled
    Tanguy PELADO
    @tpelado
    I enabled it manually
    as to why it wasn't, can't say I know the cause
    the irony is that I can't make a rudder directive to enable it because it won't run automatically on the affected nodes lol
    Anyhow, that's now fixed. Merci pour ton aide !
    saying that, the node didn't send anything yet...
    Nicolas Charles
    @ncharles
    if it doesn't start in 5 minutes, we'll investigate
    Tanguy PELADO
    @tpelado
    "2021-12-08 13:48:18+00:00 ( 94s) Enforce: 65 compliant, 0 repaired, 18 N/A, 0 errors Audit: 0 compliant, 0 non-compliant, 0 N/A, 0 errors" heyyyyyyyy
    just needed time (and apparently the cronjob isn't on *5)
    Again, thanks for your help!
    Nicolas Charles
    @ncharles
    it every 5 minutes with a splay of 4 minutes
    you did have to to a systemctl enable rudder-cf-execd ?
    Tanguy PELADO
    @tpelado
    exactly
    image.png
    as you can see here, the service isn't enabled
    this is another node that's suffering from the same issue
    Nicolas Charles
    @ncharles
    is it also disabled ?
    Tanguy PELADO
    @tpelado
    yes, as you can see in my screenshot
    some, thyere's something happening that doesn't enable the service
    and after that, even if rudder runs correctly, it doesn't check if the service is enabled
    Nicolas Charles
    @ncharles
    could you check the upgrade logs in /var/log/rudder/install ?
    it should state something
    standart content is ```Thu Dec 2 10:07:32 CET 2021 - Starting rudder-agent post installation script
    rudder-cf-serverd: enabled
    rudder-cf-execd: enabled
    ok: stop service rudder-agent succeeded
    INFO: Scheduling an inventory during next run...
    INFO: No disable file detected and no agent executor process either. Restarting agent service... Done
    FINISH: Rudder agent check ran properly, please look at messages above to see if there has been any error.
    Thu Dec 2 10:07:34 CET 2021 - Ending rudder-agent post installation script
    do you happen to have a /etc/default/rudder-agent file ?
    Tanguy PELADO
    @tpelado
    root@IPERF:/var/log/rudder/install# cat rudder-agent-20211130180821.log 
    mar. 30 nov. 2021 18:08:21 CET - Starting rudder-agent post installation script
    ok: stop service rudder-agent succeeded
    INFO: The UUID of the node does not exist and no backup exist. A new one will be generated... Done
    INFO: Agent certificate is missing, creating it... Done
    INFO: No disable file detected and no agent executor process either. Restarting agent service... Done
    INFO: Inventory older than 3 days, resending ...Rudder agent 6.2.11-debian11
    Node uuid: 8658e2fa-5bb4-419d-bb92-81dffcfb40dc
       error: Anomalous ending '
       error: Anomalous ending '
       error: Anomalous ending '
       error: Anomalous ending '
       error: Anomalous ending '
       error: Anomalous ending '
       error: Anomalous ending '
    Start execution with config [20211122-174737-4e6dd716]
    do note that this is after a factory reset
    Nicolas Charles
    @ncharles
    you did a factory-reset before the upgrade ?