Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Matthew Frost
    @mattronix
    can you point me in the direction of docs for condtions
    is it cfengine conditions or something rudder?
    Vincent Membré
    @VinceMacBuche
    yes cfengine one
    Matthew Frost
    @mattronix
    coool
    do you have any docs for how to use the advanced conditions?
    have not found anything :(
    the abstraction does not click in my head yet hahaha
    Zora66
    @Zora66
    Is there a proper way to check if linux host needs to restart without getting the message “was repaired” every single time in logs after command execution like: (Execute the command if [ -f /var/run/reboot-required ]; then exit 1; else exit 0; fi was repaired) ?
    peckpeck
    @peckpeck
    use "condition from command" instead of "command execution"
    if you still want a report, use "command execution result"
    Vincent Membré
    @VinceMacBuche
    in 7.0 you can disable reporting of methods
    Zora66
    @Zora66
    image.png
    Thx, it works for me :)
    Alexis Mousset
    @amousset:matrix.org
    [m]
    ℹ️ We are currently experiencing problems on some of our servers (due to a network outage) and some services are unavailable. Things should be back online soon, we'll keep you informed.
    Alexis Mousset
    @amousset:matrix.org
    [m]
    The problem is now solved ✅ Please report any issue you may encounter on our services.
    Benjamin Belot
    @benbelo

    Hi,

    I'm facing an issue with the compliance reports of a host.
    I can register the host on the pending list, but then it appears with an error.
    when i try a rudder agent update, it gives me an error :
    rudder-agent could not get an updated configuration from the policy server.

    • This can be caused by:
      • an agent key that has been changed
      • if this node is not accepted or deleted node on the Rudder root server
      • if this node has changed policy server without sending a new inventory
        error: Rudder agent policies could not be updated

    Any ideas ?

    6 replies
    Rudder agent 6.2.13-debian10 / Server Rudder 6.2.9
    Thank you...
    ishackigozi
    @ishackigozi
    Hello Guy, can rudder check if a service has failed?
    3 replies
    Anil Choudhury
    @anil.choudhury2008_gitlab
    Hi All..
    I m very new to rudder..and like to download plugins and install
    11 replies
    please help
    Elenui
    @Elenui
    Hello, how many node can handle rudder before using satellite ?
    plz
    Nicolas Charles
    @ncharles
    You mean relay ?
    at least 1000
    Elenui
    @Elenui
    yes relay sorry
    Ok should be ok :p
    Thanks Nicolas
    Elenui
    @Elenui
    is it possible for rudder to interact with an interactive script ?
    I would like to give rudder the solarwind's installation but they don't think their script to be used by automate
    15 replies
    Elenui
    @Elenui
    Is it possible to send a if command inside command tasks ?
    Elenui
    @Elenui
    want to do this :
    if [[ $(cat /var/rudder/local/properties.d/role.json | grep use$sgbd | cut -d : -f2 | cut -d , -f1) == true ]]; then
        echo $sgbd;
    else
        exit 1
    fi
    Nicolas Charles
    @ncharles
    Hi Elenui ! I think this is exactly this issue https://issues.rudder.io/issues/20128 that has been released in 6.2.13 and 7.0.2
    Elenui
    @Elenui
    oooooffff
    Sexy`
    I'll give it a try thanks again Nicolas ;)
    Nicolas Charles
    @ncharles
    :thumbsup:
    lkoenen
    @lkoenen
    Hey, I'm trying to install a .deb file with the help of Rudder if the currently installed version on the node is older than X. The problem now is that some nodes already have a newer version than the one I'm trying to install. But the generic methods all require an exact version number to check for and you can't specify ranges. I looked in the documentation if there is a way to check if the installed version of a package is <= X and found for example "package_install_version_cmp" (https://docs.rudder.io/reference/6.2/reference/generic_methods.html#_package_install_version_cmp). but this generic method is marked as deprecated and one is supposed to use "package_present". But there is no such functionality specified for "package_present".
    Elenui
    @Elenui
    Hey Guys, I have a strange behaviour with my rudder server.
    We monitor the compliance's status and everyday I have an alert saying I only have 99% compliance. When I check my node some have rule in error BUT when I launch the agent's run everything goes green again. I think it's related to my report. Is anything I can do to not have those false alarm ? cheer team :)
    45 replies
    Jonas_402
    @JONAS402
    hi guys, wonder if you can help. we originally had a rudder server which worked fine, we then decided to backup and migrate to another server in a different location and ever since we get "Starting Jetty: . . . . . . . . . . . . . . . FAILED Thu Apr 28 10:43:30 BST 2022" almost constantly. occasionly the service will start and report OK but most of the time fails. any ideas?
    146 replies
    i used your official guide, with the latest version (at the time v7)
    Nicolas Charles
    @ncharles
    image.png
    1 reply
    Elenui
    @Elenui
    image.png
    Jonas_402
    @JONAS402
    image.png
    Jonas_402
    @JONAS402
    image.png
    Jonas_402
    @JONAS402
    image.png
    Elenui
    @Elenui
    Hello, is there a way to register only my nodes with only their hostname and not hostname.fqdn ?
    Elenui
    @Elenui
    Hi guys, is anyone get this error yet ?
    /opt/rudder/bin/run-inventory --local=/var/rudder/tmp/inventory/prod-c2d09dd7-a6d8-4eec-8812-297506ff2a92.ocs
    [info] FusionInventory instance: builtin
    Encode.c: loadable library and perl binaries are mismatched (got handshake key 0xce00080, needed 0xed00080)