Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Benjamin Belot
    @benbelo
    Rudder agent 6.2.13-debian10 / Server Rudder 6.2.9
    Thank you...
    ishackigozi
    @ishackigozi
    Hello Guy, can rudder check if a service has failed?
    3 replies
    Anil Choudhury
    @anil.choudhury2008_gitlab
    Hi All..
    I m very new to rudder..and like to download plugins and install
    11 replies
    please help
    Elenui
    @Elenui
    Hello, how many node can handle rudder before using satellite ?
    plz
    Nicolas Charles
    @ncharles
    You mean relay ?
    at least 1000
    Elenui
    @Elenui
    yes relay sorry
    Ok should be ok :p
    Thanks Nicolas
    Elenui
    @Elenui
    is it possible for rudder to interact with an interactive script ?
    I would like to give rudder the solarwind's installation but they don't think their script to be used by automate
    15 replies
    Elenui
    @Elenui
    Is it possible to send a if command inside command tasks ?
    Elenui
    @Elenui
    want to do this :
    if [[ $(cat /var/rudder/local/properties.d/role.json | grep use$sgbd | cut -d : -f2 | cut -d , -f1) == true ]]; then
        echo $sgbd;
    else
        exit 1
    fi
    Nicolas Charles
    @ncharles
    Hi Elenui ! I think this is exactly this issue https://issues.rudder.io/issues/20128 that has been released in 6.2.13 and 7.0.2
    Elenui
    @Elenui
    oooooffff
    Sexy`
    I'll give it a try thanks again Nicolas ;)
    Nicolas Charles
    @ncharles
    :thumbsup:
    lkoenen
    @lkoenen
    Hey, I'm trying to install a .deb file with the help of Rudder if the currently installed version on the node is older than X. The problem now is that some nodes already have a newer version than the one I'm trying to install. But the generic methods all require an exact version number to check for and you can't specify ranges. I looked in the documentation if there is a way to check if the installed version of a package is <= X and found for example "package_install_version_cmp" (https://docs.rudder.io/reference/6.2/reference/generic_methods.html#_package_install_version_cmp). but this generic method is marked as deprecated and one is supposed to use "package_present". But there is no such functionality specified for "package_present".
    Elenui
    @Elenui
    Hey Guys, I have a strange behaviour with my rudder server.
    We monitor the compliance's status and everyday I have an alert saying I only have 99% compliance. When I check my node some have rule in error BUT when I launch the agent's run everything goes green again. I think it's related to my report. Is anything I can do to not have those false alarm ? cheer team :)
    45 replies
    Jonas_402
    @JONAS402
    hi guys, wonder if you can help. we originally had a rudder server which worked fine, we then decided to backup and migrate to another server in a different location and ever since we get "Starting Jetty: . . . . . . . . . . . . . . . FAILED Thu Apr 28 10:43:30 BST 2022" almost constantly. occasionly the service will start and report OK but most of the time fails. any ideas?
    146 replies
    i used your official guide, with the latest version (at the time v7)
    Nicolas Charles
    @ncharles
    image.png
    1 reply
    Elenui
    @Elenui
    image.png
    Jonas_402
    @JONAS402
    image.png
    Jonas_402
    @JONAS402
    image.png
    Jonas_402
    @JONAS402
    image.png
    Elenui
    @Elenui
    Hello, is there a way to register only my nodes with only their hostname and not hostname.fqdn ?
    Elenui
    @Elenui
    Hi guys, is anyone get this error yet ?
    /opt/rudder/bin/run-inventory --local=/var/rudder/tmp/inventory/prod-c2d09dd7-a6d8-4eec-8812-297506ff2a92.ocs
    [info] FusionInventory instance: builtin
    Encode.c: loadable library and perl binaries are mismatched (got handshake key 0xce00080, needed 0xed00080)
    I thought at first my perl wasn't up to date
    but it's seem ok
    Try to force install encode with cpan but so far no luck :'(
    Nicolas Charles
    @ncharles
    you installed the wrong rudder-agent for your distro
    like debian10 agent on a debian11
    Elenui
    @Elenui
    OH
    Someone fuck my repo up so
    Thanks Nicolas
    Elenui
    @Elenui
    It was what u said... Someone put deb11 repo on deb10 perl is mixup :'(
    Elenui
    @Elenui
    the SSO documentation is missing :'(
    18 replies
    I know not available yet but I was hype for the 7.1
    Suvi
    @Suvi8

    Hi

    I wanted to upgrade from 6.2 to 7.0. I added the rudder.repo and run this command:

    yum update rudder-server-root

    However it says me no packages marked for update., what to do?

    11 replies
    Alexis Mousset
    @amousset:matrix.org
    [m]
    Which operating system si it on? What does your repo URL look like?
    Hi
    Suvi
    @Suvi8
    Amazon Linux 2
    [Rudder_6.2]
    name=Rudder 6.2
    username=xxxxxx
    password=xxxxxxx
    baseurl=http://download.rudder.io/rpm/6.2/RHEL_7/
    gpgcheck=1
    gpgkey=https://download.rudder.io/rpm/rudder_rpm_key.pub