Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Elenui
    @Elenui
    Someone fuck my repo up so
    Thanks Nicolas
    Elenui
    @Elenui
    It was what u said... Someone put deb11 repo on deb10 perl is mixup :'(
    Elenui
    @Elenui
    the SSO documentation is missing :'(
    18 replies
    I know not available yet but I was hype for the 7.1
    Suvi
    @Suvi8

    Hi

    I wanted to upgrade from 6.2 to 7.0. I added the rudder.repo and run this command:

    yum update rudder-server-root

    However it says me no packages marked for update., what to do?

    11 replies
    Alexis Mousset
    @amousset:matrix.org
    [m]
    Which operating system si it on? What does your repo URL look like?
    Hi
    Suvi
    @Suvi8
    Amazon Linux 2
    [Rudder_6.2]
    name=Rudder 6.2
    username=xxxxxx
    password=xxxxxxx
    baseurl=http://download.rudder.io/rpm/6.2/RHEL_7/
    gpgcheck=1
    gpgkey=https://download.rudder.io/rpm/rudder_rpm_key.pub
    i changed to 7.0
    in name and baseurl
    ishackigozi
    @ishackigozi
    Hello All, I am trying to utilize the CVE Plugin in Rudder. When I click on Start CVE check, I get a 500 error response. Any ideas why this is happening
    1 reply
    lpwevers
    @lpwevers

    Hi,

    I've updated my Rudder server from 6.2 to 7.1. I've done this by updating the repository and then ran:
    zypper up rudder-server-root rudder-server-relay rudder-reports rudder-webapp rudder-agent

    Upgrade went fine, no errors reported etc. There is however now one issue. The compliance of the nodes dropped from 100% to 0%. When checking on the individual nodes they all report this error: "No recent reports have been received for this node in the grace period since the last configuration policy change."

    So as a test on some of the nodes I changed some resources managed by Rudder and ran the agent. And that ran without any problem at all. Everything was corrected by Rudder as expected.

    As I figured that maybe this was due to the 6.2 version of the agent still runnnig on the nodes, I upgraded that on some of them as well to 7.1. Still no luck.

    Then I thought that maybe it needed some time to update the reports again. But it has been over 4 hours by now and I'm still at 0% compliance.

    I'm running this on SLES15 SP3. I took a snapshot of the VM running the Rudder server before the upgrade, so I could revert back to that. (If I haven't solved it by Monday I guess it will come to that), but I prefer not to do this. So if someone could help me fix this, that would be greatly appreciated.

    30 replies
    Elenui
    @Elenui
    hello, I've a strange behaviour with my template, I create a Technic to deploy custom php.ini.
    I create a template : /var/rudder/configuration-repository/shared-files/common/configuration-template/PHP/conf/php.ini.tpl
    The file exist and if I cat it I've everything I put inside. But when I deploy the template throught "file from remote template" my agent repaired it but the file is empty...
    rudder agent -u -g -i output :
    
    2022-05-16T15:26:33+00:00 rudder     info: Created file '/var/rudder/cfengine-community/tmp/templates/file_from_remote_template//etc/php/8.0/fpm/php.ini.datastate.78436.json', mode 0600
    2022-05-16T15:26:33+00:00 rudder     info: Updated rendering of '/var/rudder/cfengine-community/tmp/templates/file_from_remote_template//etc/php/8.0/fpm/php.ini.datastate.78436.json' from mustache template '/var/rudder/cfengine-community/modules/templates/datastate.json.tpl'
    2022-05-16T15:26:34+00:00 rudder     info: Copied file '/var/rudder/cfengine-community/tmp/templates/file_from_remote_template//etc/php/8.0/fpm/php.ini.78436.new' to '/etc/php/8.0/fpm/php.ini.cfnew' (permissions preserved)
    2022-05-16T15:26:34+00:00 rudder     info: Moved '/etc/php/8.0/fpm/php.ini.cfnew' to '/etc/php/8.0/fpm/php.ini'
    2022-05-16T15:26:34+00:00 rudder     info: Updated file '/etc/php/8.0/fpm/php.ini' from 'localhost:/var/rudder/cfengine-community/tmp/templates/file_from_remote_template//etc/php/8.0/fpm/php.ini.78436.new'
       info          optimisation___php_fpm    Deploy php.ini Conf       /etc/php/8.0/fpm/| Copying /etc/php/8.0/fpm/php.ini from /var/rudder/cfengine-community/tmp/templates/file_from_remote_template//etc/php/8.0/fpm/php.ini.78436.new was repaired
       info          optimisation___php_fpm    Deploy php.ini Conf       /etc/php/8.0/fpm/| Copying /etc/php/8.0/fpm/php.ini from local /var/rudder/cfengine-community/tmp/templates/file_from_remote_template//etc/php/8.0/fpm/php.ini.78436.new, recursion level 0 was repaired
       info          optimisation___php_fpm    Deploy php.ini Conf       /etc/php/8.0/fpm/| Copying /etc/php/8.0/fpm/php.ini from local /var/rudder/cfengine-community/tmp/templates/file_from_remote_template//etc/php/8.0/fpm/php.ini.78436.new was repaired
    2022-05-16T15:26:34+00:00 rudder     info: Deleted file '/var/rudder/cfengine-community/tmp/templates/file_from_remote_template//etc/php/8.0/fpm/php.ini.datastate.78436.json'
       info          optimisation___php_fpm    Deploy php.ini Conf       /etc/php/8.0/fpm/| Remove file /var/rudder/cfengine-community/tmp/templates/file_from_remote_template//etc/php/8.0/fpm/php.ini.datastate.78436.json was repaired
    2022-05-16T15:26:34+00:00 rudder     info: Deleted file '/var/rudder/cfengine-community/tmp/templates/file_from_remote_template//etc/php/8.0/fpm/php.ini.78436.new'
       info          optimisation___php_fpm    Deploy php.ini Conf       /etc/php/8.0/fpm/| Remove file /var/rudder/cfengine-community/tmp/templates/file_from_remote_template//etc/php/8.0/fpm/php.ini.78436.new was repaired
       info          optimisation___php_fpm    Deploy php.ini Conf       /etc/php/8.0/fpm/| Build file /etc/php/8.0/fpm/php.ini from jinja2 template /var/rudder/cfengine-community/tmp/templates/file_from_remote_template//etc/php/8.0/fpm/php.ini was repaired
       info          optimisation___php_fpm    Deploy php.ini Conf       /etc/php/8.0/fpm/| Build file /etc/php/8.0/fpm/php.ini from jinja2 template /var/rudder/cfengine-community/tmp/templates/file_from_remote_template//etc/php/8.0/fpm/php.ini was repaired
    E| repaired      optimisation___php_fpm    Deploy php.ini Conf       /etc/php/8.0/fpm/| Build file /etc/php/8.0/fpm/php.ini from template /var/rudder/configuration-repository/shared-files/common/configuration-template/PHP/conf/php.ini.tpl was repaired
    Elenui
    @Elenui
    OK I find the problem I have this JSON as group properties :
    {
        "disable_functions": "XXX,syslog,openlog,closelog,posix_kill,posix_getpwuid,dl,exec,system,shell_exec,proc_open,popen,passthru",
        "exectime": "30",
        "maxinputtime": "30",
        "maxinputvars": "30",
        "memorylimit": "256M",
        "timezone": "Europe/Paris",
        "uploadmaxfilesize": "100M"
    }
    Exectime doesn't work
    I tried to update my jinja2 template and use other variable and no problem
    I tried to change the variable name to exectime (before was maxexectim)
    And I still can't using it or my php.ini end up empty :'(
    Vincent Membré
    @VinceMacBuche
    Is there a file /var/rudder/cfengine-community/tmp/templates/file_from_remote_template//etc/php/8.0/fpm/php.ini.78436.new on the node ?
    Elenui
    @Elenui
    I tried to reproduce
    now it works...
    I spend yersterday on this problem
    and I didn't touch anything and now it works
    ctr0603
    @ctr0603
    https not working for rudder 7.0 and 7.1 versions could any one help i am using comunity edition
    7 replies
    Jonas_402
    @JONAS402
    hi guys just a very quick question, is there any timeframe for agents on ubuntu 22.04? we have tried installing but we would keep getting an error regarding the version on libssl so came to the conclusion it is not supported at the moment
    8 replies
    fanf42
    @fanf42:matrix.org
    [m]
    ℹ️ Hey people, it seems that in fresh install since 7.0, we ship a default config file for webapp logs that has too verbose level for one item: that leads to verbose debug logs in files /var/log/rudder/webapp/YYYY_MM_dd.stderrout.log .
    This is not grave, but it can result in bloated logs (and so, useless space consumption).
    You can correct that by changing the line: <logger name="explain_compliance" level="debug" additivity="false"> to <logger name="explain_compliance" level="info" additivity="false"> (ie change level from debug to info) in file /opt/rudder/etc/logback.xml
    ctr0603
    @ctr0603
    How to check the docker binary is installed using rudder
    3 replies
    should i need to use file present
    ishackigozi
    @ishackigozi
    Hello, Our Rudder server database is backing up on a constant basis and this is utilizing a lot of storage. How can I limit this to once a week
    Nicolas Charles
    @ncharles
    We are not doing any database backup - what do you mean ?
    ishackigozi
    @ishackigozi
    Everyday, the database takes a backup of 3GB
    The space utilization is very highj
    Nicolas Charles
    @ncharles
    It was archiving old reports, but this is disabled in "recent" rudder
    which version of Rudder are you using ?
    in the menu, in Reports Database you have info about what is configured
    image.png
    you should have something like that
    ishackigozi
    @ishackigozi
    Hello Nicolas, it is Version 7.1
    image.png
    Nicolas Charles
    @ncharles
    it shows only 2.22GB
    so you have something else backuping the database
    ishackigozi
    @ishackigozi
    Hello Nicolas, I was able to figure this one out. I have to change a few lines in the postgress.conf
    I am seeing a new issue on a node Ubuntu 22.04 agent 7.1.
    When I run, rudder agent run, I get these errors
    var/rudder/cfengine-community/modules/packages/apt_get:18: DeprecationWarning: The distutils package is deprecated and slated for removal in Python 3.12. Use setuptools or check PEP 632 for potential alternatives
    from distutils.version import LooseVersion
    /var/rudder/cfengine-community/modules/packages/apt_get:18: DeprecationWarning: The distutils package is deprecated and slated for removal in Python 3.12. Use setuptools or check PEP 632 for potential alternatives
    from distutils.version import LooseVersion
    /var/rudder/cfengine-community/modules/packages/apt_get:18: DeprecationWarning: The distutils package is deprecated and slated for removal in Python 3.12. Use setuptools or check PEP 632 for potential alternatives
    from distutils.version import LooseVersion
    /var/rudder/cfengine-community/modules/packages/apt_get:18: DeprecationWarning: The distutils package is deprecated and slated for removal in Python 3.12. Use setuptools or check PEP 632 for potential alternatives
    from distutils.version import LooseVersion
    Start execution with config [20220601-111029-210a93da]