These are chat archives for ntaoo/material2_dart

20th
Jan 2017
Max Riegler
@rinukkusu
Jan 20 2017 22:12
@ntaoo can I try and sync with alpha.11 on top of your alpha.10 branch?
ntaoo
@ntaoo
Jan 20 2017 22:17
Wow, it will be really appriciated.
Max Riegler
@rinukkusu
Jan 20 2017 22:18
I will try my best!!
ntaoo
@ntaoo
Jan 20 2017 22:19
During your try, I would tackle the new components which hasn’t ported yet.
Max Riegler
@rinukkusu
Jan 20 2017 22:33
What are you using for your sass transformations? The ruby gem?
ntaoo
@ntaoo
Jan 20 2017 22:37
I’m using my https://github.com/ntaoo/sass_builder, but it has some bugs on exception handling. I will evaluate https://github.com/daniel-v/dart_sass_builder.
Max Riegler
@rinukkusu
Jan 20 2017 22:38
Yea, I saw - could successfully build the sass files :smile:
ntaoo
@ntaoo
Jan 20 2017 22:41
FYI, for Sass executable, I usually use sassc. I have not tried dart-sass. :smile:
This does not yet work in the Dart version of Angular 2 right?
animations with @
ntaoo
@ntaoo
Jan 20 2017 23:33
Yes. AngularDart doesn’t support animations that TS version support.
We should find another way. Plain (s)css is the quick way, I think.
Max Riegler
@rinukkusu
Jan 20 2017 23:35
Alright, will think about it! :sparkles:
ntaoo
@ntaoo
Jan 20 2017 23:38
Also, I have postponed touch gesture support with Hammer.js which the TS version depends.
Max Riegler
@rinukkusu
Jan 20 2017 23:38
Ah, with (touchstart) and the like right?
ntaoo
@ntaoo
Jan 20 2017 23:40
I don’t remember ’touchestart’ is the issue, but hammer.js enables some complex gesture, and maybe patches some browser dependent bugs.
Max Riegler
@rinukkusu
Jan 20 2017 23:41
Ah okay!
ntaoo
@ntaoo
Jan 20 2017 23:43
material2 depends on hammerjs on some components. AngularTS itself includes the adapter. I don’t know AngularDart also supports (the code itself compiled from the TS ver exists, though).