Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Ali Diouri
    @theshadowx
    hi @konstantingoretzki , I think the package was created and modifications were done on the source code just after that having the same version. Our Mistake :( . @nuttyartist could you please contact @gkbrk to regenerate the ArchLinux package for the version 1.0.0
    Ruby Mamistvalove
    @nuttyartist
    Sure. What's the problem @theshadowx?
    I asked him to do so.
    Ali Diouri
    @theshadowx

    the issue is that when the new release 1.0.0 was added to the release section in github, @gkbrk create a package for ArchLinux for 1.0.0 and uploaded it to the repository https://aur.archlinux.org/packages/notes/. but just after that, I have made some changes in the code source and then I removed the version release 1.0.0 you have added and made a new one having the same version. That's why md5sums-checksum reports that there is an error as the code source have been modified.

    the md5sums that was provided to Arch repo is : 63e42d1b8337c2c3f3d4a53754938b3b
    but to be sure that there was no corruption in the package, the package manager check against source=($pkgname-$pkgver.tar.gz::"https://github.com/nuttyartist/notes/archive/v$pkgver.tar.gz")

    So when the release 1.0.0 was changed the two md5sums are not equal anymore --> error.

    so to handle this issue, @gkbrk should provide a new md5sums and regenerate a new package based on the new release 1.0.0 present in the release section in github.

    Ali Diouri
    @theshadowx
    @nuttyartist @konstantingoretzki I think the issue is fixed. @konstantingoretzki could you please check if everything works well now ?
    Ruby Mamistvalove
    @nuttyartist
    Ah ok, seems like he fixed that now.
    Konstantin Goretzki
    @konstantingoretzki
    @theshadowx Works! Thanks a lot ;)
    Ali Diouri
    @theshadowx
    great
    Ruby Mamistvalove
    @nuttyartist
    Let's put Notes on many other people's computers.
    I should take the installer from here, right? @theshadowx
    https://travis-ci.org/nuttyartist/notes/builds/265315114
    Ruby Mamistvalove
    @nuttyartist
    @theshadowx I'm waiting for your approval that this is the right place to take the installers from.
    Ali Diouri
    @theshadowx
    yes
    Ruby Mamistvalove
    @nuttyartist
    Cool
    wait, what package should I put here for linux?
    Ali Diouri
    @theshadowx
    hmm big problem
    Ruby Mamistvalove
    @nuttyartist
    Yes... I though we may resort to 16.04 and write on the website that only this version would get automatic updates...
    Ali Diouri
    @theshadowx
    I think trusty as I think the dependencies will be satisfied
    Ruby Mamistvalove
    @nuttyartist
    But the trusty package has problems with Unity (nad maybe others) and that's where most of the people
    If someone from 16.04
    will be running our trusty package
    what will happen?
    Ali Diouri
    @theshadowx
    he/she will need to install qt5.5.1 packages
    which are not in the base official repo
    Ruby Mamistvalove
    @nuttyartist
    isn't it the default on 16.04?
    Ali Diouri
    @theshadowx
    ouch sorry
    it will be installed a problem
    Ruby Mamistvalove
    @nuttyartist
    What do you mean?
    Ali Diouri
    @theshadowx
    as in the dependencies there ">=" for the version
    Ruby Mamistvalove
    @nuttyartist
    Aren't 16.04 satisfy the trusty dependencies?
    Ali Diouri
    @theshadowx
    yes
    it's the opposite that won't work
    Ruby Mamistvalove
    @nuttyartist
    Ok, ok. SO 16.04, 16.10 17.04 all will run trusty package without a problem?
    Ali Diouri
    @theshadowx
    yes
    to be sure let me do a quick check
    Ruby Mamistvalove
    @nuttyartist
    Cool, I wonder if we install the trusty package on Ubuntu Unity 16.04
    will we have problems with that, can you check that?
    Ali Diouri
    @theshadowx
    I think we won't get the problem seen in 14.04
    Ruby Mamistvalove
    @nuttyartist
    If not, then we go with the trusty, can you test that?
    Ali Diouri
    @theshadowx
    ok
    Ali Diouri
    @theshadowx
    it worked without the both issues (stretching and systemtrayicon)
    Sélection_328.jpg
    Ruby Mamistvalove
    @nuttyartist

    great! So I will put the trusty for in the UPDATES.json file. Yet now what is the reason for us to put versions other than 14.04 on our site if they all going to update to 14.04?

    Since I'm going to sleep now I will publish everything tomorrow which is a still good of a day (traffic wise).

    Ali Diouri
    @theshadowx
    there are two ways to handle this issue, either send the user to the website and then it's up to the user to choose the installer that suit to the OS used or check the version of the OS and then set in the updates.json the link to that is adequate to the os version detected.
    Ruby Mamistvalove
    @nuttyartist
    Of course, the second option is the best one, for the user.
    How hard/easy it is to detect different versions of Ubuntu?
    Ali Diouri
    @theshadowx
    I think there should be a way to detect the version of the OS
    Ruby Mamistvalove
    @nuttyartist
    I think it's important to do that.
    but it was added in Qt5.4