These are chat archives for olistic/warriorjs

30th
Mar 2016
gts00k
@gts00k
Mar 30 2016 07:38
I get an error when I run warriorjs
warriorjs
module.js:327
    throw err;
    ^

Error: Cannot find module './constants/units'
    at Function.Module._resolveFilename (module.js:325:15)
    at Function.Module._load (module.js:276:25)
    at Module.require (module.js:353:17)
    at require (internal/module.js:12:17)
    at Object.<anonymous> (/home/ubuntu/.nvm/versions/node/v4.4.0/lib/node_modules/warriorjs/node_modules/warriorjs-engine/lib/LevelLoader.js:13:23)
    at Module._compile (module.js:409:26)
    at Object.Module._extensions..js (module.js:416:10)
    at Module.load (module.js:343:32)
    at Function.Module._load (module.js:300:12)
    at Module.require (module.js:353:17)
    at require (internal/module.js:12:17)
    at Object.<anonymous> (/home/ubuntu/.nvm/versions/node/v4.4.0/lib/node_modules/warriorjs/node_modules/warriorjs-engine/lib/Level.js:13:20)
    at Module._compile (module.js:409:26)
    at Object.Module._extensions..js (module.js:416:10)
    at Module.load (module.js:343:32)
    at Function.Module._load (module.js:300:12)
Matías Olivera
@olistic
Mar 30 2016 11:27
@gts00k what version of warriorjs are you running? have you tried re-installing it?
gts00k
@gts00k
Mar 30 2016 11:27
@olistic I don't know the version
I just did the npm install
Matías Olivera
@olistic
Mar 30 2016 11:28
Assuming you installed it following the instructions, this should tell you the version: npm list -g warriorjs
gts00k
@gts00k
Mar 30 2016 11:30
my terminal just froze :P
Matías Olivera
@olistic
Mar 30 2016 11:32
still frozen?
gts00k
@gts00k
Mar 30 2016 11:36
1.2.2
now I got
Welcome to WarriorJS
Invalid .profile file. Try changing the directory under which you are running warriorjs.
Matías Olivera
@olistic
Mar 30 2016 11:40
that's because warriorjs uses a .profile file, and you're probably running it from your home directory, where there is a .profile file
gts00k
@gts00k
Mar 30 2016 11:40
what should I do ?
Matías Olivera
@olistic
Mar 30 2016 11:45
cd to another directory
and run warriorjs again
gts00k
@gts00k
Mar 30 2016 11:48
ok done
:D
let's play with some JS
should I update it ?
I saw you have new stuff on github repo
Matías Olivera
@olistic
Mar 30 2016 11:51
@gts00k cool, enjoy! :smile:
gts00k
@gts00k
Mar 30 2016 11:51
?
Matías Olivera
@olistic
Mar 30 2016 11:51
not yet, I updated the engine because I'm working on another project that uses it, but for warriorjs, 1.2.2 is the latest version
gts00k
@gts00k
Mar 30 2016 12:01
cool!
gts00k
@gts00k
Mar 30 2016 18:12
if you guys like AI programming check out codingame.com