Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Jan 08 2019 17:20
    mmagnuski closed #219
  • Oct 12 2018 13:40
    gdkrmr closed #218
  • May 19 2018 02:07
    yehielliv commented #223
  • May 19 2018 02:03
    yehielliv opened #223
  • Feb 10 2018 11:08
    currymj closed #171
  • Jul 25 2016 19:04
    jingpengwu commented #203
  • May 24 2016 12:19
    JonWel closed #183
  • May 24 2016 12:19
    JonWel commented #183
  • Apr 12 2016 11:11
    MikeInnes closed #185
  • Apr 12 2016 11:11
    MikeInnes closed #166
  • Apr 12 2016 11:11
    MikeInnes closed #163
  • Apr 12 2016 11:11
    MikeInnes closed #101
  • Apr 12 2016 11:11
    MikeInnes closed #82
  • Apr 12 2016 11:11
    MikeInnes closed #73
  • Apr 12 2016 11:11
    MikeInnes closed #68
  • Apr 12 2016 11:11
    MikeInnes closed #69
  • Apr 12 2016 11:11
    MikeInnes closed #61
  • Apr 12 2016 11:10
    MikeInnes closed #59
  • Apr 12 2016 11:10
    MikeInnes closed #57
  • Apr 12 2016 11:08
    MikeInnes closed #32
Ismael Venegas Castelló
@Ismael-VC
ok I will compile julia insted of using the one provided by the Arch repos and test again then, thanks!
Mike J Innes
@MikeInnes
@Ismael-VC Great, let me know if you have any other issues!
@Varanas TBH it's a tiny fix, and it might be a few weeks before all the prebuilt copies of Julia are up to date, so it's probably worthwhile
Ismael Venegas Castelló
@Ismael-VC
@one-more-minute Sure I will certainly do so!
Sebastian Pfitzner
@pfitzseb
Oh, and those inline plots are pretty neat! Although I'm getting an AssertionError: path must be a string when using Gadfly (the plot is still displayed). Anyone else seeing that?
Mike J Innes
@MikeInnes
Try Pkg.clone("Gadfly")
I've got a patch for the JS but it's not out yet. If you get the master version you'll get interactivity
Mike J Innes
@MikeInnes
@Ismael-VC If you have problems doing the build then Pkg.update() should fix the Jewel problem for you
Andre Pemmelaar
@Andy-P
I upgraded the light table plugin today. seem to have lost line-wrapping of error msgs. That's making it hard to debug. Did something change? If not, how do we force line-wrapping of error msgs?
Mike J Innes
@MikeInnes
I have changed error messages a little but didn't intend to remove line wrapping. Would it be possible to send me a small snippet that causes this kind of long error message? Or perhaps a screenshot if I've misunderstood you? This should be fixable anyway.
Andre Pemmelaar
@Andy-P
I'm not at the machine that caused the error, but as I recall it was a @test macro used for unit testing. The problem was on a Windows 64 bit machine. I also use light table on a mac. I upgraded that as well, but am not experiencing the problem there. I will send the snippet tomorrow when I get to work.
Try @test 1 == 2 to see if that generates the problem
Mike J Innes
@MikeInnes
Ok, I think I see what you mean – if you evaluate `@test` with a long expression the header trails off the screen, right? (I'm on a mac too, but I can test on Windows though if that's not it). When I can I'll patch this anyway
Ismael Venegas Castelló
@Ismael-VC
@one-more-minute I've just compiled from source, and updted everything, now I get this: http://bit.ly/1x6hsCF
Mike J Innes
@MikeInnes
Not sure about the first one but the second one looks to be from an outdated plugin – do you definitely see Jewel 0.6.3 in the plugin manager?
Ismael Venegas Castelló
@Ismael-VC
julia> pkgs = Pkg.installed(); pkgs["Jewel"]
v"0.6.3"
Ismael Venegas Castelló
@Ismael-VC
ismaelvc@toybox ~ % julia -v
julia version 0.3.0-prerelease+3956
ismaelvc@toybox ~ % pacman -Qs lighttable                                                                   
local/lighttable 0.6.6-2
The Jupiter plugin is also updated.
Andre Pemmelaar
@Andy-P
Screen Shot 2014-07-01 at 7.12.30 AM.png
@one-more-minute I think you have already identified the error, but just in case, here is a screen shot of the problem I described earlier.
Mike J Innes
@MikeInnes
Great, thanks @Andy-P, I'll see what I can do
Andre Pemmelaar
@Andy-P
The problem is now on both my mac and windows after upgrading. Also,,The font for error msg seems to have changed.
Mike J Innes
@MikeInnes
Oh yes, there's a CSS definition in Jewel which shouldn't be there – I'll fix that too
Andre Pemmelaar
@Andy-P
Despite this minor problem, I think lightTables + Julia is brilliant!
Finding it very productive!
Mike J Innes
@MikeInnes
Thanks! I'm glad to hear that you like it
Screenshot 2014-06-30 23.27.42.png
Mike J Innes
@MikeInnes
@Ismael-VC Sorry, I meant to say the plugin manager in LT. It should look something like this – note the Jewel plugin is listed, also at 0.6.3
Apologies if you've already done this, I'm just making extra sure because I'm pretty sure that's the issue (and if it's not I'm not sure what is)
If an update isn't listed try the "refresh plugin list" command
Andre Pemmelaar
@Andy-P
My plug-in looks like this...
Screen Shot 2014-07-01 at 7.38.21 AM.png
And I confirmed I am using the right version of Jewel
Screen Shot 2014-07-01 at 7.40.03 AM.png
but I am still getting
Screen Shot 2014-07-01 at 7.40.52 AM.png
Mike J Innes
@MikeInnes
@Andy-P Woops, I actually meant to ask @Ismael-VC to check his version, but thanks for the confirmation anyway – I'll definitely look at fixing this
Andre Pemmelaar
@Andy-P
Np. Doing this reminded me to point Jewel at the latest Julia install. :smile: )
Mike J Innes
@MikeInnes
I just pushed a new version which should fix this up for you, let me know if there's anything else!
Andre Pemmelaar
@Andy-P
Just updated plugin. Still getting the same no-wrap problem.
Screen Shot 2014-07-01 at 9.35.49 AM.png
Ismael Venegas Castelló
@Ismael-VC
@one-more-minute Ok I got it. Thanks it works now! :smile:
Mike J Innes
@MikeInnes
@Ismael-VC Great!
Mike J Innes
@MikeInnes
@Andy-P That's odd, it works for me (on mac and windows), but I only tested the problem with the header rather than the "while loading" thing, so it may not have that fixed that for some reason – I'll check. Is the header issue looking better? You may also need to restart LT for the changes to take effect if you haven't already.
Andre Pemmelaar
@Andy-P
For me, the "while loading" is the problem as it includes the line number of the error
I don't have any other problems with it
So that's not happening any more?
Sorry I didn't manage to fix this, unfortunately I don't have loads of time to look into it in more detail right now but I will do as soon as I can
Mike J Innes
@MikeInnes
Ok, I think I see what you mean
There might be a quick fix, I'll update later on