Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Jan 08 2019 17:20
    mmagnuski closed #219
  • Oct 12 2018 13:40
    gdkrmr closed #218
  • May 19 2018 02:07
    yehielliv commented #223
  • May 19 2018 02:03
    yehielliv opened #223
  • Feb 10 2018 11:08
    currymj closed #171
  • Jul 25 2016 19:04
    jingpengwu commented #203
  • May 24 2016 12:19
    JonWel closed #183
  • May 24 2016 12:19
    JonWel commented #183
  • Apr 12 2016 11:11
    MikeInnes closed #185
  • Apr 12 2016 11:11
    MikeInnes closed #166
  • Apr 12 2016 11:11
    MikeInnes closed #163
  • Apr 12 2016 11:11
    MikeInnes closed #101
  • Apr 12 2016 11:11
    MikeInnes closed #82
  • Apr 12 2016 11:11
    MikeInnes closed #73
  • Apr 12 2016 11:11
    MikeInnes closed #68
  • Apr 12 2016 11:11
    MikeInnes closed #69
  • Apr 12 2016 11:11
    MikeInnes closed #61
  • Apr 12 2016 11:10
    MikeInnes closed #59
  • Apr 12 2016 11:10
    MikeInnes closed #57
  • Apr 12 2016 11:08
    MikeInnes closed #32
Andre Pemmelaar
@Andy-P
but I am still getting
Screen Shot 2014-07-01 at 7.40.52 AM.png
Mike J Innes
@MikeInnes
@Andy-P Woops, I actually meant to ask @Ismael-VC to check his version, but thanks for the confirmation anyway – I'll definitely look at fixing this
Andre Pemmelaar
@Andy-P
Np. Doing this reminded me to point Jewel at the latest Julia install. :smile: )
Mike J Innes
@MikeInnes
I just pushed a new version which should fix this up for you, let me know if there's anything else!
Andre Pemmelaar
@Andy-P
Just updated plugin. Still getting the same no-wrap problem.
Screen Shot 2014-07-01 at 9.35.49 AM.png
Ismael Venegas Castelló
@Ismael-VC
@one-more-minute Ok I got it. Thanks it works now! :smile:
Mike J Innes
@MikeInnes
@Ismael-VC Great!
Mike J Innes
@MikeInnes
@Andy-P That's odd, it works for me (on mac and windows), but I only tested the problem with the header rather than the "while loading" thing, so it may not have that fixed that for some reason – I'll check. Is the header issue looking better? You may also need to restart LT for the changes to take effect if you haven't already.
Andre Pemmelaar
@Andy-P
For me, the "while loading" is the problem as it includes the line number of the error
I don't have any other problems with it
So that's not happening any more?
Sorry I didn't manage to fix this, unfortunately I don't have loads of time to look into it in more detail right now but I will do as soon as I can
Mike J Innes
@MikeInnes
Ok, I think I see what you mean
There might be a quick fix, I'll update later on
Mike J Innes
@MikeInnes
Ok, with a Pkg.update() you should be golden, let me know if that sorts this out for you
Sebastian Pfitzner
@pfitzseb
It didn't work for me. The box's width is only 500px, but the content will not be wrapped. But you can add word-wrap: break-word; to .julia.error and it will correctly wrap long errors.
Sebastian Pfitzner
@pfitzseb
And I'm not sure that a fixed max-width really is the way to go here. But I don't really have any suggestion... Do you know why something like width: 100% doesn't work?
Mike J Innes
@MikeInnes
Ok, I guess you have a particularly long path with no spaces or something? I didn't know about forcing word wrap like that so I'll have a go with it
I definitely agree that max-width isn't the best solution, but similarly nothing better springs to mind. It's odd that scrolling doesn't work, but since it does work for inline results there must be a way around this – I'll do some digging.
The best thing might be to put the error message itself in a scroll pane
Sebastian Pfitzner
@pfitzseb
Ah, yeah, that was the case (kinda, I just created an artificial error without any spaces to test for that). And I didn't know about that css-property either until I looked for it.
Andre Pemmelaar
@Andy-P
just wanted to confirm that error msg now properly wrap around on win, (haven't tests on OSX yet)
Mike J Innes
@MikeInnes
Great, thanks
Let me know if there's anything else
Andre Pemmelaar
@Andy-P
I have begun using light tables behind a firewall. The plugin approach to installing Jupiter/jewel, etc doesn't work for a number of reason. But I can download zip file directly from github, and other sites. Is there a way to install Jupiter, etc without going through LT's plugin manager?
Mike J Innes
@MikeInnes
Sure, just drop the downloaded folder into the plugins directory. On windows that's
``
C:\Users[YourUserName]\AppData\Local\LightTable
Or on os x
~/Library/Application Support/LightTable/plugins/
Note also that the Jupiter plugin depends on several others (listed in plugin.json) so you'll need to grab them too
Mike J Innes
@MikeInnes
Sorry, that windows path should end in LightTable/plugins. This website is awful on mobile. That should be straightforward but let me know if you have any issues
Andre Pemmelaar
@Andy-P
Thanks. I will try it out
Just to be sure, I just drop the decompressed zip folder from github into the above folders. No need to build anything, right?
BTW, gave a presentation on the many benefits of using Jupiter/jewel at the Tokyo Julia meetup Resulted in this blog post http://qiita.com/chezou/items/5070bde5dc6647e55af3 (Japanese install explanation)
Andre Pemmelaar
@Andy-P
Trying to sell it to my team but our analytics environment is seriously locked down
If I can overcome the install issue, I think it will be a go
Eric West
@edubkendo
ナイス
Mike J Innes
@MikeInnes
That's great! Exactly right, just drop the folders in, no build required (that's all the plugin manager does anyway). At some point I'll make a bundle so that this kind of thing is easier.
Andre Pemmelaar
@Andy-P
FYI, the install procedure you outlined above went smoothly. Lt+jewel running on several PC that are behind a firewall
Mike J Innes
@MikeInnes
Thanks for the update, I'm glad you got it working. I added some notes on doing an offline install to the wiki, but I haven't tried to do this myself so let me know if any steps are missing / not clear.
Mike J Innes
@MikeInnes
I'm on the Yosemite beta and autocomplete is causing me massive performance problems – anyone else seeing this or is it just an OS X issue?
Sebastian Pfitzner
@pfitzseb
Autocomplete seems quite snappy to me (on Windows).
Mike J Innes
@MikeInnes
Odd – it's so bad I had to disable it completely. No idea why it would be any different on Yosemite, but here's hoping it goes away on its own...
Sebastian Pfitzner
@pfitzseb
About the builtinList in julia.js: Should abstract types be added? I think that'd be a nice touch, but maybe there's some resoning against it? If not, I'll add them and submit a PR.
Mike J Innes
@MikeInnes
Honestly I'm not even sure the builtin list needs to exist. What's it supposed to represent? Every type in Base? Just "fundamental" types like Int or String? These aren't really built in / special anyway, so what's the benefit in distinguishing them?
Anyway, you're welcome to send a PR with more types, like I said I don't have a particular opinion on what should/shouldn't be there