These are chat archives for opal/opal

16th
Nov 2014
Elia Schito
@elia
Nov 16 2014 01:23
@ryanstout just pushed to master, should be fixed by opal/opal@578911b
Ryan Stout
@ryanstout
Nov 16 2014 01:57
Awesome, thanks a bunch!
Ryan Stout
@ryanstout
Nov 16 2014 21:18
@elia you around by chance?
Elia Schito
@elia
Nov 16 2014 21:38
yep
Adam Beynon
@adambeynon
Nov 16 2014 21:39
@ryanstout anything I can help with?
Ryan Stout
@ryanstout
Nov 16 2014 21:39
@adambeynon still having a few problems with sourcemaps, but I have the feeling it's related to how I'm mounting the app
Adam Beynon
@adambeynon
Nov 16 2014 21:40
@ryanstout are they coming through at all?
Ryan Stout
@ryanstout
Nov 16 2014 21:40
the map is, but it's not loading the actual .rb files (the urls are wrong)
I think I need to use Rack::Cascade or something to mount it. I'm using app.map '/assets' do ...
which I think is putting it under /assets twice
anyway, I need to just mess with it a bit more on my end :-)
@adambeynon btw, I'll be saying some good things about opal in my rubyconf talk :-)
Adam Beynon
@adambeynon
Nov 16 2014 21:42
@ryanstout elia is the right person to ask, but looking at opal-rails we use Cascade there
Elia Schito
@elia
Nov 16 2014 21:42
@ryanstout cascade seems a good choice
Ryan Stout
@ryanstout
Nov 16 2014 21:42
@elia cool, I think I realized what I'm doing wrong. The only thing that is weird is that I need to serve my own index files, that won't conflict will it?
Elia Schito
@elia
Nov 16 2014 21:44
shold “Cascade” to the next app when finds a 404
Ryan Stout
@ryanstout
Nov 16 2014 21:56
ok, cool
I think I need to just get some time and change around stuff in volt to get it to work :-)