These are chat archives for opal/opal

28th
Mar 2015
Kurtis Rainbolt-Greene
@krainboltgreene
Mar 28 2015 01:27
I'm super interested in getting react.rb into a framework, maybe like Clearwater.
But I want something well defined and composed like ember and ember-cli.
Kurtis Rainbolt-Greene
@krainboltgreene
Mar 28 2015 04:10
@elia If I wanted to use rom-rb in an opal app, a gem that shouldn't have any non-standard API usage or c-extensions, how would I go about doing that?
Elia Schito
@elia
Mar 28 2015 08:26
In MRI you would Opal.use_gem "rom" and then require "Tom" in Opal
Kurtis Rainbolt-Greene
@krainboltgreene
Mar 28 2015 18:36
@elia: As cool as that is it looks like ROM has a dynamic require. Foiled.
Elia Schito
@elia
Mar 28 2015 23:46
@krainboltgreene if you explicitly require the files that would be required by the dynamic require it should work fine (remember to set the dynamic require error level to warning or ignore)
Kurtis Rainbolt-Greene
@krainboltgreene
Mar 28 2015 23:48
@elia: Quite frankly I don't think dynamic requires are really that good an idea anyways. I'm hoping to patch it out.
But thanks for the detail.
Elia Schito
@elia
Mar 28 2015 23:52
Most of them are not really dynamic anyway