These are chat archives for opal/opal

24th
Mar 2017
Mitch VanDuyn
@catmando
Mar 24 2017 21:47
Does anybody know of problems with Opal.use_gem in rails 5.1 ?
I am getting
Gem Load Error is: can't find gem activesupport
Backtrace for gem load error is:
/Users/rmitchellvanduyn/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/opal-0.10.3/lib/opal/paths.rb:48:in `require_paths_for_gem'
/Users/rmitchellvanduyn/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/opal-0.10.3/lib/opal/paths.rb:51:in `block in require_paths_for_gem'
/Users/rmitchellvanduyn/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/opal-0.10.3/lib/opal/paths.rb:50:in `each'
/Users/rmitchellvanduyn/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/opal-0.10.3/lib/opal/paths.rb:50:in `require_paths_for_gem'
/Users/rmitchellvanduyn/.rbenv/versions/2.3.1/lib/ruby/gems/2.3.0/gems/opal-0.10.3/lib/opal/paths.rb:39:in `use_gem'
when I do a Opal.use_gem('mutations') which worked fine in 5.0
Elia Schito
@elia
Mar 24 2017 21:50
Same rubygem version?
Mitch VanDuyn
@catmando
Mar 24 2017 22:27
Yes
Mutations 8.1
Elia Schito
@elia
Mar 24 2017 22:28
Does Opal.use_gem('activesupport') works?
Mitch VanDuyn
@catmando
Mar 24 2017 22:30
I wonder if it's specific to activesupport. Hmmm I'll dig in tonight
I will try that, but u know I'm using Opal active support to plug that hole. Maybe that's the problem
Elia Schito
@elia
Mar 24 2017 22:32
looks like it's looking for mutations' deps