These are chat archives for opal/opal

4th
Jan 2018
Tom Black
@blacktm
Jan 04 2018 01:33 UTC

Hey all! Does Opal work on Windows? I've tried installing in the RubyInstaller 2.5.0 and 2.4.3 environments with no luck. Opening the "Start Command Prompt with Ruby" and running gem install opal gives:

Fetching: opal-0.11.0.gem (100%)
ERROR:  While executing gem ... (Errno::EACCES)
    Permission denied @ rb_file_s_symlink - (./exe, C:/Ruby25-x64/lib/ruby/gems/2.5.0/gems/opal-0.11.0/bin)

For context, I'm using Opal for Ruby 2D.

Jamie Gaskins
@jgaskins
Jan 04 2018 04:35 UTC
@blacktm Looks like it might be a permissions issue with the gems directory. There's no native extension to compile and I don't believe the gem includes post-install scripts or anything like that that could fail during a gem install.
Tom Black
@blacktm
Jan 04 2018 05:42 UTC
Hmm, gem dir is writable (fresh install of Windows, RubyInstaller). Installing previous version works (gem install opal -v 0.10.5), but 0.11.0 fails with the error above. This symbolic link was added in the new release — not sure what it's for, but maybe that's causing it to fail. Has anyone gotten 0.11 to install on Windows? Could also be something specific to the RubyInstaller 2.4.X and higher.
Jamie Gaskins
@jgaskins
Jan 04 2018 05:47 UTC
Ooooh, I see.
Yeah, now that you mention it, that's the error it's getting: Permission denied @ rb_file_s_symlink
I hadn't thought about it being a symlink issue on Windows.
Elia Schito
@elia
Jan 04 2018 16:28 UTC
@blacktm looks related to rubygems rather than opal itself, should work fine on windows as each version is tested automatically with appveyor https://ci.appveyor.com/project/elia/opal/branch/master
@blacktm this seems the same issue, maybe one of the proposed solutions works: https://stackoverflow.com/questions/29275904/installing-ruby-gems-permission-denied-issue-on-windows-7
Tom Black
@blacktm
Jan 04 2018 21:23 UTC

@elia Oh wow, didn't know there was a CI for Ruby on Windows — will have to try it out for Ruby 2D.

Ok, looking at your CI config, it's using ruby_version: '23', which resolves to ruby 2.3.3p222, which uses the old RubyInstaller. My suspicion is that Opal fails to install on Ruby 2.4 and higher using the new RubyInstaller2 (has anyone tried it?), which has been re-architected to use MSYS2, gets rid of the DevKit, simplifies a bunch of stuff.

I'd suggest adding ruby_version: '24' (latest version on AppVeyor) to the build matrix to test with future versions of Ruby and the RubyInstaller. Would it be cool if I opened a PR?

Elia Schito
@elia
Jan 04 2018 21:37 UTC
@blacktm would be super cool! 😎
Tom Black
@blacktm
Jan 04 2018 21:40 UTC
@elia Sweet, will get to it.