These are chat archives for opal/opal

May 2018
Mitch VanDuyn
May 09 2018 02:01
what is the situation on opal-jquery? currently we have to do this: gem "opal-jquery", git: "", branch: "master" otherwise there is a dependency mismatch between opal-rails, opal, and opal-jquery.
for example
    hyperloop was resolved to 1.0.0.lap28, which depends on
      opal-rails (~> 0.9.4) was resolved to 0.9.4, which depends on
        opal-jquery (~> 0.4.0) was resolved to 0.4.0, which depends on
          opal (< 0.9.0, >= 0.7.0)
Mitch VanDuyn
May 09 2018 14:33
May 09 2018 14:53
it's also theoretically possible for you to build your dependencies directly into your gem ( which would sidestep the whole "can't include a git branch as a gemspec dependency" issue
but i think the only true and proper answer is for the the dependency conflict to be resolved on the opal side.
Mitch VanDuyn
May 09 2018 15:00
@eiko yeah I don't know what the problem is actually the code is sitting there on master ready to go. @elia made the changes October 6 last year ?!?
May 09 2018 15:04
i'm not sure! when i started working with opal, i got the impression that opal-jquery was being deprecated in favor of opal-browser. but of course that doesn't help if opal-rails itself depends on opal-jquery.
i'm sure elia will be able to bump the newest opal-jquery when he's available
G. Gibson
May 09 2018 16:22
I use both opal-browser for some classes, opal-jquery for other things
I hope opal-jquery isn't deprecated - it is darn handy I've found