These are chat archives for opal/opal

4th
Oct 2018
Hadasa Vengrover
@HadasaGett
Oct 04 2018 08:38
@catmando
Yes. I'm using Rails.
Actually it's a gem for calculations and there is no views/client side code.
And I want to convert the Rspecs that test the calculations code.
Mitch VanDuyn
@catmando
Oct 04 2018 08:39
@HadasaGett - confused. if there are no views/client side how are you using Opal :-)
ahh I see... the gem itself is opal
yes then hyperspec may be perfect for you. We use it for all the hyperstack code
which are just a collection of gems - so I think the same situation.
Hadasa Vengrover
@HadasaGett
Oct 04 2018 08:43
@catmando if no views in my code, do I will need to install those:
selenium, poltergeist and firefox version 46.0.1
?
Mitch VanDuyn
@catmando
Oct 04 2018 08:45
@HadasaGett we are switching to new name/repo. Use this branch / gem version 0.99 https://github.com/hyperstack-org/hyperstack/tree/hyperloop-legacy
gem hyper-spec should install v 0.99 which is latest
@HadasaGett just sent private IM here https://gitter.im/HadasaGett