These are chat archives for openseadragon/openseadragon

13th
Nov 2014
Mark Salsbery
@msalsbery
Nov 13 2014 01:25
@iangilman dragging outside the document element, dragging stops.
Ian Gilman
@iangilman
Nov 13 2014 17:09
@msalsbery I assume that's the result of #481?
Is there a better way to fix that issue?
Mark Salsbery
@msalsbery
Nov 13 2014 18:33
@iangilman I sure hope so ;) On it...
Ian Gilman
@iangilman
Nov 13 2014 18:33
Awesome. Thank you!
Ian Gilman
@iangilman
Nov 13 2014 21:13
@msalsbery are you also looking into #502?
Dominik Picheta
@dom96
Nov 13 2014 22:20
Hey @iangilman. I am trying to work out a navigator bug where the navigator disappears under a very high zoom when you rotate the image. I came up with a little sample which reproduces it, think you could take a look and maybe tell me what I should be looking at to fix it?
*the image in the navigator disappears
Ian Gilman
@iangilman
Nov 13 2014 22:21
Sure.
BTW, I've done some navigator work in the new collections branch... don't know if I touched that issue though.
Dominik Picheta
@dom96
Nov 13 2014 22:23
@iangilman I don't suppose I can send files through gitter?
Ian Gilman
@iangilman
Nov 13 2014 22:24
I have no idea!
Possibly?
You can certainly send links...
Or you can email me: ian@iangilman.com
Dominik Picheta
@dom96
Nov 13 2014 22:26
Ahh, cool. I'll email it to you.
@iangilman sent
Ian Gilman
@iangilman
Nov 13 2014 22:27
Cool... I'll take a look.
Dominik Picheta
@dom96
Nov 13 2014 22:28
Just press the "Perform tests" link and look at the navigator.
It will take a couple of seconds but the navigator will disappear for some time.
It's easy to reproduce on a tablet where you can pinch rotate but I figured it would be nice to reproduce programmatically.
Dominik Picheta
@dom96
Nov 13 2014 22:35
Anyway, please let me know what you can about which piece of code I should look at to fix it.
I'll talk to you later.
Ian Gilman
@iangilman
Nov 13 2014 22:37
Yup, looks like it's fixed in #446
@dom96 ^
Dominik Picheta
@dom96
Nov 13 2014 22:37
Awesome, i'll take a look at that :D
Ian Gilman
@iangilman
Nov 13 2014 22:37
I just dropped in that version and didn't get the missing images.
Dominik Picheta
@dom96
Nov 13 2014 22:38
Great.
Ian Gilman
@iangilman
Nov 13 2014 22:38
I believe the issue is a tile collision bug, where the cache was sometimes dropping tiles incorrectly.
Dominik Picheta
@dom96
Nov 13 2014 22:39
I see. Thank you for taking a look.
Ian Gilman
@iangilman
Nov 13 2014 22:40
This is the actual commit, FYI: openseadragon/openseadragon@8641279
Not that you could cherry-pick that out. Actually, I'd be delighted if you gave #446 a try and let me know if you find any issues.
Dominik Picheta
@dom96
Nov 13 2014 22:41
will do
see you later
Ian Gilman
@iangilman
Nov 13 2014 22:41
Cheers!
sbansford
@sbansford
Nov 13 2014 22:49
Thanks @iangilman. I thought it was but just in case I missed something in the source code. I've been using the imaginehelperplugin which is a great help. Many thanks.
Ian Gilman
@iangilman
Nov 13 2014 23:03
@sbansford awesome... @msalsbery made imagehelperplugin.
Mark Salsbery
@msalsbery
Nov 13 2014 23:06
Cool @sbansford ! I haven't updated the plugins in quite a while but I'm freshening them up now. Please let me know if there's anything broken or if there's any features you'd like to see (or you can add them yourself of course - I'm open to pull requests :))