These are chat archives for openseadragon/openseadragon

30th
Mar 2015
Tomasz Neugebauer
@photomedia
Mar 30 2015 16:29
I just tested it on Windows 7, and the same problem exists there, so it's not just a Windows 8.1 issue... why would the full-screen fail, just from localhost?
Antoine Vandecreme
@avandecreme
Mar 30 2015 17:03
@photomedia chrome doesn't allow that except if you start it with the --disable-web-security option
regarding Firefox, it should work. What you are describing looks odd.
Ian Gilman
@iangilman
Mar 30 2015 17:04
@photomedia Very strange! I just tested an OpenSeadragon on my localhost in Mac Firefox and Mac Chrome, and it worked just fine. This doesn't rule out the possibility it's a Windows thing. I guess you might try making a simple localhost website that just uses the standard full screen API to see if it's an OSD issue.
@avandecreme I don't think I've fiddled with the --disable-web-security option on my Chrome
Antoine Vandecreme
@avandecreme
Mar 30 2015 17:06
hum, strange last time I checked chrome didn't like Ajax requests to localhost without that switch
Ian Gilman
@iangilman
Mar 30 2015 17:07
I never had that problem
How do I test to see if I have that switch set?
Antoine Vandecreme
@avandecreme
Mar 30 2015 17:09
I don't know :) But I hope you don't have it enabled by default!
Ian Gilman
@iangilman
Mar 30 2015 17:09
Indeed :)
Thanks for the patch, btw! I'll take a look at it today
Antoine Vandecreme
@avandecreme
Mar 30 2015 17:11
Great, it is really just a demo to start the discussion. The code is still very hacky.
Ian Gilman
@iangilman
Mar 30 2015 17:12
Fair enough. Still, it's an important feature, so it's good to get it rolling
Ian Gilman
@iangilman
Mar 30 2015 22:02
@photomedia Finally got around to fixing that keyboard page thing: openseadragon/site-build#68 thanks again for mentioning it!