These are chat archives for openseadragon/openseadragon

31st
Mar 2016
sickrandir
@sickrandir
Mar 31 2016 11:08
@avandecreme thanx! it worked perfectly for proportions and positions of images. However, adding 'width' parameters to all the images introduced a problem. Controls don't work as expected anymore. The image opens as expected, then if pressing zoom-in or clicking it goes immediately to maximum zoom. Zoom-out doesn't seem to work. Only the home button restore the initial appearance. You can see it here: http://differenthood.duckdns.org/rhythm/configurator.html
sickrandir
@sickrandir
Mar 31 2016 11:16
here is the same example just without the width parameters on the two images (wrong proportions but working controls): http://differenthood.duckdns.org/rhythm/configurator2.html
Antoine Vandecreme
@avandecreme
Mar 31 2016 13:57
I suspect something else is going here.
What you can try, is set the width of the first image to 1 (so the default functionality) and set the width of the second one to secondWidth/firstWidth
^ @sickrandir
sickrandir
@sickrandir
Mar 31 2016 14:06
yes it works!
I also had to normalize position x,y in the same way
but in this way position, proportions and controls are ok!
as usual, thanx a lot
Antoine Vandecreme
@avandecreme
Mar 31 2016 14:09
Hum, weird. @iangilman is it expected?
Ian Gilman
@iangilman
Mar 31 2016 16:24
@avandecreme Definitely not. I'm pretty sure I've done that sort of thing and not had that reaction. @sickrandir The links about aren't loading at the moment... do you still have a version that has the issue visible?
sickrandir
@sickrandir
Mar 31 2016 16:25
@iangilman yes
give me 2 minutes
Ian Gilman
@iangilman
Mar 31 2016 16:30
No rush :)
sickrandir
@sickrandir
Mar 31 2016 16:39
here is fine using avandecreme suggestion: http://differenthood.duckdns.org/rhythm/configuratorok.html
Ian Gilman
@iangilman
Mar 31 2016 16:50
@sickrandir Okay, it doesn't look like there's a problem with zooming, per se... it's just that you start out already zoomed in
Also the sizing isn't quite right, because the handle doesn't line up with the bag
Anyway, doesn't look like an issue with OSD, and since you got it working, sounds like we're all good. Thanks for giving me a chance to take a look!
(as for why you start out already zoomed in, looks like you're using a min zoom... that may explain it)
Antoine Vandecreme
@avandecreme
Mar 31 2016 17:28
@iangilman I think the overlay refactoring is coming along. I still need to fix the changelog and add unit tests with rotation.
Ian Gilman
@iangilman
Mar 31 2016 17:32
@avandecreme Right on. Feeling cleaner?
Antoine Vandecreme
@avandecreme
Mar 31 2016 18:32
A bit. Might still be difficult to understand at first sight though.
Ian Gilman
@iangilman
Mar 31 2016 18:41
Fair enough. I like that you've been adding comments. Maybe more are needed?
Antoine Vandecreme
@avandecreme
Mar 31 2016 19:00
Yeah, I will try
Ian Gilman
@iangilman
Mar 31 2016 19:01
:)