These are chat archives for opentk/opentk

11th
Nov 2017
VperuS
@VPeruS
Nov 11 2017 14:02
Proposal: create new branch for netstandard
Rosen Iliev
@winterhell
Nov 11 2017 14:04
Question - I read net core and net standard 2.0 are only being able to take net framework 4.5 code or higher
That doesnt make much sense, since framework 4.5 can use all the features written in 2.0
What is going on? Does that just mean you have to flip the switch to target 4.5?
VperuS
@VPeruS
Nov 11 2017 14:07
2.0(framework?) can use all features from 4.5?
Rosen Iliev
@winterhell
Nov 11 2017 14:07
no, the opposite thing
you can write for framework 2.0, and tell it to target 4.5 and it'll just work
or heck you can write a 4.5 program and call a 2.0 dll
VperuS
@VPeruS
Nov 11 2017 14:13
Yeah, after you mention(framework4.5 is superset of framework2.0), it may be some changes in dll format that dotnet team don't want to maintain
chatbridge
@chatbridge
Nov 11 2017 14:15
(Discord) Jax (Nihlus): It has to do with the available API
(Discord) Jax (Nihlus): The API in a library has to target a strict subset of the application's target