Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
Pranshu Srivastava
@PranshuSrivastava
for using yarn
2 replies
Akshay Nandwana
@anandwana001:matrix.org
[m]
Any auto formatter suggestion for python code so that it can fix all the line breaks, indentation, extra whitespace issues?
2 replies
Md Shahbaz Alam
@SAEb-ai
ask.JPG
Can anyone please explain how is the views list getting updated whenever a user visits it?
Aryaman Gupta
@atpug22

Hello Devs,

Hope you are well. We are excited that a Tech Talk on Frontend Testing is being organized today i.e. 28st August (Saturday) - 22:30 IST (17:00 UTC).

The talk would cover the following points:

  • Writing robust frontend unit tests
  • Covering various scenarios in the code (testing the code thoroughly instead
    of just covering lines)
  • Different scenarios that are difficult to test
  • Avoiding flakes
  • Identifying and resolving flakes if you get any

After the talk, you will get a brief idea about Frontend Unit testing, which would be helpful to you, as you'll have to write Frontend Tests for your future contributions to Oppia.

Link for the event: https://meet.google.com/nuj-jate-rfz

Hoping to see you all there! If you have any questions/suggestions you can add them to this Slido Link: https://app.sli.do/event/bxrnwack

Aryaman Gupta
@atpug22
@/all
Pranshu Srivastava
@PranshuSrivastava
image.png
Pranshu Srivastava
@PranshuSrivastava
Hey, can somebody tell me how to fix this error? answer is clearly an object but it says that object does not have a property of error. Apart from object I don't see any type that can be assigned to it
5 replies
Aryaman Gupta
@atpug22

Hello Devs,

Hope you are well. We are excited that a Tech Talk on Frontend Testing is being organized today i.e. 28st August (Saturday) - 22:30 IST (17:00 UTC).

The talk would cover the following points:

  • Writing robust frontend unit tests
  • Covering various scenarios in the code (testing the code thoroughly instead
    of just covering lines)
  • Different scenarios that are difficult to test
  • Avoiding flakes
  • Identifying and resolving flakes if you get any

After the talk, you will get a brief idea about Frontend Unit testing, which would be helpful to you, as you'll have to write Frontend Tests for your future contributions to Oppia.

Link for the event: https://meet.google.com/nuj-jate-rfz

Hoping to see you all there! If you have any questions/suggestions you can add them to this Slido Link: https://app.sli.do/event/bxrnwack

@/all Reminder

Pranshu Srivastava
@PranshuSrivastava
./.python-version is not listed in the .github/CODEOWNERS file.
Can somebody tell me where do i need to list my python-version in the file
11 replies
Aniketh Varma
@aniketh-varma
image.png
5 replies
I am trying to install oppia on windows 10, but I am getting these errors. Can someone help me fix these errors.
yuktibagrodia
@yuktibagrodia
Capture.PNG
3 replies
yuktibagrodia
@yuktibagrodia
Capture.PNG
5 replies
Not going ahead .....30 mins...
after running python -m scripts.start
Vivek Jaiswar
@Narcos101
Hello everyone! I am a pre-final year university student. I want to contribute towards the growth of oppia can someone guide me!
Aryanm465
@Aryanm465
Hello everyone! I am a 2nd year university student. I want to contribute towards the growth of oppia can someone guide me
Nikhil
@Nik-09
Hello @Narcos101 and @Aryanm465 welcome to Oppia, you can follow the link as given in the nav-bar of the group for getting started.
Feel free to post here any of your queries.
Thanks.
Mahendra
@mahendra1290
Screenshot from 2021-09-02 15-42-24.png
I am getting this error during pushing my changes
3 replies
Vishal Teotia
@vashuteotia123
image.png
can someone help with this ?
do we have the future package from pip or the is it a custom package ?
Vishal Teotia
@vashuteotia123
because I tried to install with pip and I got some error regarding NoModuleFound: _ctypes. Is _ctypes is sub-package of any other package ?
5 replies
Vishal Teotia
@vashuteotia123
image.png
this is what I'm getting when installing future inside my virtualenv
10 replies
Mohd salman ansari
@salmanansari14
can anyone guide me that how can i run its code
3 replies
please help me
ruinan-liu
@ruinan-liu

Hey team!
I was working the backend linter fix(oppia/oppia#11496) and I was able to successfully run the test prompt python -m scripts.run_custom_eslint_tests

---------------------------
All tests passed
---------------------------

so I think it means that the linter test is working as intended. However when I was later running the three python command

python -m scripts.linters.pre_commit_linter --path core/tests/protractor
python -m scripts.linters.pre_commit_linter --path core/tests/protractor_desktop
python -m scripts.linters.pre_commit_linter --path core/tests/protractor_utils
I received an error message like this
./.python-version is not listed in the .github/CODEOWNERS file.
./package-lock.json is not listed in the .github/CODEOWNERS file.
I am not sure I am supposed to fix those two bugs as it seems not related to linter check?
6 replies
Any guidance will be very appreciated
Vishal Teotia
@vashuteotia123
Can anyone please help me with the error, it has been two days since I'm stuck at the same thing.
8 replies
patrycjapraczyk
@patrycjapraczyk

After upgrading Python version to 3.7.10 I am getting this error when trying to run 'python3 -m scripts.start'. Does anyone know why this could be? Thank you for your help!

image.png

11 replies
Mahendra
@mahendra1290
@DubeySandeep please review my oppia/oppia#13772 so that it can be merged.
2 replies
Shivam
@heyimShivam

Hey coders, I am new to the open-source world, while installing the Oppia project in my local environment I am getting this error after using the command python -m scripts.start. can anyone help me to resolve this issue?

-> python -m scripts.start

---log---

some xyz Text

toml==0.10.2

# via pytest

typing-extensions==3.7.4.3

# via
#   apache-beam
#   importlib-metadata

uritemplate==3.0.1

# via google-api-python-client

urllib3==1.26.6

# via
#   -r requirements.in
#   elasticsearch
#   requests

webapp2==3.0.0b1

# via -r requirements.in

webencodings==0.5.1

# via
#   -r requirements.in
#   bleach
#   html5lib

webob==1.8.7

# via webapp2

zipp==3.4.1

# via importlib-metadata

The following packages are considered to be unsafe in a requirements file:

setuptools

All third-party Python libraries are already installed correctly.
Downloading and unzipping file bootstrap-4.3.1-dist to ./third_party/static ...
Traceback (most recent call last):
File "/home/shivam/.pyenv/versions/3.7.10/lib/python3.7/runpy.py", line 193, in _run_module_as_main
"main", mod_spec)
File "/home/shivam/.pyenv/versions/3.7.10/lib/python3.7/runpy.py", line 85, in _run_code
exec(code, run_globals)
File "/home/shivam/Desktop/opensource/oppia/scripts/start.py", line 31, in <module>
install_third_party_libs.main()
File "/home/shivam/Desktop/opensource/oppia/scripts/install_third_party_libs.py", line 251, in main
install_third_party.main(args=[])
File "/home/shivam/Desktop/opensource/oppia/scripts/install_third_party.py", line 457, in main
download_manifest_files(MANIFEST_FILE_PATH)
File "/home/shivam/Desktop/opensource/oppia/scripts/install_third_party.py", line 331, in download_manifest_files
dependency_zip_root_name, dependency_target_root_name)
File "/home/shivam/Desktop/opensource/oppia/scripts/install_third_party.py", line 133, in download_and_unzip_files
python_utils.url_retrieve(source_url, filename=TMP_UNZIP_PATH)
File "/home/shivam/Desktop/opensource/oppia/python_utils.py", line 409, in url_retrieve
return urlrequest.urlretrieve(source_url, filename=filename)
File "/home/shivam/.pyenv/versions/3.7.10/lib/python3.7/urllib/request.py", line 247, in urlretrieve
with contextlib.closing(urlopen(url, data)) as fp:
File "/home/shivam/.pyenv/versions/3.7.10/lib/python3.7/urllib/request.py", line 222, in urlopen
return opener.open(url, data, timeout)
File "/home/shivam/.pyenv/versions/3.7.10/lib/python3.7/urllib/request.py", line 531, in open
response = meth(req, response)
File "/home/shivam/.pyenv/versions/3.7.10/lib/python3.7/urllib/request.py", line 641, in http_response
'http', request, response, code, msg, hdrs)
File "/home/shivam/.pyenv/versions/3.7.10/lib/python3.7/urllib/request.py", line 563, in error
result = self._call_chain(args)
File "/home/shivam/.pyenv/versions/3.7.10/lib/python3.7/urllib/request.py", line 503, in _call_chain
result = func(
args)
File "/home/shivam/.pyenv/versions/3.7.10/lib/python3.7/urllib/request.py", line 755, in http_error_302
return self.parent.open(new, timeout=req.timeout)
File "/home/shivam/.pyenv/versions/3.7.10/lib/python3.7/urllib/request.py", line 531, in open
response = meth(req, response)
File "/home/shivam/.pyenv/versions/3.7.10/lib/python3.7/urllib/request.py", line 641, in http_response
'http', request, response, code, msg, hdrs)
File "/home/shivam/.pyenv/versions/3.7.10/lib/python3.7/urllib/request.py", line 569, in error
return self._call_chain(args)
File "/home/shivam/.pyenv/versions/3.7.10/lib/python3.7/urllib/request.py", line 503, in _call_chain
result = func(
args)
File "/home/shivam/.pyenv/versions/3.7.10/lib/python3.7/urllib/request.py", line 649, in http_error_default
raise HTTPError(req.full_url, code, msg, hdrs, fp)
urllib.error.HTTPError: HTTP Error 403: Forbidden

5 replies
Vishal Teotia
@vashuteotia123
image.png
Vishal Teotia
@vashuteotia123
Can anyone explain to me what's going wrong?
Vishal Teotia
@vashuteotia123
image.png
Can someone help me out point the mistake I'm doing, I was writing the spec.js file for my lint check.
5 replies
Shiqi Wu
@sophiewu6
Screen Shot 2021-09-06 at 11.38.34 AM.png
Is anyone else's frontend tests also failing? The errors are not relevant to my changes, and I have tested it on the develop branch.
3 replies
Mahendra
@mahendra1290

Not able to push changes to branch can anybody help?

Screenshot from 2021-09-07 17-39-25.png

3 replies
Shivam Jha
@ShivamJhaa
Can anyone help me!
7 replies
Screenshot from 2021-09-08 15-21-19.png
Why push is not working further
ruinan-liu
@ruinan-liu
Hey Team,
I was working on adding the no .filter() linting rule and although it passes the python -m scripts.run_custom_eslint_tests test (Which means the lint I wrote is accurate?), it was showed error on the check python -m scripts.linters.pre_commit_linter --path core/tests/protractor_utils. It verified that some files in protractor_utils directory is using the .filter() function. Do we have an alternative for .filter()? And as part of the PR, should I also fix the files in /tests/protractor_utils?
Any guidance will be much appropriated.
Thanks Team!
2 replies
Mahendra
@mahendra1290

Screenshot from 2021-09-09 15-11-14.png

fron-tend tests failing while pushing can anybody help. I also tried to run tests on develop branch head these are also failing there

1 reply