Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • 17:45
    oppiabot[bot] assigned #14129
  • 17:45
    oppiabot[bot] commented #14129
  • 17:45
    oppiabot[bot] labeled #14129
  • 17:45
    oppiabot[bot] commented #14129
  • 17:45
    oppiabot[bot] unassigned #14129
  • 17:08
    oppiabot[bot] commented #14130
  • 17:08
    oppiabot[bot] unassigned #14130
  • 16:24
    CircleCI success: oppia build (#128178) in https://github.com/oppia/oppia
    • done
      (7b7f07c4b1803f56fd634eff588692573ad50811 by heyimShivam)
  • 16:17
    heyimShivam commented #14111
  • 16:16
    oppiabot[bot] unlabeled #14111
  • 16:16
    oppiabot[bot] unlabeled #14111
  • 16:16
    heyimShivam synchronize #14111
  • 16:02
    oppiabot[bot] assigned #14130
  • 16:02
    oppiabot[bot] commented #14130
  • 14:54
    sahiljoster32 commented #10474
  • 14:52
    sahiljoster32 commented #10474
  • 14:51
    CircleCI success: oppia build (#128177) in https://github.com/oppia/oppia
    • done
      (8446c4b0bf1748e83c7cd88e04f03bd806a2126a by heyimShivam)
  • 14:48
    heyimShivam review_requested #14089
  • 14:45
    oppiabot[bot] unlabeled #14089
  • 14:45
    heyimShivam synchronize #14089
Srikanth K B
@srikanthkb
Hi,
Has anyone had the frontend test failing with the above error ?
2 replies
Shivam
@heyimShivam
error.png
while pushing branch to github this error appears
can any one help me with this ?
36 replies
Shivam
@heyimShivam
@U8NWXD
chrome Headless error
Shivam
@heyimShivam
I actually tried 5-6 times
Mahendra
@mahendra1290
okay
Shivam
@heyimShivam
4.png
5.png
1.png
2.png
3.png
0.png
@U8NWXD
Shivam
@heyimShivam
Okay i will try that tomorrow , thanks for your kind help .
Lucifer
@ashish-patwal
Hey guys i am getting these lint errors when pushing my code . It seems confusing all the files in scripts dir contains " quotes instead of ' quotes , yet it is particularly pointing errors to my modified files . I wanted to confirm if the linters have been updated for python , and we are using PEP8 principles from now on ?
Starting Linter....
----------------------------------------
----------------------------------------
05:45:18 FINISHED General Purpose Linter: 0.0 secs
----------------------------------------
----------------------------------------
Tasks still running:
  Custom Lint Checks Manager (started 11:15:18)
  Codeowner Lint Checks Manager (started 11:15:18)
  General Purpose Linter (started 11:15:18)
----------------------------------------
05:45:18 FINISHED General Purpose Linter: 0.0 secs
05:45:18 FINISHED Custom Lint Checks Manager: 0.3 secs
05:45:39 FINISHED Codeowner Lint Checks Manager: 21.8 secs
----------------------------------------
Tasks still running:
  Third Party Python Lint Checks Manager (started 11:15:39)
----------------------------------------
05:45:44 FINISHED Third Party Python Lint Checks Manager: 4.9 secs
----------------------------------------
Please fix the errors below:
----------------------------------------
************* Module scripts.common
scripts/common.py:110:0: C0301: Line too long (88/80) 
scripts/common.py:138:0: C0301: Line too long (83/80) 
scripts/common.py:182:0: C0301: Line too long (86/80) 
scripts/common.py:183:0: C0301: Line too long (82/80) 
scripts/common.py:184:0: C0301: Line too long (84/80) 
scripts/common.py:186:0: C0301: Line too long (88/80) 
scripts/common.py:187:0: C0301: Line too long (81/80) 
scripts/common.py:226:0: C0301: Line too long (81/80) 
scripts/common.py:287:0: C0301: Line too long (81/80) 
scripts/common.py:317:0: C0301: Line too long (84/80) 
scripts/common.py:325:0: C0301: Line too long (84/80) 
scripts/common.py:333:0: C0301: Line too long (87/80) 
scripts/common.py:351:0: C0301: Line too long (86/80) 
scripts/common.py:437:0: C0301: Line too long (84/80) 
scripts/common.py:491:0: C0301: Line too long (87/80) 
scripts/common.py:494:0: C0301: Line too long (81/80) 
scripts/common.py:505:0: C0301: Line too long (84/80) 
scripts/common.py:579:0: C0301: Line too long (86/80) 
scripts/common.py:582:0: C0301: Line too long (83/80) 
scripts/common.py:701:0: C0301: Line too long (84/80) 
scripts/common.py:36:0: C4001: Invalid string quote ", should be ' 
scripts/common.py:36:0: C4001: Invalid string quote ", should be ' 
scripts/common.py:36:0: C4001: Invalid string quote ", should be ' 
scripts/common.py:41:0: C4001: Invalid string quote ", should be ' 
scripts/common.py:42:0: C4001: Invalid string quote ", should be ' 
scripts/common.py:43:0: C4001: Invalid string quote ", should be ' 
scripts/common.py:44:0: C4001: Invalid string quote ", should be ' 
scripts/common.py:45:0: C4001: Invalid string quote ", should be ' 
scripts/common.py:46:0: C4001: Invalid string quote ", should be ' 
scripts/common.py:47:0: C4001: Invalid string quote ", should be ' 
scripts/common.py:48:0: C4001: Invalid string quote ", should be ' 
scripts/common.py:49:0: C4001: Invalid string quote ", should be ' 
scripts/common.py:50:0: C4001: Invalid string quote ", should be ' 
scripts/common.py:51:0: C4001: Invalid string quote ", should be ' 
scripts/common.py:52:0: C4001: Invalid string quote ", should be ' 
scripts/common.py:53:0: C4001: Invalid string quote ", should be ' 
scripts/common.py:54:0: C4001: Invalid string quote ", should be ' 
scripts/common.py:57:0: C4001: Invalid string quote ", should be ' 
scripts/common.py:60:0: C4001: Invalid string quote ", should be ' 
scripts/common.py:63:0: C4001: Invalid string quote ", should be ' 
scripts/common.py:66:0: C4001: Invalid string quote ", should be ' 
scripts/common.py:86:0: C4001: Invalid string quote ", should be ' 
scripts/common.py:87:0: C4001: Invalid string quote ", should be ' 
scripts/common.py:89:0: C4001: Invalid string quote ", should be '
3 replies
Pranshu Srivastava
@PranshuSrivastava
Hey, my PR hasn't been reviewed in a week van someone check it out please? oppia/oppia#13768
7 replies
Nihir Agarwal
@nihirag
Hey everyone! I am currently a pre-final year university student. I want to contribute to the oppia project. Can someone just show me the right direction from where I can start ?
1 reply
Pranshu Srivastava
@PranshuSrivastava
image.png
And can someone help me with this
2 replies
ShivamJhaa
@ShivamJhaa
image.png
I am not able to understand what comment I need to write, as I don't know exactly why the null type is needed here. Can anyone help me with this? Thank you
1 reply
inevitable_VD
@VDliveson
Hi everyone,I am Vanshaj, a second year student and I wish to contribute to Oppia foundation in open-source.Could anyone guide for the same
1 reply
Pranshu Srivastava
@PranshuSrivastava
image.png
Hey I have fetched the latest commits from upstream and .python-version is also listed in gitignore but still I am getting this error
8 replies
Mohith Khatri
@mohithk100
Screen Shot 2021-09-16 at 8.56.10 PM.png
6 replies
Screen Shot 2021-09-16 at 8.53.15 PM.png
I am facing these errors while running e2e tests. I am a new contributor to oppia, and am working on issue #10798, can someone help me in resolving these errors ?
Pranshu Srivastava
@PranshuSrivastava
image.png
13 replies
I reinstalled oppia but now some of my front end tests are not passing
Pranshu Srivastava
@PranshuSrivastava
image.png
SanjaySajuJacob
@SanjaySajuJacob
Capture.PNG
2 replies
When I try to push to the develop branch of my fork of oppia, I am getting this issue. Can someone help me out with this?
chirag baid
@chiragbaid7
@chiragbaid7
image.png
After creating schemas and clicking subscribe button I am getting this error. Someone help
Thank you
1 reply
SanjaySajuJacob
@SanjaySajuJacob
Capture2.PNG
10 replies
I am facing this issue when I try to push to my fork of oppia, I think the same issue has been discussed above also. Can someone help me out with this?
chirag baid
@chiragbaid7

@chiragbaid7
image.png
After creating schemas and clicking subscribe button I am getting this error. Someone help
Thank you

can somebody help?

3 replies
JG-11
@JeeveshGarg
Hey, Jeevesh this side, I'm very new contributor in Oppia, trying to Installing Oppia in Windows and WSL2(https://github.com/oppia/oppia/wiki/Installing-Oppia-(Windows;-Python-3)#installing-oppia-in-windows-and-wsl2), in step 4 do i only clone my fork on window or something else, like virtualbox etc.
1 reply
sahil jhangar
@sahiljoster32
Hey, I'm new contributer here, I just want to ask can i take another issue while having one PR opened for previous issue ?
1 reply
Mohd salman ansari
@salmanansari14
Hello
3 replies
SanjaySajuJacob
@SanjaySajuJacob
I am facing an issue, the changes that I have added and committed to my local repository are not visible in my fork after pushing to it. Can someone please tell me why this could be happening?
19 replies
SanjaySajuJacob
@SanjaySajuJacob
1.PNG
2.PNG
SanjaySajuJacob
@SanjaySajuJacob
2.PNG
1.PNG
Nirmit Jain
@nj7
hi (No response Required)
Praneeth
@gp201
@nj7 Hi!
Welcome to Oppia!
JG-11
@JeeveshGarg
I haven't been assigned a mentor yet, I did fill out a survey three days ago and also sent a mail.
1 reply