These are chat archives for orbitjs/orbit.js

24th
Jul 2016
Dan Gebhardt
@dgeb
Jul 24 2016 15:50
we really need to rename fetch / Fetchable since it doesn't align with the global fetch method - the mismatch is just too confusing
esp since I'd like to transition over from jquery.ajax() to fetch soon
(requiring a polyfill as needed)
Mitch Lloyd
@mitchlloyd
Jul 24 2016 18:35
request / Requestable? There is also window.Request for fetch :/
Dan Gebhardt
@dgeb
Jul 24 2016 18:36
@mitchlloyd I actually was just exploring that exact change
Mitch Lloyd
@mitchlloyd
Jul 24 2016 18:37
ajax / Ajaxable :smile:
Dan Gebhardt
@dgeb
Jul 24 2016 18:37
nooooo ;P
I'm not terribly concerned about conflict withwindow.Request, since that's the noun form
Mitch Lloyd
@mitchlloyd
Jul 24 2016 18:38
:+1:
Dan Gebhardt
@dgeb
Jul 24 2016 18:39
It simplifies the logic from the coordinator perspective to group all requests (fetches + updates) together in a single interface
and then provide some sugar on top at the Store layer
so that you can still call update and query and the appropriate requests will be generated
I'm still working through the ramifications ...